You are not logged in.

#1 2007-09-13 18:25:56

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

New fglrx drivers 8.41.7 - package NOT in [extra]

Hi everyone,

Yesterday, AMD's 8.41.7 fglrx drivers, which are a complete rewrite of their codebase which they have spent more than a year of work on, were released.

On their release notes page, they offer the following recommendation:

Caution:     AMD recommends that this release of the AMD Proprietary Linux software driver not be used for distribution packages. Distributors should continue to use the AMD Proprietary Linux driver version 8.40.4

After some thought, I've decided to take this warning to heart, and will not be packaging this version of the drivers for inclusion in the [extra] repo. Instead, I have made packages for these drivers and placed them in my webspace for you to try out.

Please note that the 8.40.4 release will remain in the [extra] repo until AMD releases a new version which they feel is suitable for general use.

To install the packages, grab them from my webspace http://www.archlinux.org/~travis/pkg and install them with pacman -U

Last edited by Cerebral (2007-10-18 12:06:58)

Offline

#2 2007-09-13 19:02:58

Mikko777
Member
From: Suomi, Finland
Registered: 2006-10-30
Posts: 837

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Can't they be put on testing? or even unstable? smile

Offline

#3 2007-09-13 19:09:34

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

They definitely won't go to testing.  Unstable.... I hadn't considered that.  They may end up in unstable, come to think of it, but I'll have to give it more consideration.

-edit- Well, looks like I'm eating my words - into testing they go.

Last edited by Cerebral (2007-09-18 14:44:47)

Offline

#4 2007-09-13 21:38:48

Roberth
Member
From: The Pale Blue Dot
Registered: 2007-01-12
Posts: 891

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

IMO, theyve probably changed their policy to ensure that it works on all distributions, not the commersial ones and therefor need more time to sharpen the driver for distribution packaging, just a though.


Use the Source, Luke!

Offline

#5 2007-09-13 22:28:34

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

I would love to give these drivers a go... Compiz Fusion is pretty bad with the current drivers (on a 2 GHz Core Duo with ATI X1400).


thayer williams ~ cinderwick.ca

Offline

#6 2007-09-13 22:48:02

pebo
Member
Registered: 2007-09-13
Posts: 15

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

8.41.7 simply can't be that much of a PITA like 8.40.4 already is.

Offline

#7 2007-09-14 07:33:02

Bapman
Member
From: Ottawa, Canada
Registered: 2007-09-02
Posts: 140

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

I think this is a wise decision since these drivers should only be installed on R600 based chips (HD2000 series) which had no support on Linux previously... It might work on other cards but many users reported various problems (see http://phoronix.com/forums/showthread.php?t=5193).

But I own an HD2000 card and I can't wait for this package ! Thank you... wink

Offline

#8 2007-09-14 11:42:14

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Adding the packages to [UNSTABLE] now.  Since the unstable repo is defined below the extra repo in pacman.conf by default (where it should be), you'll need to install the packages like so:

pacman -S unstable/fglrx-utils unstable/fglrx unstable/fglrx-ck unstable/fglrx-suspend2

obviously you can omit -ck and -suspend2 if you don't use those kernels.

Offline

#9 2007-09-14 12:35:47

Bapman
Member
From: Ottawa, Canada
Registered: 2007-09-02
Posts: 140

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Thank you very much big_smile !

Offline

#10 2007-09-14 13:54:24

pebo
Member
Registered: 2007-09-13
Posts: 15

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Cerebral wrote:

Adding the packages to [UNSTABLE] now.  Since the unstable repo is defined below the extra repo in pacman.conf by default (where it should be), you'll need to install the packages like so:

pacman -S unstable/fglrx-utils unstable/fglrx unstable/fglrx-ck unstable/fglrx-suspend2

obviously you can omit -ck and -suspend2 if you don't use those kernels.

Awesome -- no more freezes after restarting X on my ThinkPad T42.

Thanks for packaging!

Offline

#11 2007-09-14 15:19:15

roadboy
Member
From: Turkey
Registered: 2007-06-23
Posts: 38
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

8.41.7 sucks with XGL mad


in /dev/null no one can hear your scream...

Turkish Archlinux & KDEmod Mirror Administrator
http://server.elsistech.com/archlinux/ ~ http://server.elsistech.com/archlinux/kdemod/

Offline

#12 2007-09-14 15:36:59

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

roadboy wrote:

8.41.7 sucks with XGL mad

What card do you have?  Note that this release was intended primarily for R500 and R600 cards, and may still be quite buggy with earlier chipsets.

Last edited by Cerebral (2007-09-14 15:37:31)

Offline

#13 2007-09-14 16:05:53

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Thanks for packaging this Cerebral...even though this driver blows (that was to be expected for all non-R600 owners) I'm glad I had the chance to test it out...

My initial findings with an ATI X1400 (R500):

Standard X performance seems to have fairly good 2D performance (same or better than before), however I can't benchmark Half-Life 2 because it now crashes with an "unhandled page fault" on load.  Also the desktop suffers from artifacts after a few minutes of running.  For example, strange black lines and/or boxes appear at various places on the screen, and the mouse cursor transforms into a big ugly block.

Xgl performance on the other hand is abysmal. Everything is dreadfully slow.  Keyboard input is about 2-3 seconds behind real-time, and dragging a window causes it to continue moving a few seconds after letting go.  I can't seem to run Compiz Fusion anymore, due to the GLX_EXT_texture_from_pixmap issues (and the existing workarounds don't work around it smile)

BUT... despite all that, I'm looking VERY forward to 8.42.x (and the subsequent FOSS driver), which is slated to address these issues for the R300-R500 cards and also include the long-awaited AIGLX support.

For anyone interested, here's a couple of links that should shed some light onto the subject:

http://www.phoronix.com/scan.php?page=a … =833&num=1
http://www.phoronix.com/scan.php?page=a … =823&num=1

Last edited by thayer.w (2007-09-14 16:26:58)


thayer williams ~ cinderwick.ca

Offline

#14 2007-09-14 16:08:03

roadboy
Member
From: Turkey
Registered: 2007-06-23
Posts: 38
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Cerebral wrote:
roadboy wrote:

8.41.7 sucks with XGL mad

What card do you have?  Note that this release was intended primarily for R500 and R600 cards, and may still be quite buggy with earlier chipsets.

I have x1600pro neutral


in /dev/null no one can hear your scream...

Turkish Archlinux & KDEmod Mirror Administrator
http://server.elsistech.com/archlinux/ ~ http://server.elsistech.com/archlinux/kdemod/

Offline

#15 2007-09-15 16:11:44

Mikko777
Member
From: Suomi, Finland
Registered: 2006-10-30
Posts: 837

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Well, im happy to report that the driver doesn't blow for me smile

I got radeon9600 pro 128Mb ram.

Infact the performance is noticeably better, prolly like double better than it used to be.
(double fps, games that crawled ie nexuiz work ok now...)

glxgears is same as before tho and i seemed to have a gnome panel crash... might be related to dangerfrom the deep crashing.

tvout seems to work too so all in all a great improvement from ati smile
Anxious for the aigl 8.42 version too if ati could still improve this driver even further smile

Offline

#16 2007-09-15 17:08:08

robotangel
Member
From: cologne/germany
Registered: 2007-08-30
Posts: 63

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Well, I just get a traceback when I want to start xorg with this driver. I have a R380-based-card (X600)... Well, maybe next month...

Offline

#17 2007-09-16 01:42:22

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Heh, my 9600pro was looking pretty good with these drivers, but I just got ugly artifacts in the bottom-right corner, so I guess I didn't luck out.  tongue

By the way, I just realized that the names we have in unstable shouldn't conflict with extra, so I will be renaming these packages shortly (probably to something like fglrx-unstable... or something shorter)  - anyway, as usual I'll keep you informed.

Offline

#18 2007-09-18 07:56:11

JaQoB
Member
Registered: 2007-04-04
Posts: 60

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

Cerebral wrote:

Heh, my 9600pro was looking pretty good with these drivers, but I just got ugly artifacts in the bottom-right corner, so I guess I didn't luck out.  tongue

By the way, I just realized that the names we have in unstable shouldn't conflict with extra, so I will be renaming these packages shortly (probably to something like fglrx-unstable... or something shorter)  - anyway, as usual I'll keep you informed.

Have the exactly same error with my 9800pro

Offline

#19 2007-09-18 11:13:12

thedonvaughn
Member
From: Dallas, TX
Registered: 2007-06-07
Posts: 14
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

I personally noticed a huge difference on my ATI Xpress 200 on board.   It's nearly night and day between this and it's predecessors. Great performance!
bzflag was rockin'!

However, in order to use Compiz with XGL, I had to tell compiz where to find Mesa's libGL.  (As opposed to use ATI's library)

I did this by installing libgl-dri manually into /lib/mesa and just issued:

$ LD_PRELOAD=/lib/mesa/libGL.so.1.2 fusion-icon

It works, but it definitely doesn't play well.   Screen wouldn't refresh properly.  Fragments of Windows would remain after closing/minimizing/moving, and a few other bugs. This was expected though, no harm.

I am very excited with this new driver.  This shows great hope for the future of ATI on linux imho.

Last edited by thedonvaughn (2007-09-18 11:41:37)


Jayson Vaughn

#pacman -R GOP
(1/302) removing John Boehner            [#####################] 100%

Offline

#20 2007-09-18 14:44:14

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

NOTE: Packages moved to testing, as the naming policy with unstable means I shouldn't have uploaded them there in the first place.

To install the packages, enable the testing repo and run pacman -Syu

If you wish to remain with the previous versions and still have testing enabled, add fglrx, fglrx-utils, fglrx-ck, and fglrx-suspend2 to your IgnorePkg line in /etc/pacman.conf

Offline

#21 2007-09-21 17:09:32

adax
Member
Registered: 2006-10-28
Posts: 31

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

hi. i was wondering if this driver would work on an x1950 pro agp card?
my system locks up using 8.40.4 but this one just crashes out with the following message when i try to start x

(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
        compiled for 7.2.0, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0

Backtrace:
0: X(xf86SigHandler+0x84) [0x80d0574]
1: [0xb7f6c420]
2: /usr/lib/xorg/modules//glesx.so [0xb5b9ba24]
3: /usr/lib/xorg/modules//glesx.so [0xb5b9509c]
4: /usr/lib/xorg/modules//glesx.so [0xb5b283fb]
5: /usr/lib/xorg/modules//glesx.so [0xb5b3a196]
6: /usr/lib/xorg/modules//glesx.so [0xb5b273d9]
7: /usr/lib/xorg/modules//glesx.so [0xb5b50c12]
8: /usr/lib/xorg/modules//glesx.so [0xb5b3eebd]
9: /usr/lib/xorg/modules//glesx.so [0xb5b40469]
10: /usr/lib/xorg/modules//glesx.so [0xb5ac76e3]
11: /usr/lib/xorg/modules//glesx.so [0xb5abcf88]
12: /usr/lib/xorg/modules//glesx.so [0xb5abd670]
13: /usr/lib/xorg/modules//glesx.so(esutInit+0x74) [0xb5abc484]
14: /usr/lib/xorg/modules//glesx.so [0xb5ab817b]
15: /usr/lib/xorg/modules//glesx.so(GlesxExtensionInit+0x9b) [0xb5ab73fb]
16: X(InitExtensions+0xb2) [0x80edea2]
17: X(main+0x2af) [0x806e39f]
18: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7d6af90]
19: X(FontFileCompleteXLFD+0xa9) [0x806d8b1]

Fatal server error:
Caught signal 11.  Server aborting

any ideas?

thanks,
ad.

Offline

#22 2007-09-22 10:57:38

tomato
Member
Registered: 2007-09-20
Posts: 72

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

hi adax!

i've been looking for solution for this problem, as i have an exact same card to no avail

here's a big thread (http://phoronix.com/forums/showthread.php?t=5193) but i didn't see any one with AGP version of PCIe card reporting that the drivers are working

it can be caused by similar bug:
AGP versions of X1xxx ATI cards don't work well with anything past 8.35. It's caused by broken detection of card type and all of them are threated as PCIe cards, so AGP mode isn't changed and the cards' bus is working in normal PCI mode giving crappy performance in everything from extensive 3D to HD video.

check for

(II) fglrx(0): PCIE card detected

in your /var/log/Xorg.0.log

Last edited by tomato (2007-09-22 10:59:30)


sorry for my miserable english, it's my third language ; )

Offline

#23 2007-09-23 06:55:33

gkal
Member
From: Athens-Greece
Registered: 2006-09-09
Posts: 38

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

JaQoB wrote:
Cerebral wrote:

Heh, my 9600pro was looking pretty good with these drivers, but I just got ugly artifacts in the bottom-right corner, so I guess I didn't luck out.  tongue

By the way, I just realized that the names we have in unstable shouldn't conflict with extra, so I will be renaming these packages shortly (probably to something like fglrx-unstable... or something shorter)  - anyway, as usual I'll keep you informed.

Have the exactly same error with my 9800pro

2 questions cause I have 9800pro too.

1) Any improvement with the artifacts?

2) Does the tv-out work? Has anyone tried?

Thanks

Offline

#24 2007-09-26 14:52:49

adax
Member
Registered: 2006-10-28
Posts: 31

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

hi tomato.

Thanks for the tip, I found the line you mentioned in my xorg log file so it looks like that is the problem.
I guess i'm gonna have to roll back to the old drivers until this 'issue' is sorted out.
knowing the state of ATI drivers that could be some time next year. sad

Thanks,
ad.

Offline

#25 2007-09-26 16:42:58

tomato
Member
Registered: 2007-09-20
Posts: 72

Re: New fglrx drivers 8.41.7 - package NOT in [extra]

adax wrote:

hi tomato.

Thanks for the tip, I found the line you mentioned in my xorg log file so it looks like that is the problem.
I guess i'm gonna have to roll back to the old drivers until this 'issue' is sorted out.
knowing the state of ATI drivers that could be some time next year. sad

Thanks,
ad.

to my knowledge (i've personally tested only fglrx 8.40 and 8.41, radeonhd /current git/ and avivo /current git/ drivers knowing about the issue) no linux driver properly initializes AGP with this card sad

the radeonhd looks promising though, but it lacks 3d and xvideo also x11 and sdl video is slower than with fglrx (or at most of comparable speed)

i yet have to check how 8.35 (or older) behaves with this gpu but AFAICR there were issues with text console (you couldn't get back to it) but at lest the video was fast

tomato


sorry for my miserable english, it's my third language ; )

Offline

Board footer

Powered by FluxBB