You are not logged in.

#1 2007-09-23 08:21:18

PointOtto
Member
From: Perugia, Italy
Registered: 2006-01-24
Posts: 6

Can't enable macro on Openoffice.org 2.3

I have upgraded openoffice.org to 2.3, and I can't enable macro.

I select Tools->Option->Security and then click on "macro security" button but nothing append.

It seems an arch-related problem, since i tried on Ubuntu (7.10 testing) and appears correctly the dialog that enables macro...

Any advice?

Thank you!

Offline

#2 2007-09-25 11:17:32

giovanni
Developer
From: Livorno, Italy
Registered: 2005-04-07
Posts: 68
Website

Re: Can't enable macro on Openoffice.org 2.3

I've got the same problem here...


Arch Linux Developer
AUR & Pacman Italian Translations

Offline

#3 2007-09-25 12:01:14

bandan
Member
Registered: 2007-07-13
Posts: 8

Re: Can't enable macro on Openoffice.org 2.3

Same Problem. Have you filed a bugreport?

bandan

Offline

#4 2007-09-25 17:15:08

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: Can't enable macro on Openoffice.org 2.3

I've submitted a bug as I have the same problem.


sin² x + cos² x = 1

Offline

#5 2007-09-25 19:26:20

PointOtto
Member
From: Perugia, Italy
Registered: 2006-01-24
Posts: 6

Re: Can't enable macro on Openoffice.org 2.3

danym wrote:

I've submitted a bug as I have the same problem.

Thank you! And I'm happy since I'm not alone! smile

Meanwile are there any work-around?
Someone knows where the macro's setting are saved, so I can force the activation?

Offline

#6 2007-09-25 19:33:50

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

Re: Can't enable macro on Openoffice.org 2.3

the issue is located. i'm working on a fix. see also http://qa.openoffice.org/issues/show_bug.cgi?id=81230

Offline

#7 2007-09-25 22:22:01

giovanni
Developer
From: Livorno, Italy
Registered: 2005-04-07
Posts: 68
Website

Re: Can't enable macro on Openoffice.org 2.3

I solved temporarily with a workaround that I found at http://qa.openoffice.org/issues/show_bug.cgi?id=79885
I added following lines in my ~/.openoffice.org2/user/registry/data/org/openoffice/Office/Common.xcu at the end - 1 line:

<node oor:name="Security">
 <node oor:name="Scripting">
  <prop oor:name="MacroSecurityLevel" oor:type="xs:int">
   <value>1</value>
  </prop>
 </node>
</node>

Now, I can use my personal macros, but dialog window doesn't appear anyway...

Last edited by voidnull (2007-09-25 22:22:34)


Arch Linux Developer
AUR & Pacman Italian Translations

Offline

#8 2007-09-26 21:11:07

PointOtto
Member
From: Perugia, Italy
Registered: 2006-01-24
Posts: 6

Re: Can't enable macro on Openoffice.org 2.3

voidnull wrote:

I solved temporarily with a workaround that I found [...]

It works! Thank You! cool

Last edited by PointOtto (2007-09-26 21:11:28)

Offline

Board footer

Powered by FluxBB