You are not logged in.

#1 2007-10-09 16:21:13

Registered: 2007-10-09
Posts: 3

[SOLVED]: Grub setup issue

Hi Arch community !

First, please excuse my (very) (bad) english...

I'm installing the Arch on a new machine, but in the grub installation step, something is blocking me.

The output says

grub> root (hd0,2)
  Filesystem type unknown, partition type 0x82
grub> setup (hd0,3)
  Error 17: Cannot mount selected partition

Huh... is really 0x82 an unknown type ? There might be a problem somewhere...

So i look my fdisk :

# fdisk -l
/dev/sda1  *        946       25261   195318270    7     HPFS/NTFS
/dev/sda2            1     945    7590681      7    HPFS/NTFS
/dev/sda3      25262       25784    4200997+    82     Linux swap / Solaris
/dev/sda4    25785     48641    183598852+    83     Linux

Partition table entries are not in disk order

I agree with this... one redmond, one redmond/backup, one swap and my /.
And they are not in disk order, ok.

I check my menu.lst with thoses informations :

title           Arch Linux
root            (hd0,2)
kernel          /boot/vmlinuz26 root=/dev/sda3 ro
initrd          /boot/kernel26.img

It seems to me to be all right ! Where is the problem ?

Do you maybe have an idea ?

Last edited by F-eeks (2007-10-09 21:52:59)


#2 2007-10-09 16:59:29

From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: [SOLVED]: Grub setup issue


Type 82 is SWAP, and hd(0, 2) is your swap partition.  Try changing hd(0,2) to hd(0,3), to make it point to /dev/sda4 instead.  I think that'll fix it.

also change root=/dev/sda4

Last edited by peart (2007-10-09 17:00:42)


#3 2007-10-09 17:15:50

Registered: 2007-10-09
Posts: 3

Re: [SOLVED]: Grub setup issue

Thank you peart

You are right, (hd0,2) seems to be my swap partition, and (hd0,3) my ext2 one.

I did the change, bu grub is always trying

root (hd0,2)
setup (hd0,3)

with the same errors... strange

SOLVED : That is allright after re-install...

thank you quand même !

Last edited by F-eeks (2007-10-09 21:52:40)


Board footer

Powered by FluxBB