You are not logged in.

#1 2007-10-14 20:03:08

Registered: 2007-04-21
Posts: 119

Display fails to turn after resume on X41T

I tried following the "Suspend to Disk" guide on the wiki for using suspend2 but I haven't had much luck. The suspend happens quickly but on resume, the screen, at least, doesn't work.  However, I can enter 'reboot' and the computer will reboot. I just can't see what I am typing.

Here is my kernel line:

# (0) Arch Linux
title  Arch Linux
root   (hd0,0)
kernel /vmlinuz26suspend2 root=/dev/sda3 ro resume2=swap:/dev/sda2 vga=773
initrd /kernel26suspend2.img

Here is the output from dmesg | grep -i suspend

Linux version 2.6.22-suspend2 (root@fuckup-ng) (gcc version 4.2.1) #1 SMP PREEMPT Wed Sep 26 22:41:10 CEST 2007
Suspend v2.2.10
Suspend2 Userspace Storage Manager support registered.
Suspend2 Basic User Interface support registered.
Suspend2 Compressor support registered.
Suspend2 Block I/O support registered.
Suspend2 Swap Allocator support registered.
Suspend2 File Allocator support registered.
Suspend2 Userspace UI support registered.
Suspend2: SwapAllocator: Signature found.
Suspend2: Resuming enabled.
Suspend2: Normal swapspace found.

I have added resume and userui to my HOOK's and I am kernel26suspend2.

Switching consoles doesn't help and since I've tried running hibernate only from the console with no X server running.I tried the suggestion from standby problem[SOLVED] but the screen still wouldn't come up.

Thanks for any help you can give me in resolving this issue.

Last edited by kandrews (2007-10-14 22:31:22)


Board footer

Powered by FluxBB