You are not logged in.

#1 2007-10-24 23:24:08

wooptoo
Member
From: UK
Registered: 2007-04-23
Posts: 73
Website

How to enable NX bit/eXecute Disable on Arch?

I have a CPU that supports NX bit / eXecute Disable extension, how can i enable it on arch? do i have to recompile the kernel (i have 2.6.23-ARCH) to use HIGHMEM64 or is there another way?

Thanks

Offline

#2 2007-10-25 00:37:58

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: How to enable NX bit/eXecute Disable on Arch?

If I'm not mistaken - if you're using i686, you indeed have to recompile the kernel with HIGHMEM64 enabled.

Offline

#3 2009-02-24 10:51:03

wooptoo
Member
From: UK
Registered: 2007-04-23
Posts: 73
Website

Re: How to enable NX bit/eXecute Disable on Arch?

I recently switched to Arch64 and NX bit is still not enabled. Why?
I have a 64 bit CPU, NX bit is enabled in BIOS, I can't find HIGHMEM64 in /proc/config.gz, there is also no line in the logs stating that NX is enabled.

Offline

#4 2009-04-24 11:26:57

ckristi
Member
From: Bucharest, Romania
Registered: 2006-11-21
Posts: 225

Re: How to enable NX bit/eXecute Disable on Arch?

You have to add this to your boot line (/boot/grub/menu.lst -> the kernel line):

noexec=on noexec32=on

In love I believe and in Linux I trust

Offline

Board footer

Powered by FluxBB