You are not logged in.

#1 2007-10-25 20:18:34

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

new glibc hits testing

it's a major update - glibc2.7 is now in testing for both architectures. timezone datas has been splitted out into a new tzdata pkg.

give it a try. look out for typical segfault errors when starting programs or found in dmesg. there have also been changes to some locales. file bugs if you find something broken.

Offline

#2 2007-11-10 10:48:34

Sylphe
Member
Registered: 2006-08-28
Posts: 5

Re: new glibc hits testing

[root@Arch2Flo florent]# pacman -Syu
:: Synchronizing package databases...
 perso is up to date
 core is up to date
 extra is up to date
 community is up to date
 unstable is up to date
:: Starting full system upgrade...
:: Replace libgl-dri with extra/libgl? [Y/n] Y
warning: ruby: forcing upgrade to version 1.8.6_p111-3
resolving dependencies... 
error: cannot resolve dependencies for "glibc" ("tzdata" is not in the package set)
error: failed to prepare transaction (could not satisfy dependencies)
:: glibc requires tzdata

I have tested with ftp.archlinux.org without success. I can only do pacman -A tzdata but I don't want hmm.

Offline

#3 2007-11-10 12:22:06

kumico
Member
Registered: 2007-09-28
Posts: 224
Website

Re: new glibc hits testing

please use a mirror ,, not the main repo ,, edit the mirrors in /etc/pacman.d

Offline

#4 2007-11-10 12:27:59

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,178
Website

Re: new glibc hits testing

I'm guessing the mirrors hadn't synced yet because I managed just fine.

kumico wrote:

please use a mirror ,, not the main repo ,, edit the mirrors in /etc/pacman.d

I looks like (s)he was just using it for testing purposes to see if he was dealing with a bad mirror...

Offline

#5 2007-11-10 17:06:21

Sylphe
Member
Registered: 2006-08-28
Posts: 5

Re: new glibc hits testing

Yes, I was using the main repo for testing purposes, but I got the same error. I'm going to wait a bit and maybe add temporarily tzdata to my local repo.

Edit: It's ok now smile

Last edited by Sylphe (2007-11-10 23:32:25)

Offline

Board footer

Powered by FluxBB