You are not logged in.

#1 2007-10-26 13:56:19

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

AMD/ATI fglrx 8.42.3 Experiences

The 8.41 thread is getting a little clogged with 8.42 talk, so I decided to make a new thread for 8.42.3

Phoronix have announced that AMD/ATI have released their new driver, 8.42.3, which I hvae placed into [testing].  Although they haven't updated their site anywhere about this release, I have found release notes for the driver here: http://www2.ati.com/drivers/linux/linux_8.42.3.html

Of note:

New Features

This release of the ATI Catalyst™ Linux driver introduces the following new features:

    * Support for Accelerated Indirect Rendering (AIGLX)
    * Support for X.org version 7.3
    * Products older than Radeon™ HD 2x00 are now supported after being enabled only for testing in 8.41.7
    * A new 3D user interface is now avaialble in the ATI Catalyst™ Control Center-Linux Edition. The new interface allows for the setting of Anti-Aliasing, Anisotropic Filtering, and VSync. Included on the new 3D interface are static preview images showing the visual effects of the different 3D settings

Resolved Issues

The following section provide a brief description of resolved issues with the latest version of the ATI Catalyst™ Linux software suite. These include:

    * Playing videos with TexturedVideo no longer results in stuttering being noticed
    * Corruption is no longer noticed when the Composite extension is enabled
    * Segmentation faults in OpenGL applications and the ATI Catalyst™ Control Center Linux Edition with Rialto-based AGP cards no longer occur
    * Various error messages no longer appear during RPM installation under SuSE 10.2. Further details can be found in topic number 737-29576

Known Issues

The following section provides a brief description of known issues associated with the latest version of ATI Catalyst™ Linux software suite. These issues include:

    * There is no support for video playback on the second head in dual head mode. Further details can be found in topic number 737-26985
    * Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-29578
    * A black screen may be observed on some hardware when switching to the console or leaving the X window system when a Vesa framebuffer console driver is used. Further details can be found in topic number 737-28558
    * The display may go blank with clone/dual/horizontal mode configured or switching VT on systems containing an ATI Radeon 9800 XT product. Further details can be found in topic number 737-29574
    * An error message appears during installation if dash is used as /bin/sh. A topic number is not available for this issue
    * Several distribution-specific packaging scripts are not up-to-date in this release. In particular packaging for 64-bit Ubuntu versions is known to be broken. A topic number is not available for this issue

The release notes state that AMD/ATI still recommend that 8.40.4 remain the version provided by distros - I'd believe it.  I've had graphical corruption, non-working compiz, glibc double-free errors, and general unhappiness with this version of the driver on my dual-head setup with a 9600XT.  However, since it is the first version to support Xorg 7.3 (xorg-server 1.4) it will remain in [testing] with xorg-server.  If Xorg 7.3 moves out of testing, fglrx 8.42 will follow it.

Please use this thread to post your experiences with 8.42.3

Last edited by Cerebral (2007-10-26 14:48:44)

Offline

#2 2007-10-26 14:44:28

BJJ
Member
Registered: 2007-10-23
Posts: 25

Re: AMD/ATI fglrx 8.42.3 Experiences

The only problems I am having with this driver are:
-Compiz fusion crashes when using dual head mode. (works great with pair mode)
-Video playback under compiz fusion doesn't work well.
-Amdcccle doesn't start
-Scrolling in firefox and such, is slow

Does problems aside, I am really pleased with this release!
My desktop cubes rotates smoothly and all the fusion effects work.

Specs:
Xorg-server 1.2
X1400
Core Duo
2GB Ram

Fusion snow effect ftw! wink

Offline

#3 2007-10-26 14:45:01

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 383

Re: AMD/ATI fglrx 8.42.3 Experiences

Hi,
I have installed this version from testing. I have a P4/HT notebook with a dedicated Radeon Mobile 9600 (M10). While I had some issues with the 8.41 version regarding corruption in the lower right corner (and under the mouse), but infrequent and not easily reproducible, I have not experienced this with the 8.42 yet. It seems to work ok so far. I havent tried compiz due to lack of time. While I was downloading the package I also installed xorg-server 1.4 and all that stuff. So all this is running well so far. The Control Center is not working at the moment, can you confirm that?

Cheers,
Blind

Offline

#4 2007-10-26 14:49:45

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

Many people are having issues with amdcccle not displaying any window, although the process starts and runs.

Offline

#5 2007-10-26 15:23:17

MrWeatherbee
Member
Registered: 2007-08-01
Posts: 277

Re: AMD/ATI fglrx 8.42.3 Experiences

I installed and tried the 8.42.3 driver from the testing repo yesterday after having used the Radeon driver for quite some time. While I was getting a very substantial increase in glrxgears and Compiz-Fusion benchmarking, the following (common) real-world issues forced me back to the Radeon driver for now:

- DVD video flickering and stuttering with Compiz-Fusion
- DVD video color inversion with Gnome + XFWM4
- scrolling in Firefox created artifacts and was not smooth (worsens with increased scroll speed)
- amdcccle doesn't start (or perhaps the GUI just wasn't visible ... I neglected to check)

Thing(s) that improved:

- Playback of video files (*.flv, *.wmv, *.mpg, etc) in various players (xine, mplayer. vlc) improved. With the Radeon driver, video will sometimes go black when moving (or re-sizing) the playback window. Video can always be recovered by slightly moving the window, and once the window is left undisturbed, no issues occur. However, with the fglrx 8.42.3 driver, the playback windows can be moved or resized without ever experiencing the temporary black-outs ... even with Compiz-Fusion running.

Anyway, the trade-offs were too great with fglrx 8.42.3 versus the Radeon open-source driver, so I'll be waiting for the next release from ATI.

Thanks for all your efforts, Cerebral.

---
Tested with:
- ATI Radeon 9600 XT
- xorg-server 1.2.0-5
- Compiz-Fusion (git from nesl's repo)
- Kernel 2.6.23

Offline

#6 2007-10-26 15:32:21

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: AMD/ATI fglrx 8.42.3 Experiences

How about 64bit? It seems that 32bit gets all the attention. If you could point me to the pkgbuild that would be great.

Offline

#7 2007-10-26 15:38:05

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

The files are located here in CVS:

http://cvs.archlinux.org/cgi-bin/viewcv … ag=TESTING

I'd love to hear some 64-bit reports.  One of the reasons AMD/ATI didn't include kernel 2.6.23 support in this release was supposedly problems with 64-bit, so anyone willing to report on this would be awesome.

Offline

#8 2007-10-26 15:48:59

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: AMD/ATI fglrx 8.42.3 Experiences

Thanks. I'm not currently on my 64bit computer, but I'll get to it when it's available.

Offline

#9 2007-10-26 16:08:39

quex
Member
Registered: 2007-10-05
Posts: 4

Re: AMD/ATI fglrx 8.42.3 Experiences

I'm running a 2.6.23-kamikaze kernel with 8.42.3 running a Mobility X1400.

I can confirm that the amdcccle does not open a window although the process does execute.  AIGLX and video playback work fine as far as I can tell, and I'm not having any problems with slow scrolling.  However, at least in Firefox, middle-clicking to autoscroll glitches the cursor across the screen as it moves down.  Also, when I log out from XFCE4, I see a brief flash of screen corruption.  3d performance is much improved from 8.40.7.  Overall, I'm happy with this driver even if it does still feel a bit "experimental".

Last edited by quex (2007-10-26 16:13:11)

Offline

#10 2007-10-26 17:07:56

bboozzoo
Member
From: Poland
Registered: 2006-08-01
Posts: 122

Re: AMD/ATI fglrx 8.42.3 Experiences

does anyone get a strage screen corruption when for instance scrolling screen? It manifests are 4-6 horizontal bars near the bottom right end of a screen, after this the playback using Xv is also broken. The poblem did not exist with 8.40 drivers, it appeared starting from 8.41

Offline

#11 2007-10-26 17:12:29

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

Many people, myself included, are getting corruption in the bottom-right corners of their screen, as well as directly beneath the mouse.

Offline

#12 2007-10-26 18:07:50

signor_rossi
Member
Registered: 2007-08-24
Posts: 257

Re: AMD/ATI fglrx 8.42.3 Experiences

Will try the new driver only now but I can say that I get the screen corruption from time to time with different recent versions of fglrx in arch, kubuntu and suse.

Bye, signor_rossi.

P.S. Havn't looked at AIGLx for a while, what benefits can I get from it (after enaling Composite in xorg.conf of course) in KDE now? And most of all are there other things to do?

Offline

#13 2007-10-26 18:33:32

tomato
Member
Registered: 2007-09-20
Posts: 72

Re: AMD/ATI fglrx 8.42.3 Experiences

Cerebral wrote:

Many people, myself included, are getting corruption in the bottom-right corners of their screen, as well as directly beneath the mouse.

i've got it too when i played with the driver but when i downgraded xorg-server to 1.2 from 1.4(the one in testing repo) both problems went away

anyway, It Works For Me™


sorry for my miserable english, it's my third language ; )

Offline

#14 2007-10-26 18:37:42

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

tomato wrote:

i've got it too when i played with the driver but when i downgraded xorg-server to 1.2 from 1.4(the one in testing repo) both problems went away

I never tried with 1.4 (1.2 only) and I still had the issues.

Offline

#15 2007-10-26 18:47:44

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: AMD/ATI fglrx 8.42.3 Experiences

I have installed it onto 64bit. I get the problem with the corner. My FPS has multiplied at least by 2 (maybe 3!) on glxgears, but KSplash doesn't work. Next I will try out compiz fusion.

EDIT: I enabled AIGLX and the corner problem has disappeared. smile
EDIT2: I chose a regular KSplash theme and it works perfectly. Must be a problem with OpenGL with KSplash...
EDIT3: Compiz Fusion doesn't work on KDE very well I can see (didn't work too well before with the open source drivers) sad The built in compositor for KDE3 works, but not too well.

Last edited by miggols99 (2007-10-26 19:10:49)

Offline

#16 2007-10-26 19:40:40

bboozzoo
Member
From: Poland
Registered: 2006-08-01
Posts: 122

Re: AMD/ATI fglrx 8.42.3 Experiences

you mean by adding Compisite "Enabled" in extensions and AIGLX "True" in ServerFlags? I've got these both set and still experience corruption.
What's more interesting that after the corruption appears Xv output does not work properly anymore, it seems like the lower diagonal displays undefined blurred thing, whereas the upper diagonal has the data that should normaly be in the lower part.

Offline

#17 2007-10-26 19:59:43

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: AMD/ATI fglrx 8.42.3 Experiences

I used this wiki page:

http://wiki.archlinux.org/index.php/Aiglx

EDIT: Tried Compiz Fusion again and it worked (almost) ! I got a white screen...and I had to restart X. Maybe upgrading to Xorg 1.4 would help?

Last edited by miggols99 (2007-10-26 21:03:14)

Offline

#18 2007-10-26 22:40:32

mintcoffee
Member
From: Waterloo, ON
Registered: 2007-10-05
Posts: 120
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

8.42 manages to suspend on my laptop, but it doesn't resume. I have a FireGL V5200 and I hacked the PCI ID to a X1600 for 8.42 to work so its not surprising.


Arch on a Thinkpad T400s

Offline

#19 2007-10-27 12:00:20

raven3x7
Member
Registered: 2007-03-11
Posts: 23

Re: AMD/ATI fglrx 8.42.3 Experiences

Im having a watermarkk issue with both 8.4 and 8.42 from testing. I made a bugreport. watermark.jpg

Offline

#20 2007-10-27 14:52:40

Emphrygian
Member
Registered: 2007-04-18
Posts: 27

Re: AMD/ATI fglrx 8.42.3 Experiences

raven3x7 wrote:

Im having a watermarkk issue with both 8.4 and 8.42 from testing. I made a bugreport. http://i164.photobucket.com/albums/u2/r … ermark.jpg

I had similar problems, but they went away when I put in "AIGLX" "true" under the server layout section of xorg.conf, as well as putting in "XAANoOffscreenPixmaps" "true" and "DRI" "true" under the device section. A less lazy user would probably try to determine which one solved the problem, but I am lazy big_smile

Offline

#21 2007-10-27 14:58:51

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: AMD/ATI fglrx 8.42.3 Experiences

Emphrygian wrote:
raven3x7 wrote:

Im having a watermarkk issue with both 8.4 and 8.42 from testing. I made a bugreport. http://i164.photobucket.com/albums/u2/r … ermark.jpg

I had similar problems, but they went away when I put in "AIGLX" "true" under the server layout section of xorg.conf, as well as putting in "XAANoOffscreenPixmaps" "true" and "DRI" "true" under the device section. A less lazy user would probably try to determine which one solved the problem, but I am lazy big_smile

I hope it really does fix it permanently for you - there've been a lot of "red herring" Xorg.conf fixes for the corruption, but it's always seemed to come back.

Offline

#22 2007-10-27 15:48:25

bboozzoo
Member
From: Poland
Registered: 2006-08-01
Posts: 122

Re: AMD/ATI fglrx 8.42.3 Experiences

For me not using Xv output seems to solve the problem, switching all players to opengl helps.

BTW. does anyone know why there is no gstreamer OpenGL output package in repositories?

Offline

#23 2007-10-27 19:37:05

Emphrygian
Member
Registered: 2007-04-18
Posts: 27

Re: AMD/ATI fglrx 8.42.3 Experiences

Cerebral wrote:
Emphrygian wrote:
raven3x7 wrote:

Im having a watermarkk issue with both 8.4 and 8.42 from testing. I made a bugreport. http://i164.photobucket.com/albums/u2/r … ermark.jpg

I had similar problems, but they went away when I put in "AIGLX" "true" under the server layout section of xorg.conf, as well as putting in "XAANoOffscreenPixmaps" "true" and "DRI" "true" under the device section. A less lazy user would probably try to determine which one solved the problem, but I am lazy big_smile

I hope it really does fix it permanently for you - there've been a lot of "red herring" Xorg.conf fixes for the corruption, but it's always seemed to come back.

I understand your point, but this certainly fixed it for me. The problem appeared not many seconds after I logged in to my upgraded machine. I also had problems with playing certain video files (flickering/no video) which worked before the upgrade, but after doing these changes they also started working again. I'll keep my fingers crossed that the corruption and video problems will stay away...

Offline

#24 2007-10-27 19:37:23

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: AMD/ATI fglrx 8.42.3 Experiences

Anyone know why it's not working? I actually tried a Ubuntu livecd to see if it would work. But I got the same problem. And it was 32bit. Does anyone else get this white screen when running "fusion-icon"?

Offline

#25 2007-10-28 04:23:00

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 383

Re: AMD/ATI fglrx 8.42.3 Experiences

I just switched to the new open source drivers which I wanted to check out anyways (6.7.195).
Had several hard crashes and the known corruption. Well, the new open source drivers are ok enough for me for now...
Cheers,
Blind

Offline

Board footer

Powered by FluxBB