You are not logged in.

#1 2007-10-29 18:46:28

mango
Member
Registered: 2007-04-27
Posts: 29

Wireless not working

Hi.

I've been trying to get my wireless network working, but no luck so far. I have Packad Bell  EasyNote with Atheros chipset and i've installed madwifi as told in archwiki, but no luck. I can scan for networks and see my own wireless network, but I can't connect to it. Also, when i boot i get the message  "ath0 timed out" when starting network. So I could imagine that the drivers work since I can scan for networks, but something with the settings or whatever fails and prevents me from connecting to the network.

What can cause this and how can it be solved? It's pretty useless to have a laptop if the wireless connection does not work.

Any help appreciated, thanks.

Offline

#2 2007-10-29 21:21:40

Jack B
Member
Registered: 2006-06-27
Posts: 107
Website

Re: Wireless not working

It could be a large number of things, some of which I may be able to help with, some not.

Some more information might help, what method do you use to try to connect? how does it fail? any error messages?

Bringing the network up at boot is handled by the network daemon, which uses the network section of /etc/rc.conf, and possibly some other files too, depending on setup.  It might help to post the appropriate chunk of said file (i.e everything from where it says "NETWORKING" to where it says "DAEMONS", without the comments).

There are a number of options for bringing up a wireless network when the system is running, so I don't know where to start on that one.

cheers
Jack

Offline

#3 2007-10-29 21:24:48

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,899
Website

Re: Wireless not working

iwconfig

iwlist ath0 scan [hope I got that the right way round!]

ath0 should show up.... check modules are loaded and network settings in rc.conf

HTH


Mr Green

Offline

#4 2007-10-30 04:07:21

AlmaMater
Member
Registered: 2007-02-28
Posts: 92

Re: Wireless not working

what i do, i install madwifi, i go to modprobe.conf, and:

alias ath0 ath_pci

and thats all, i dont touch rc.conf or anything  (actually i  add ath_pci to the MODULES array, but thats it)

then i install yaourt  (AUR)

and then:

yaourt -S wicd

and thats all i do :-) and it works perfectly

Last edited by AlmaMater (2007-10-30 04:08:57)

Offline

#5 2007-10-30 07:17:33

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Wireless not working

http://bbs.archlinux.org/viewtopic.php?id=36384

Seeing as you already have madwifi installed and configured, you just need to connect to your network. The above profile scripts should make it fairly easy.

James

Offline

#6 2007-10-30 19:26:24

mango
Member
Registered: 2007-04-27
Posts: 29

Re: Wireless not working

Wicd solved the problem! Thank you!

Offline

Board footer

Powered by FluxBB