You are not logged in.

#1 2007-10-31 08:46:30

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Wireless not working on eth1

I just tried to get my wireless card working on my laptop which is running Arch "Core Dump" 2007.11.  I follwed the "Wireless Setup" http://wiki.archlinux.org/index.php/Wireless instructions for my wireless card (Intel PRO/Wireless 2200bg which used the ipw2200 driver) but to no avail, on boot up my wireless card doesn't seem to load or connect or whatever. 

Here is the network section of my /etc/rc.conf file:

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTHOSTNAME="steve-laptop"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
wlan0="dhcp"
wlan0_eth1="eth1 essid markandrosie key Mynetworkkey"
WLAN_INTERFACES=(eth1)
INTERFACES=(lo eth0 eth1)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

where "mynetworkkey" is my network key (a number)

i'm not really sure that i've set up this file correctly.

Here is the output of ifconfig -a if thats helpful too:

eth0      Link encap:Ethernet  HWaddr 00:0E:7B:E2:74:27  
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:571 errors:0 dropped:0 overruns:0 frame:0
          TX packets:599 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:388280 (379.1 Kb)  TX bytes:89389 (87.2 Kb)

eth1      Link encap:Ethernet  HWaddr 00:0E:35:86:EB:56  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2533 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Memory:cffff000-cfffffff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:280 (280.0 b)  TX bytes:280 (280.0 b)

Thanks

Offline

#2 2007-10-31 08:55:54

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: Wireless not working on eth1

try iwconfig...

iwconfig wlan0 scan

have you loaded modules for wireless? [maybe hwdetect --net!]


Mr Green

Offline

#3 2007-10-31 09:08:34

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Re: Wireless not working on eth1

iwconfig wlan0 scan gives the rather unhelpful output of "unknown command 'scan'"

but no, i didn't load any modules for wireless, which ones should i load, I just tried

hwdetect --show-net
NET    : e100 eepro100 mii ppp_generic slhc ieee80211_crypt ieee80211 ipw2200

and of those, only e100 eepro100 mii slhc and ipw2200 are loaded in the modules section of my rc.conf file
does this mean i should add the others (ppp_generic ieee80211_crypt ieee80211)??

Last edited by stevesutt89 (2007-10-31 09:24:34)

Offline

#4 2007-10-31 11:03:37

newgargamel
Member
From: PL, CZ
Registered: 2005-08-28
Posts: 156

Re: Wireless not working on eth1

change your rc.conf file to this:

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTHOSTNAME="steve-laptop"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
eth1="dhcp"
#wlan0_eth1="eth1 essid markandrosie key Mynetworkkey"
#WLAN_INTERFACES=(eth1)
INTERFACES=(lo eth0 eth1)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
#ROUTES=(gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

in /etc/config there is a file wireless(.conf) and you should put there "eth1 essid markandrosie key Mynetworkkey"

Offline

#5 2007-10-31 11:59:10

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Re: Wireless not working on eth1

Well, I tried adding those lines to my /etc/conf.d/wireless file, but to no avail, its still not working. I shall no try and add some more modules to see if this helps

As a side question, is there a command that i can execute that will try to load network just as it does at start up, so i don't have to reboot to test the wireless connection each time.....

EDIT: Ok, i just tried adding the modules ieee80211 and ieee80211_crypt to my modules line of my rc.conf file, but again, no change

Last edited by stevesutt89 (2007-10-31 12:04:53)

Offline

#6 2007-10-31 13:59:20

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Wireless not working on eth1

The command is /etc/rc.d/network start/stop/restart, as required.

Offline

#7 2007-10-31 16:39:02

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: Wireless not working on eth1

sorry I meant iwlist wlan0 scan


Mr Green

Offline

#8 2007-10-31 20:13:26

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Wireless not working on eth1

Did you install the firmware? Just checking, one never knows...

I would recommend to create a wireless profile and use that in rc.conf. That's how I do it for my (WPA) WLAN, and it works just fine.

Last edited by B (2007-10-31 20:17:06)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#9 2007-10-31 20:45:25

newgargamel
Member
From: PL, CZ
Registered: 2005-08-28
Posts: 156

Re: Wireless not working on eth1

What kind on encryption do you use? WEP or WPA?

Offline

#10 2007-10-31 23:03:18

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Re: Wireless not working on eth1

Alrighty: Sorry about the delay in replying, but in australia is was early in the moring, Anyways,

I'm pretty sure i installed the firmware, that is if it is as simple as:
pacman -Sy ipw2200-fw

I just reinstalled it to make sure and i noticed an interesting output:

==> In order to use the firmware you have to agree to Intel's license located in
==> /lib/firmware/LICENSE.ipw2200-fw else please remove this package.

does this mean i have to do somehting to get it working???

As for encryption, I'm using WEP encryption

Oh, and the output of iwlist eth1 scan (eth1, because wlan0 does not exist on my system) is:

[root@(none) steve]# iwlist eth1 scan
eth1      Scan completed :
          Cell 01 - Address: 00:09:5B:D9:BC:9A
                    ESSID:"markandrosie"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Quality=67/100  Signal level=-60 dBm  
                    Extra: Last beacon: 333ms ago

Hope that helps wink

Offline

#11 2007-11-01 08:56:51

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Re: Wireless not working on eth1

Hooorah!!! I got it working, thanks guys!!

However it's still not doing what it should.  In the /etc/conf.d/wireless file i read this:

# Settings for wireless cards
#
# For each wireless interface declared in INTERFACES (in rc.conf), declare
# a wlan_${IF} variable that contains the arguments to be passed to
# iwconfig(8).  Then list the original interface name in the
# WLAN_INTERFACES array.
#

so i decided to put the lines from this file straight into iwconfig:

[root@(none) steve]# iwconfig eth1 essid markandrosie key myNetworkKey

and suddenly my wireless is working!

so, to me it seems as if there is a problem where the file /etc/conf.d/wireless is not passing off the commands to iwconfig at boot up. 

Any ideas?

Offline

#12 2007-11-01 09:52:51

stevesutt89
Member
From: Newcastle Australia
Registered: 2007-10-30
Posts: 46
Website

Re: Wireless not working on eth1

Well, its fixed!!(!!!!!)

It turns out that in the /etc/rc.conf/wireless file i had entered this:

wlan0_eth1="eth1 essid markandrosie key myNetworkKey"

Instead of this:

wlan_eth1="eth1 essid markandrosie key myNetworkKey"

also in my /etc/rc.conf i needed to change

wlan0="dhcp"

to:

eth1="dhcp"

while the first error was a stupid mistake by me, i get the feeling the second was the result of unclear wording on the wireless setup page of the arch wiki which assumed your wireless device was called "wlan0"...or it was just a stupid mistake by me.....

.....off to arch wiki page to check out the wording, and see if i can help make it more clear........

Thanks for all the help guys!!

Last edited by stevesutt89 (2007-11-01 09:54:00)

Offline

#13 2007-11-13 23:55:16

Pantera
Member
Registered: 2007-11-05
Posts: 13

Re: Wireless not working on eth1

stevesutt89 I've your same problem, can you write your new files /etc/rc.conf and /etc/conf.d/wireless and exactly what you've done.
I've your same wireless card and I can't connect.
Thank you.

Offline

#14 2007-11-14 07:53:45

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: Wireless not working on eth1

According to Wiki you should be able to set up wireless profile from rc.conf [read phraktures trick!]

Last edited by Mr Green (2007-11-14 07:55:33)


Mr Green

Offline

Board footer

Powered by FluxBB