You are not logged in.

#1 2007-12-02 13:20:09

Registered: 2007-06-02
Posts: 314

xorg-server 1.4-6 breaks tablet support

Hi. I just downloaded the latest xorg-server update, and when I restarted X, all I got was an underscore cursor and the system stopped responding. No input I gave it worked, so I had to manually restart my system. What's worse is that it didn't seem to log anything. I just checked /var/log/Xorg.0.log and it had results from another X problem I had (my tablet's pad buttons crash X when pressed).

What can I do? I've considered downgrading X to a version that I know worked...

EDIT: I'm using xorg-server 1.4-6

EDIT2: I got rid of all of my settings for my tablet in xorg.conf, and now everything seems to be working fine. What's strange is that linuxwacom is already the latest version (0.7.9-2) and I recently recompiled it to get my tablet to work again. Is another recompile necessary with this new xorg-server update, or will I just have to go tabletless for a while?

EDIT3: Recompiling linuxwacom again didn't help anything. It looks like I'm going tabletless.. again.

Last edited by xelados (2007-12-02 14:57:50)


#2 2007-12-02 17:52:40

Registered: 2007-02-19
Posts: 22

Re: xorg-server 1.4-6 breaks tablet support

I'm sharing your pain, new Xorg versions seems to be lot different (than before) to cause such incompatibilities. All my wishes goes to the linuxwacom team \o/


Board footer

Powered by FluxBB