You are not logged in.

#1 2007-12-14 12:36:54

dninja
Member
From: Sheffield, UK
Registered: 2006-04-29
Posts: 374
Website

slib and gnucash building problems

I'm trying to build gnucash from AUR and hitting this error

checking for SLIB support... configure: error:

   Cannot find SLIB.  Are you sure you have it installed?
   See http://bugzilla.gnome.org/show_bug.cgi?id=347922


make: *** No targets specified and no makefile found.  Stop.

I do have slib installed but reading the bug report there is the suggestion that it may be to do with the install location of slib and that guile is looking for it in a different directory.

Running this:

 guile -c "(use-modules (ice-9 slib)) (require 'printf)"

I get this back

ERROR: Could not find slib/require.scm in  ("/usr/share/guile/site" "/usr/share/guile/1.8" "/usr/share/guile")

so I made a symlink from /usr/lib/slib to /usr/share/guile/ and re-ran the guile command to get this new error:

ERROR: Unbound variable: slib:features

At this point I've got stuck. Can anyone help?

Offline

#2 2007-12-21 07:06:50

queueRAM
Member
Registered: 2006-09-05
Posts: 14

Re: slib and gnucash building problems

I posted some info in the slib AUR comments section:
3a1 installed to /usr/share/guile/slib whereas 3a4 and 3a5 are installing to /usr/lib/slib and guile can no longer find it. Additionally, the slibcat file included with this package references the old /usr/share/guile/slib/ and is installed there in the PKGBUILD as well (although that may be correct). slibcat says it is autogenerated, but i couldn't figure out how to generate a new one myself.

Offline

#3 2007-12-21 09:29:38

dninja
Member
From: Sheffield, UK
Registered: 2006-04-29
Posts: 374
Website

Re: slib and gnucash building problems

I assume that you've not managed to get a working system yet then?

I'm thinking of creating an ubuntu vmware image and installing gnucash in that just so I know that I have a working copy!

Offline

#4 2007-12-22 16:26:12

Teld
Member
From: Nice, France
Registered: 2007-08-01
Posts: 15
Website

Re: slib and gnucash building problems

I posted this comment in AUR to the slib and gnucash packages:

After upgrading to slib-3a5-2, I encountered now the following problem when starting gnucash:

ERROR: Unbound variable: slib:features

Some googling around showed that slib has changed: the function slib:features used to be *features*.

Compare the webpages:
http://not-your-cup-of-chai.blogspot.co … ucash.html
http://www.mail-archive.com/debian-bugs … 85541.html

Unfortunately I lack the knowledge to understand what has to be done about it. Anyone else does?

Offline

#5 2007-12-26 13:15:08

Teld
Member
From: Nice, France
Registered: 2007-08-01
Posts: 15
Website

Re: slib and gnucash building problems

OK, I've got Gnucash working by doing the following.

- upgrade guile from 1.8.1. to 1.8.3 after having built it yourself. You just have to change the version in the PKGBUILD in your ABS.
- upgrade slib to 3a5-2.
- make a symlink in /usr/share/guile/slib: ln -s mklibcat.scm mklibcat. This will prevent the following error message:
ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/share/guile/slib/mklibcat"
- make a symlink in /usr/share/guile/site: ln -s ../slibcat slibcat.
- now in /usr/share/guile change the permissions of slibcat: chmod 666 slibcat and start Gnucash. This will prevent the error:
ERROR: In procedure open-file:
ERROR: Permission denied: "/usr/share/guile/site/slibcat"
- Immediately close Gnucash and restore the permissions again of slibcat: chmod 644 slibcat. This action had to be done once in order to update the catalogue. Apparently, this file is wrong in the slib package and has to be changed there. I have already informed its maintainer sergej.

Offline

#6 2007-12-27 18:11:31

dninja
Member
From: Sheffield, UK
Registered: 2006-04-29
Posts: 374
Website

Re: slib and gnucash building problems

Thanks Teld, that worked for me

Offline

#7 2008-01-13 19:45:44

Teld
Member
From: Nice, France
Registered: 2007-08-01
Posts: 15
Website

Re: slib and gnucash building problems

Update.

I updated GNUCash to 2.2.3-1 using the newest slib 3a5-3 and guile 1.8.3 (my own compilation). Only one symlink has to be created manually:

ln -s /usr/share/guile/slibcat  /usr/share/guile/site/slibcat

There is no need to patch or change anything else.

On my system, GNUCash works flawlessly.

Offline

#8 2008-01-15 11:34:08

Teld
Member
From: Nice, France
Registered: 2007-08-01
Posts: 15
Website

Re: slib and gnucash building problems

Update again.

The maintainer of slib has updated this package. After upgrading to slib 3a5-4, there is no need anymore to do any manual action. A fresh install of GNUCash and its dependencies works now out of the box! Just keep in mind to use guile 1.8.3!

Offline

#9 2008-01-15 18:13:02

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: slib and gnucash building problems

For the record, I *will* be pulling both slib and gnucash into extra soon. This will be done at the same time I upgrade goffice to 0.6.1 as well. The only potential issue is that aqbanking support will be dropped, so if that is important, and AUR package for that will still be needed.

What I'm saying is: you shouldn't need to worry about this for much longer 8)

Offline

#10 2008-01-15 18:40:54

dninja
Member
From: Sheffield, UK
Registered: 2006-04-29
Posts: 374
Website

Re: slib and gnucash building problems

Thank you very much phrakture, that will make life a lot easier!

Offline

#11 2008-01-15 20:08:57

ploub
Member
Registered: 2007-05-16
Posts: 128

Re: slib and gnucash building problems

phrakture wrote:

For the record, I *will* be pulling both slib and gnucash into extra soon. This will be done at the same time I upgrade goffice to 0.6.1 as well. The only potential issue is that aqbanking support will be dropped, so if that is important, and AUR package for that will still be needed.

What I'm saying is: you shouldn't need to worry about this for much longer 8)

That's great. Gnucash is an important package but has been troublesome. Hats off to queueRam and the AUR people for keeping this alive.

Offline

#12 2008-01-16 06:46:50

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: slib and gnucash building problems

Aaaand, here we go. slib added to extra, goffice upgraded to 0.6.1, gnumeric patched and upgraded, and gnucash pushed too. Please report any problems as this was a large chain of time consuming rebuilds and I may have missed something... x86_64 incoming soon(ish)

Offline

#13 2008-01-16 09:22:38

dninja
Member
From: Sheffield, UK
Registered: 2006-04-29
Posts: 374
Website

Re: slib and gnucash building problems

Works fine for me but could you explain this message which I get every time I start it up:

gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

I know it isn't a problem/bug I'm just curious to know what binreloc relocation is and why it is disabled.

Offline

#14 2008-01-18 00:29:00

Teld
Member
From: Nice, France
Registered: 2007-08-01
Posts: 15
Website

Re: slib and gnucash building problems

For the record, I first uninstalled my own versions of GNUCash, slib and guile and then did a fresh reinstall from the official repositories. I faced no problems at all and GNUCash works perfectly for me. Thanks, phrakture.

Offline

#15 2008-01-18 07:02:05

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: slib and gnucash building problems

dninja wrote:

Works fine for me but could you explain this message which I get every time I start it up:

gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

I know it isn't a problem/bug I'm just curious to know what binreloc relocation is and why it is disabled.

I have no idea either... it happened to me too, but everything seemed to work fine, so I assumed it was standard "too much output from gnome apps".

Offline

#16 2008-02-04 08:13:40

lydgate
Member
From: London, UK
Registered: 2006-01-10
Posts: 60

Re: slib and gnucash building problems

Very cool!  Is the swig dependency still required though?

http://www.gnucash.org/

Gnucash wrote:

Neither the currently used swig nor the previously used g-wrap packages are needed anymore when compiling from tarball or when installing a binary.

Last edited by lydgate (2008-02-04 08:14:55)

Offline

#17 2008-02-04 14:07:20

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: slib and gnucash building problems

lydgate wrote:

Very cool!  Is the swig dependency still required though?

http://www.gnucash.org/

Gnucash wrote:

Neither the currently used swig nor the previously used g-wrap packages are needed anymore when compiling from tarball or when installing a binary.

Bug tracker

Offline

#18 2008-02-26 14:06:54

SystemParadox
Member
From: Tavistock (Devon) and Bristol
Registered: 2006-06-09
Posts: 35
Website

Re: slib and gnucash building problems

Just tried to install this today and am still getting the problems with mklibcat. I initially installed gnucash with guile 1.8.1 before finding this thread, but I've reinstalled slib (3a5-5), guile (1.8.3-1) and gnucash (2.2.3-1) several times but still get the problem. I'm about to fix it with the symlinks, etc described above, but this isn't suppose to be necessary anymore, so why am I getting the problem? What packages do I actually need to reinstall after upgrading guile and slib? "gnucash and it's dependencies" isn't very helpful- gnucash has a lot of dependencies- I don't seriously have to reinstall ALL of them do I?

Thanks in advance.
Simon

Last edited by SystemParadox (2008-02-26 14:09:39)

Offline

#19 2008-02-26 14:29:53

SystemParadox
Member
From: Tavistock (Devon) and Bristol
Registered: 2006-06-09
Posts: 35
Website

Re: slib and gnucash building problems

It seems I have no slibcat-  for some reason pacman wasn't running the slib.install scriptlet. Maybe a bug in pacman? Ran the catalog update command manually and gnucash now works fine.

Offline

Board footer

Powered by FluxBB