You are not logged in.

#1 2007-12-15 17:26:28

From: Alberta Canada
Registered: 2006-07-31
Posts: 15

[solved] Grub is failing me during installation...

After multiple FTP and cd installs, reformatting/wiping my partitions, and almost 10 hours of attempting installation, I'm stuck on the dang bootloader. Neither grub nor lilo will install to my sda. Whenever I try to run the "setup (hd0)" command, after "root (hd0,1)", I get the following junk:

grub> root (hd0,1)
Filesystem type is ext2fs, partition type 0x83 ##the part that confuses me about this is that my fs type should be ext3, not ext2. But maybe that's just a grub bug.

grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... no ##this is a blatant lie. because i PUT stage1 there!
Checking if "/grub/stage1" exists... no ##as above

Error 15: File not found
grub> quit

Lilo also gave me an error and died.

From random checkin around on the interwebs, it *appears* that it might have to do with the kernel not being where it's supposed to be, but the only way that files want to go places is if they already physically exist, and i copy em over. Any ideas?

[Edit: I re-did the entire installation, and it worked. I guess I must have had some typos in the config files *shrug*]

Last edited by Cronanius (2007-12-16 04:16:41)

Perpetually an Arch Newbie. I'm here for the operating system, not the philosophy.


Board footer

Powered by FluxBB