You are not logged in.

#1 2007-12-17 05:00:51

From: USA
Registered: 2007-12-17
Posts: 553

Missing initrd [Solved]

I'm trying Arch Linux coming from a Linux background of only having used Ubuntu, so dealing with the kernel isn't exactly something I've had to do.

I have Ubuntu installed on /dev/sda2 and I installed Arch on /dev/sda3. I already have grub installed running from /dev/sda2 and didn't want to overwrite it by installing and using grub from Arch's installer disk on /dev/sda3, so I elected not to install a bootloader when I installed Arch.

So now I'm trying to edit Grub on /dev/sda2, but I'm not sure what exactly to add to Grub's boot menu list to boot to Arch. I figured I'd just compare the /boot directories on /dev/sda2 and /dev/sda3, look at Grub's existing menu to see what's used from /dev/sda2's /boot, and then use what looks like the equivalent from /dev/sda3's boot.

The problem is that it's not obvious what from Ubuntu's /dev/sda2 /boot coresponds to Arch's /dev/sda3 /boot.

The ls of Ubuntu's /boot:

b-con@beacon-laptop:~$ ls /boot
abi-2.6.20-15-generic             initrd.img-2.6.20-16-generic.bak
abi-2.6.20-16-generic             mbr-backup-20070506
config-2.6.20-15-generic          memtest86+.bin
initrd.img-2.6.20-15-generic      vmlinuz-2.6.20-15-generic
initrd.img-2.6.20-15-generic.bak  vmlinuz-2.6.20-16-generic

And to boot to Ubuntu, Grub uses this:

title        Ubuntu, kernel 2.6.20-16-generic
root        (hd0,1)
kernel        /boot/vmlinuz-2.6.20-16-generic root=UUID=ef56c969-460e-446e-925d-06fcaaa446b8 ro quiet splash
initrd        /boot/initrd.img-2.6.20-16-generic

The ls of Arch's /boot:

b-con@beacon-laptop:~$ ls /media/arch/boot
diag1.img  kconfig26              kernel26.img  vmlinuz26
grub       kernel26-fallback.img  System.map26

(I know what the "quiet" and "savedefault" options do.) I presume I'd want to use something akin to:

title        Arch
root        (hd0,2)
kernel        /boot/vmlinuz26 root=UUID=383ef65f-bc37-44d9-a680-8302fe059212 ro quiet splash
initrd        ??

for Arch (where the UUID has been changed appropriately)? The part that has me confused is the initrd option for Arch, because I have no file by the name of initrd, but without it I'll have no initial file system for booting.

Is having an "initrd", necessary? How/should I create one if I don't have one? And other than that, does that look like the right  option settings for Grub?

*** Problem Solved ***

I had a hunch and checked /boot/grub/menu.lst on my Arch install and it had created a valid menu for booting from by default. In it it used

initrd /boot/kernel26.img

which allowed me to boot. I now have other problems, but that's a different story.

Last edited by B-Con (2007-12-18 03:47:42)


Board footer

Powered by FluxBB