You are not logged in.

#1 2004-04-25 10:32:52

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

mouse protocol option

I've just installed  Arch on my laptop, on which I'm writing this, and there i just have "Auto".

But on my stationary I got an old 2-button ps/2 mouse, who don't want "Auto".

The other mouse settings are the same as my laptop so they should be fine!


arch + gentoo + initng + python = enlisy

Offline

#2 2004-04-25 12:18:01

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: mouse protocol option

Try "PS/2" instead of "Auto".

Offline

#3 2004-04-25 13:16:14

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

Hi i3839..

Thanks for the tip but it still not seems to work.

The mouse sucks anyway....maybe I get an optical instead.

But usb seems to be some kind of headache also!!


arch + gentoo + initng + python = enlisy

Offline

#4 2004-04-25 13:25:29

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

Fu......k!

I just found out that It's a serial mouse.

What /dev is that?


arch + gentoo + initng + python = enlisy

Offline

#5 2004-04-25 14:17:36

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: mouse protocol option

I used /dev/serialmouse for my serial mouse, but I think I made a symlink...

The serial port is something like /dec/ttyS, so try to do "cat /dev/ttyS0" and move your mouse. If you get garbage, that's your mouse, if nothing happens try another device. Others that you can try: /dev/psaux, /dev/input/*, /dev/ttyS1 etc.

Offline

#6 2004-04-25 15:02:41

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

No luck yet!

Strange that dmesg don't give any output though.

So it should be something like /dev/tty ?


arch + gentoo + initng + python = enlisy

Offline

#7 2004-04-25 15:33:15

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: mouse protocol option

You may need to load an appropriate module.  I'm not sure what you need, but you could look in /lib/modules/your kernel/kernel/drivers/input/


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#8 2004-04-25 15:56:04

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

What  a heck!!!

Spending 2hour for a complete setup from scratch and then 2hours for trying to get a 7 year old serial mouse to work.

Open source is just for free if you got the time right!!

Here is one strange scenario on my laptop  also.

First time I booted up kde it took 3 min.
Second time 2 min.
Third time 1 min.

Now maybe 40 s on an athlon 1800+ and konqi starts in 2s!

What is happening? KDE needs a few testdrives to be warm?


arch + gentoo + initng + python = enlisy

Offline

#9 2004-04-25 16:12:14

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: mouse protocol option

Hm, forgot about the serial module, I'm used to compile my custom kernels with no modules. A quick search shows up that you need modules serport, sermouse and serial, so load them with modprobe. Then look in /dev for serialmouse (if devfsd made that link), and otherwise for ttyS0, ttyS1 etc (not just tty, the S is important).

About KDE: Linux caches files, so loading the first time takes much longer because all files must be read from disk. You're not very clear on what hardware you tried it, but that the second run probably takes so long because you don't have infinite ram and KDE's memory hungry behaviour pushed the cached files out of ram. If KDE is too slow for you, then try Xfce4, just for fun.

Offline

#10 2004-04-25 17:15:39

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

I only had serport of the modules you said.

Should I see the mouse in /dev if it was recognised by devfs?
There is no sign of it yet anyway so it was not to blame on xfree!!

KDE is fast now!


arch + gentoo + initng + python = enlisy

Offline

#11 2004-04-25 17:19:39

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: mouse protocol option

Should I see the mouse in /dev if it was recognised by devfs?

I wouldn't expect the link unless you set it up yourself.  After you load the module, check dmesg and see if your mouse was set up.  Then, using /dev/input/mice in your XF86Config should work.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#12 2004-04-25 17:38:41

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

dmesg does not work on my stationary but does on my laptop..strange.

Anyway, I've only got "serport" and I changed XF86Config to /dev/input/mice, but still no sign of life in the bloody mouse.


arch + gentoo + initng + python = enlisy

Offline

#13 2004-04-25 17:44:08

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: mouse protocol option

HTH

Section "InputDevice"
    Identifier  "PS/2 Mouse"
    Driver      "mouse"
    Option      "Protocol" "imps/2"
Option          "ZAxisMapping"          "4 5"
    Option      "Device" "/dev/misc/psaux"
    Option      "Emulate3Buttons" "true"
    Option      "Emulate3Timeout" "70"
    Option        "SendCoreEvents"  "true"
EndSection

Maybe pacman in hwd to find mouse.....

Mr Green


Mr Green

Offline

#14 2004-04-25 17:59:14

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

I'ts kind of a weird thread this but the mouse is a "serial" one and I think I get an USB instead!

Tomorrow! Hope it's easier to fix.

I got Arch 2.6.5 kernel, does it has builtin USB or do you need module?


arch + gentoo + initng + python = enlisy

Offline

#15 2004-04-25 19:29:18

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: mouse protocol option

UHCI and EHCI (USB2) are built-in, and the ohci-hcd module supports everything else.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#16 2004-04-26 12:33:14

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

Oki , now I got an Logitech click 2-button wheel mouse.

It works allright, I thoght!

Then it started to flip across the screen.
I can use it but I'm getting really pissed of it.

I've read every thread about logitech mouses and it seems that there is not really an good answer to what protocol to use!

My protocol now is "imps/2". Anyone please.......


arch + gentoo + initng + python = enlisy

Offline

#17 2004-04-26 13:02:09

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: mouse protocol option

It was my mouse-underlay who screwed up the optical sensor ,it seems.

Moderator, close this thread now , please!!!!!!!!!!!!


arch + gentoo + initng + python = enlisy

Offline

Board footer

Powered by FluxBB