You are not logged in.

#1 2004-04-28 18:29:23

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

opendchub,kasablanca

A little draft for a direct connect hub!

# Contributor: xerxes2 <xerxes2@gentoo.se>
pkgname=opendchub
pkgver=0.7.14
pkgrel=1
pkgdesc="direct connect hub"
url="http://opendchub.sourceforge.net/"
groups=()
provides=()
depends=()
makedepends=()
conflicts=()
replaces=()
backup=()
install=()
source=('http://switch.dl.sourceforge.net/sourceforge/opendchub/opendchub-0.7.14.tar.gz')
md5sums=()

build() {
  cd $startdir/src/$pkgname-0.7.14
  ./configure --prefix=/usr
  make || return 1
  make Destdir=$startdir/pkg install
}

A little question also:
When I'm trying to compile dcgui-qt-cvs-alpha 0.3.0, so exits the compiler asking for /opt/qt/lib/libqt-mt.a

Anyone else got that file?
Oh btw,kbear doesn't work for me.KDE people must stop messing up those programs who worked before!!!!!!


arch + gentoo + initng + python = enlisy

Offline

#2 2004-04-29 14:14:07

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: opendchub,kasablanca

pacman -R kbear

I found another program

# Contributor: xerxes2 <xerxes2@gentoo.se>
pkgname=kasablanca
pkgver=0.3.1
pkgrel=1
pkgdesc="kde ftp client"
url="http://kasablanca.berlios.de/"
groups=
provides=
depends=('kdelibs' 'qt')
makedepends=()
conflicts=()
replaces=()
backup=()
install=()
source=('http://download.berlios.de/kasablanca/kasablanca-0.3.1.tar.gz')
md5sums=()

build() {
  cd $startdir/src/$pkgname-0.3.1
  ./configure --prefix=/opt/kde
  make || return 1
  make Destdir=$startdir/pkg install
}

It looks simple but it works!


arch + gentoo + initng + python = enlisy

Offline

#3 2004-05-08 14:00:08

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 232

Re: opendchub,kasablanca


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#4 2004-05-08 14:05:54

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: opendchub,kasablanca

xerxes2 wrote:

A little question also:
When I'm trying to compile dcgui-qt-cvs-alpha 0.3.0, so exits the compiler asking for /opt/qt/lib/libqt-mt.a

you can find out easily to what pkg a file belongs by using pacman -Qo

[damir@Asteraceae /]$ pacman -Qo /opt/qt/lib/libqt-mt.la 
/opt/qt/lib/libqt-mt.la is owned by qt 3.3.2-1

-> so qt is needed as dependency


The impossible missions are the only ones which succeed.

Offline

#5 2004-05-08 15:19:10

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: opendchub,kasablanca

Yes but it's not that file I asked about dp. Nevermind ,is there another dc-client than this one?


arch + gentoo + initng + python = enlisy

Offline

#6 2004-05-08 15:42:53

kritoke
Member
From: Texas, USA
Registered: 2003-08-01
Posts: 211
Website

Re: opendchub,kasablanca

Well you could use the non-cvs version of dcgui, for some reason the maintainer of it hasn't updated it in extra, even though there are no problems with compiling 0.2.22, there is also dctc and cccp.  For me, dcgui-qt has the most features and runs the best, dispite it being qt, I myself am more of a gtk type person.

Kritoke


http://counter.li.org/ Registered Linux User #318963 kritoke@jabber.org

Offline

Board footer

Powered by FluxBB