You are not logged in.

#1 2008-02-25 20:37:33

kalinatek
Member
From: Boston
Registered: 2007-01-07
Posts: 20

firefox ignores GTK2 font size [solved]

This is a very minute issue, but it's always really bothered me... every time I use Firefox outside of GNOME (maybe it does this in GNOME too and I forgot...) it just decides, the hell with my GTK2 theme, it's going to use whatever font size it wants. I'm sure that my GTK2 font size has actually been changed (using gtk2_prefs); I actually have a screenshot to prove it, and to clarify my point : http://kalinatek.servehttp.com/img/screenshot.png (That's Enlightenment17 btw.) As you can see the Pidgin interface font is a Sans Serif 8, while Firefox's stays at 10.

I meddled around in about:config and didn't see anything but maybe I missed something? Searching the internets has done me no good either. Help pls!

Last edited by kalinatek (2008-04-08 18:45:37)

Offline

#2 2008-02-25 20:47:13

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: firefox ignores GTK2 font size [solved]

Try going back to about:config

filter for dpi

change -1 to 0


oz

Offline

#3 2008-02-25 20:49:35

xabbott
Member
From: orlando, fl
Registered: 2007-01-11
Posts: 56
Website

Re: firefox ignores GTK2 font size [solved]

I had this issue too. I believe I had to (re)move /etc/fonts/local.conf. Also go into about:config, check layout.css.dpi
and try changing it to 0.

Last edited by xabbott (2008-02-25 20:49:51)

Offline

#4 2008-02-25 22:39:06

dunc
Member
From: Glasgow, UK
Registered: 2007-06-18
Posts: 556

Re: firefox ignores GTK2 font size [solved]

Try putting this in ~/.mozilla/firefox/{whatever}.default/chrome/userChrome.css:

window {
  font-size: 11px !important;
}

menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip
{
    font-size: 11px !important;
}

And adjust the "11px" to whatever looks right. "px"="pixels", obviously. You could try point sizes with "pt" instead; then, if your DPI is set properly, the values should be the same as for everything else. "8pt" in your case.


0 Ok, 0:1

Offline

#5 2008-02-27 00:27:58

iggames
Member
From: California, US
Registered: 2008-02-24
Posts: 13
Website

Re: firefox ignores GTK2 font size [solved]

I've had that same problem. I believe it was because firefox was looking in a different place for gtk theme information. Assuming you used gtk-chtheme, your font settings are in ~/.gtkrc-2.0. Especially if gnome is also installed, firefox may be looking for something else.

Do a ls -a in your home directory and look for files with gtk in their name (ie: .gtkrc-2.0), maybe one of them contains the font setting that is controlling firefox.

Hope that helps.

Offline

#6 2008-03-29 18:13:26

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: firefox ignores GTK2 font size [solved]

My issue was apparantly using an "unsupported" font in the gtk-qt-engine thing. I guess Firefox didn't like "Calibri" at well as qt apps do. I changed the font and all is well.

Offline

#7 2008-03-29 19:44:33

grndrush
Member
From: Hamilton, Ontario, Canada
Registered: 2003-12-28
Posts: 136
Website

Re: firefox ignores GTK2 font size [solved]

In KDE, in KControl -> Appearances and Themes -> GTK Styles and Fonts, there are entries for GTK Styles, and GTK Fonts, both with a "Use my KDE style/fonts in GTK applications". I had the same problem, and setting these two fixed it, at least in KDE (and the Fonts entry seems to reset itself on occasion; you know it when you see it, of course, and I go back into KControl and reset it).

This likely only works in KDE, but does work for it.

Offline

#8 2008-04-08 18:46:18

kalinatek
Member
From: Boston
Registered: 2007-01-07
Posts: 20

Re: firefox ignores GTK2 font size [solved]

dunc wrote:

Try putting this in ~/.mozilla/firefox/{whatever}.default/chrome/userChrome.css:

window {
  font-size: 11px !important;
}

menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip
{
    font-size: 11px !important;
}

And adjust the "11px" to whatever looks right. "px"="pixels", obviously. You could try point sizes with "pt" instead; then, if your DPI is set properly, the values should be the same as for everything else. "8pt" in your case.

Thank everyone for your replies, but this method was the winner. Problem solved!

Offline

Board footer

Powered by FluxBB