You are not logged in.

#1 2008-03-08 10:00:39

Registered: 2007-12-01
Posts: 20

[SOLVED] GRUB Error 17

After moving my grub installation on a partition of its own, grub refuses to boot stating "Error 17".

This is what the grub manual says about that error:

17 : Cannot mount selected partition
    This error is returned if the partition requested exists, but the filesystem type cannot be recognized by GRUB.

What I conclude is that grub can't read its partition to gain access to fs-drivers and the menu.lst/

I've already reinstalled grub and reformatted its partition several times, but that didn't do the trick.

Both my

(hd0)    /dev/sda

and my menu.lst

timeout    1
default    0

# (0) Arch Linux
title    Arch Linux
root    (hd0,1)
kernel    /boot/vmlinuz26 root=/dev/sda2 ro vga=795
initrd    /boot/kernel26.img

Seem to be configured correctly as when executing find /boot/vmlinuz26 in the grub shell (started via the arch rescue system) it returns the same values for root as i used in the menu.lst.

What drew my attention was my partition table (sda1 = windows partition; sda2 = arch32 partition; sda3 = arch64 partition; sda4 = boot partition):

Disk /dev/sda: 250.0 GB, 250058268160 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000d9872

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       15665   125829081    7  HPFS/NTFS
/dev/sda2           17348       23874    52428127+  83  Linux
/dev/sda3           23875       30401    52428127+  83  Linux
/dev/sda4   *       15666       17347    13510665   83  Linux

Partition table entries are not in disk order

I assume/anticipate that grub-install uses the device enumeration (/dev/sdaX) to figure out which partition grub's files are installed on and grub (when booting) uses the order written onto the partition table.
Hence grub-install writes into the mbr: "You can find the files on the 4th partition."
However, when booting, grub looks for its files on the partition to which the 4th entry in the partition table belongs (Which is not the actual boot partition as it's entry is the 2nd one on the partition table (i figured that out with gparted)).

Does anyone know if i assume correctly and/or how I can solve that mess?

[Thanks for your help in advance.

Last edited by Actium (2008-03-08 12:37:25)


#2 2008-03-08 12:43:01

Registered: 2007-12-01
Posts: 20

Re: [SOLVED] GRUB Error 17

I don't know who wrote that certain part of the super grub disk, but he definitely did his job a hell lot better than the actual developers of grub (to be a little bit more precise: the grub-install-tool).

I just used the fix grub-option of super grub disk and now my grub has come back to life.

I'm still not finished with finding out what caused all this. If anything of interest for other victims of that issue turns out, I'll be posting it here.

Last edited by Actium (2008-03-08 12:43:33)


Board footer

Powered by FluxBB