You are not logged in.

#1 2008-03-11 22:39:29

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

New to Arch. Wireless setup question.

I tried reading other posts and the guides, but at this point my head is spinning with the wireless stuff. Everything else was smooth as silk.

I installed bcm43xx-fwcutter because I know it works for this laptop. I extracted the firmware.

My wireless device is eth1 in Ubuntu, so here is my rc.conf:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="US/Eastern"
KEYMAP="us"
CONSOLEFONT="lat2-16"
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(e100 alsa mii bcm43xx snd-mixer-oss snd-pcm-oss snd-hwdep snd-page-alloc snd-pcm snd-timer snd snd-hda-intel soundcore)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="arch"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
eth1="dhcp"
INTERFACES=(lo eth1="dhcp" eth0="dhcp")
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
NET_PROFILES=(menu)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !network dhcdbd networkmanager netfs crond alsa gdm hal fam acpid)


# End of file

I did not edit the network-profiles file, or the config.d/wireless and I don't really know how to.

I installed networkmanager and have the applet on the gnome panel. When I click on it, I can only choose lo or eth0 (my wired connection).

Sorry for asking a question that I'm sure is asked all the time. neutral

Offline

#2 2008-03-11 23:21:56

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,137

Re: New to Arch. Wireless setup question.

Are you sure you have wireless-tools installed? 

pacman -S wireless-tools

Also you don't need the eth0=dhcp and eth1=dhcp in INTERFACES, just INTERFACES=(eth0 eth1).  Somewhere I read you don't need lo there anymore either.


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#3 2008-03-11 23:36:05

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: New to Arch. Wireless setup question.

Is your wireless card listed in an "iwconfig" output?

If it is, then install netcfg and follow the instructions here to get it connected:
http://wiki.archlinux.org/index.php/Network_Profiles

Offline

#4 2008-03-12 00:46:02

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: New to Arch. Wireless setup question.

My wireless card IS listed when I do iwconfig.

for some reason pacman can't find wireless-tools, but I got netcfg.

I tried to configure it, but it still doesn't seem to work. I'm not at that computer, and I'm very frustrated, so I'll update and post again tomorrow.

Thanks for the help.

Keep posting any ideas.

Last edited by pogeymanz (2008-03-12 00:48:44)

Offline

#5 2008-03-12 01:05:18

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,137

Re: New to Arch. Wireless setup question.

Sorry about that. I was sure it was always wireless-tools but apparently it's wireless_tools.  Without it nothing will work.


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#6 2008-03-12 01:53:51

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: New to Arch. Wireless setup question.

Well, I did have it installed already. And apparently I can get my wireless working by magic now.

How do I get nm-applet to load at boot-up? It's different than the network-monitor in the add-to-gnome-panel menu.

I probably have 100 more modules and apps than I need to have internet, but I'm afraid to tinker anymore and delete stuff...

Offline

#7 2008-03-12 02:03:36

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: New to Arch. Wireless setup question.

If network manager is starting at boot, then it should just automagically appear when you start gnome. Make sure the relevant networkmanager daemons are started in DAEMONS=(). There should be details on the wiki.

Offline

#8 2008-03-12 02:07:28

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: New to Arch. Wireless setup question.

Do you know what the daemon is called? Because I do have "networkmanager" in my daemons list in rc.conf, but it still doesn't load by itself. I have to summon it from the terminal.

Offline

#9 2008-03-12 07:59:53

ekerazha
Member
Registered: 2007-02-27
Posts: 290

Re: New to Arch. Wireless setup question.

Offline

#10 2008-03-12 08:44:26

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: New to Arch. Wireless setup question.

pogeymanz wrote:

Do you know what the daemon is called? Because I do have "networkmanager" in my daemons list in rc.conf, but it still doesn't load by itself. I have to summon it from the terminal.

Have a look in /etc/rc.d/ that's where all the daemons are stored. As I also said, NetworkManager is covered on the wiki, and the details are probably there too.

Offline

#11 2008-03-12 08:51:15

sH
Member
From: Braunschweig, Germany
Registered: 2007-05-02
Posts: 145

Re: New to Arch. Wireless setup question.

If you always use the same WLAN login and you don't need the feature to browse different WLAN networks that are around, then i suggest you use http://wiki.archlinux.org/?title=Autowifi
It's great. I had a lot of trouble with networkmanager, but autowifi is fast, reliable, stable, survives standby and you are ready within minutes with the mentioned Wiki-article.

Offline

#12 2008-03-13 00:56:47

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: New to Arch. Wireless setup question.

I don't know what I did differently, but I followed the network manager wiki and all is well. I'll post my rc.conf in hopes of helping someone in the future. Thank you all for all the help. big_smile

My wireless device is eth1.

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="US/Eastern"
KEYMAP="us"
CONSOLEFONT="lat2-16"
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(e100 mii bcm43xx snd-mixer-oss snd-pcm-oss snd-hwdep snd-page-alloc snd-pcm snd-timer snd snd-hda-intel soundcore)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="arch"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
eth0="dhcp"
eth1="dhcp"
WLAN_INTERFACES=(eth0 !eth1)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
NET_PROFILES=(home)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !network dhcdbd networkmanager netfs crond gdm hal fam acpid alsa)


# End of file

Last edited by pogeymanz (2008-03-13 00:57:16)

Offline

Board footer

Powered by FluxBB