You are not logged in.

#1 2008-04-03 18:02:10

Archerbee
Member
Registered: 2007-10-17
Posts: 75
Website

Problem with subtitles

Well i want to use greek subtitles to see a movie...The encoding is iso-8859-7 and it encodes correctly all the documents,but when i try to use it to subtitles the text is wrong!:(
I've tried it with vlc and mplayer and in many movies and with many subtitles,but always same...:(
Any suggestions?:/

Offline

#2 2008-04-04 08:32:08

lman
Member
From: CZ
Registered: 2007-12-18
Posts: 252

Re: Problem with subtitles

Did you configure the media players, too, to use that kind of encoding? I don't use gmplayer, just mplayer, because I couldn't configure the subtitles normally. I have sthing like this there (~/.mplayer/config):

subcp='windows-1250'
# # Set font encoding.
subfont=/usr/share/fonts/TTF/DejaVuSans.ttf
subfont-encoding=unicode
#
# # Set subtitle file encoding.
unicode=yes
utf8=yes

You should change only the subcp entry...
If no luck, try it in Xine, in the preferences there is a Subtitle tab (at first set in the gui tab, that you are Master of the Universe wink). And there set your encoding to iso8859-7, or sthing like that.

BTW. most of the subtitles you can get from the internet uses windows-1250 (cp1250) encoding...

Last edited by lman (2008-04-04 08:33:03)

Offline

#3 2008-04-05 12:11:16

Archerbee
Member
Registered: 2007-10-17
Posts: 75
Website

Re: Problem with subtitles

Tried to use xine but just when i select the greek subtitles it freezes...:(

Offline

#4 2008-04-05 17:17:37

unixNeophyte
Member
Registered: 2008-03-09
Posts: 26

Re: Problem with subtitles

directions and greek fonts for xine you can find here http://korgman.is-a-geek.net/htm/tut/ni … _fonts.php

for mplayer edit /etc/mplayer/mplayer.conf

#fontconfig = yes
#font = "Sans"
#subfont-text-scale = 3

Set a default subfont.ttf for mplayer. I like DejavuSans.ttf, so as a simple user

ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ~/.mplayer/subfont.ttf

Finally edit mplayer preferences

1 Subtitles & OSD. Set  encoding to Modern Greek (iso 8859-7

2 Font. Set /home/username/.mplayer/subfont.ttf and Encoding as unicode

Last edited by unixNeophyte (2008-04-05 17:18:12)

Offline

#5 2008-04-06 00:53:33

Archerbee
Member
Registered: 2007-10-17
Posts: 75
Website

Re: Problem with subtitles

The /etc/mplayer/mplayer.conf doesn't exist and just ignoring this step and do the others didn't help at all...Subtitles that cannot be read! sad

Offline

#6 2008-04-06 03:16:14

unixNeophyte
Member
Registered: 2008-03-09
Posts: 26

Re: Problem with subtitles

Archerbee wrote:

The /etc/mplayer/mplayer.conf doesn't exist and just ignoring this step and do the others didn't help at all...Subtitles that cannot be read! sad

create /etc/mplayer/mplayer.conf

Offline

#7 2008-04-06 09:45:20

lman
Member
From: CZ
Registered: 2007-12-18
Posts: 252

Re: Problem with subtitles

create /etc/mplayer/mplayer.conf

What for?? I thought mplayer config file is ~/.mplayer/config and when using gmplayer: ~/.mplayer/gui.conf, and the mplayerplug-in config file: ~/.mplayer/mplayerplug-in.conf.

Offline

#8 2008-04-06 14:29:28

carlocci
Member
From: Padova - Italy
Registered: 2008-02-12
Posts: 368

Re: Problem with subtitles

Archerbee wrote:

The /etc/mplayer/mplayer.conf doesn't exist and just ignoring this step and do the others didn't help at all...Subtitles that cannot be read! sad

Just restore it with this: just skim through it to check the configuration, even though I barely edited it.
Or you can reinstall mplayer.
Remember this is the system wide configuration which can be overridden via ~/.mplayer/config

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv,x11

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=alsa

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100


##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0     plain white fonts
# 0.75  very narrow black outline (default)
# 1     narrow black outline
# 10    bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
slang = en

# DVD: Play English audio tracks if available.
alang = en


# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

# Use libass to render fancy styled subtitles.
ass = yes

Offline

#9 2008-12-08 09:57:48

OBLiQUE
Member
Registered: 2008-12-04
Posts: 107
Website

Re: Problem with subtitles

i found a solution for vlc and mplayer

for vlc go tools > preferences
show settings > all
and then go Input / Codecs > Other codecs > subtitles
subtitles text encoding = iso-8859-7
and uncheck Formatted Subtitles

for mplayer just create the file ~/.mplayer/config and put this inside

stop-xscreensaver="yes"
sub-fuzziness=1
font=/usr/share/fonts/TTF/DejaVuSans.ttf
#with subfont-text-scale you can change the size of fonts
subfont-text-scale=3
subcp="iso-8859-7"

Last edited by OBLiQUE (2008-12-08 10:11:22)

Offline

Board footer

Powered by FluxBB