You are not logged in.

#1 2008-04-26 12:59:51

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Working Vmware 2.6.25 patches

Finally working Vmware patches!
Tested with Vmware Player 2.0.3_80004 and with Vmware Workstation .6.0.3_80004

vmnet and vmmon patches are adapted from patches from gentoo forum:
http://forums.gentoo.org/viewtopic-p-50 … ml#5066120

vmblock patch is made by myself big_smile

UPDATED:
http://blender6xx.ic.cz/pub/vmware/vmblock.patch
http://blender6xx.ic.cz/pub/vmware/vmmon.patch
http://blender6xx.ic.cz/pub/vmware/vmnet.patch

Old patches:
http://blender6xx.ic.cz/pub/vmware/vmblock-old.patch
http://blender6xx.ic.cz/pub/vmware/vmmon-old.patch

Last edited by 6xx (2008-05-03 15:52:33)

Offline

#2 2008-04-27 09:35:37

Venator85
Member
From: Italy
Registered: 2007-10-18
Posts: 61

Re: Working Vmware 2.6.25 patches

They worked, on VMware Workstation too! big_smile:D:D
Thanks!

I made an updated PKGBUILD for the vmware-workstation-modules package:

# Contributor: Alexander Fehr <pizzapunk gmail com>

# Change this to proper kernel release
_kernver=`uname -r`

pkgname=vmware-workstation-modules
pkgver=6.0.3_80004
pkgrel=1
pkgdesc="Kernel modules for VMware Workstation"
arch=('i686' 'x86_64')
url="http://www.vmware.com/products/ws/"
license=('custom')
depends=('kernel26')
conflicts=('vmware-player-modules' 'vmware-server-modules')
install=vmware-workstation-modules.install
if [[ $CARCH == "i686" ]]; then
  source=(VMware-workstation-6.0.3-80004.i386.tar.gz vmmon.patch vmblock.patch vmnet.patch)
#  md5sums=('57601f238106cb12c1dea303ad1b4820')
elif [[ $CARCH == "x86_64" ]]; then
  source=(VMware-workstation-6.0.3-80004.x86_64.tar.gz)
  md5sums=('d8d423a76f99a94f598077d41685e9a9')
fi

build() {
  cd $startdir/src/vmware-distrib/lib/modules/source

  # Build and install the kernel modules
  for module in vmmon vmblock vmnet; do
    tar xf $module.tar
    patch -p0 < $startdir/$module.patch
    make -C $module-only HEADER_DIR=/lib/modules/$_kernver/build/include || return 1
    install -D -m644 $module-only/$module.ko $startdir/pkg/lib/modules/$_kernver/misc/$module.ko
  done

  # License
  mkdir -p $startdir/pkg/usr/share/licenses/vmware-workstation-modules
  install -m644 $startdir/src/vmware-distrib/doc/{EULA,open_source_licenses.txt} \
    $startdir/pkg/usr/share/licenses/vmware-workstation-modules

  sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='$_kernver'/" \
    $startdir/vmware-workstation-modules.install
}

Offline

#3 2008-04-27 13:38:16

oliwer
Member
From: Paris
Registered: 2007-06-30
Posts: 153
Website

Re: Working Vmware 2.6.25 patches

Thank you both smile

Offline

#4 2008-05-03 11:04:20

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Working Vmware 2.6.25 patches

@Venator85: Thanks for this PKGBUILD. I'm having a problem, though.

I want to use VMware Workstation 6.0.3 build 80004 with kernel 2.6.25. Here's my procedure:

(1) Install VMware 6.0.3 as normal, but stop at the point where it asks if I want to run vmware-config.pl.

(2) Build the custom modules using your PKGBUILD, then install the custom vmmon, vmnet and vmblock modules using pacman -U vmware-workstation-modules-6.0.3_80004-1-i686.pkg.tar.gz.

(3) Run vmware-config.pl again. This time, though, I get an error saying that the vmmon, vmnet and vmblock modules are already installed, but not by vmware. It says to remove the modules, then try again.

Of course, if I remove the modules and try again, I'm back to square one, since the stock modules won't build again kernel 2.6.25.

@ 6xx: Thanks for posting the three patches, and for building the vmblock patch yourself. Besides trying the PKGBUILD that Venator85 wrote, I've also tried manual patching of vmmon.tar, vmnet.tar and vmblock.tar, using the three patches you posted. Although the patches apply successfully, I still can't get the modules to build against kernel 2.6.25.

Has anyone gotten this working for VMware Workstation 6.0.3 and kernel 2.6.25? What am I doing wrong?

Last edited by dhave (2008-05-03 11:08:24)


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#5 2008-05-03 11:24:00

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Re: Working Vmware 2.6.25 patches

Added kernel version control checks to patches.

2 dhave:
I'll try it with workstation soon.

Offline

#6 2008-05-03 15:48:34

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Re: Working Vmware 2.6.25 patches

So I've successfully tested it with Workstation 6.0.3.
I've used vmware-player-modules from AUR, from which I've removed sed line and I've added patches. Then I've build vmware-workstation (without any changes to PKGBUILD) package. vmware-config.pl runs succesfully.

PS. I used Reactos as guest system. My system is i686.

Offline

#7 2008-05-03 17:52:51

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Working Vmware 2.6.25 patches

6xx wrote:

So I've successfully tested it with Workstation 6.0.3.
I've used vmware-player-modules from AUR, from which I've removed sed line and I've added patches. Then I've build vmware-workstation (without any changes to PKGBUILD) package. vmware-config.pl runs succesfully.

O.K., I've got it working now. I was installing Workstation manually, i.e., by running 'vmware-install.pl'. When I installed Workstation via AUR, then it accepted the modules patched by AUR.

There are people over on the VMware communities workstation forum who'd love to be able to use these patched modules, but I imagine they're having the same problem I was having. I wonder if there's a switch so that vmware-config.pl can be made to accept the pre-installed, patched modules.

Either way, thanks very much. Everytime there's a new release of VMware, I get to enjoy this kernel wrestling!


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#8 2008-05-03 19:11:11

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Working Vmware 2.6.25 patches

Yikes! I've got my guest OS (WinXP Pro) up and running, but the clock goes 4x too fast and the CPU is recognized as a measly 155MHz (it's a core 2 duo 2.5GHz). When I load a Linux guest, the cursor jiggles like it's had 100 cups of coffee, and the keyboard produces a string of 4 or 5 characters when I depress a single key one time. It's impossible to enter a user password, for example.

I'll post over on VMware Communities and see if anybody knows. Meanwhile, it looks as if kernel 2.6.25 and WS 6.0.3 are not good companions. Maybe it's because kernel 2.6.25 has supposedly been made "friendlier" to virtualization hmm

Last edited by dhave (2008-05-03 19:15:28)


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#9 2008-05-04 05:31:22

whererun
Member
Registered: 2008-05-01
Posts: 7

Re: Working Vmware 2.6.25 patches

6xx wrote:

Finally working Vmware patches!
Tested with Vmware Player 2.0.3_80004 and with Vmware Workstation .6.0.3_80004

vmnet and vmmon patches are adapted from patches from gentoo forum:
http://forums.gentoo.org/viewtopic-p-50 … ml#5066120

vmblock patch is made by myself big_smile

UPDATED:
http://blender6xx.ic.cz/pub/vmware/vmblock.patch
http://blender6xx.ic.cz/pub/vmware/vmmon.patch
http://blender6xx.ic.cz/pub/vmware/vmnet.patch

Old patches:
http://blender6xx.ic.cz/pub/vmware/vmblock-old.patch
http://blender6xx.ic.cz/pub/vmware/vmmon-old.patch

so great work.
but I do not know how to use the patch to vmware workstation 6.0.3
and Can the patch works for vmware workstation 6.5 beta ?

I have use the Centos 5.1 with kernel 2.6.25 .
help me plz ,so thanks .

Offline

#10 2008-05-04 07:10:47

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Re: Working Vmware 2.6.25 patches

whererun wrote:

so great work.
but I do not know how to use the patch to vmware workstation 6.0.3
and Can the patch works for vmware workstation 6.5 beta ?

I have use the Centos 5.1 with kernel 2.6.25 .
help me plz ,so thanks .

ad 6.5 beta) I don't know

ad patching) untar module sources (they are in /usr/lib/vmware/modules/source/ and maybe also in /lib/modules/source) and patch them using
cd modulename-only && patch -Np1 < modulename.patch
Then make tarballs from the sources and replace old tar's with appropriate tar's made from patched sources. Run vmware-config.pl and thi is it! Ehmm... I know that it didn't work for dhave but I think this should work.

Offline

#11 2008-05-05 14:23:35

whererun
Member
Registered: 2008-05-01
Posts: 7

Re: Working Vmware 2.6.25 patches

6xx wrote:
whererun wrote:

so great work.
but I do not know how to use the patch to vmware workstation 6.0.3
and Can the patch works for vmware workstation 6.5 beta ?

I have use the Centos 5.1 with kernel 2.6.25 .
help me plz ,so thanks .

ad 6.5 beta) I don't know

ad patching) untar module sources (they are in /usr/lib/vmware/modules/source/ and maybe also in /lib/modules/source) and patch them using
cd modulename-only && patch -Np1 < modulename.patch
Then make tarballs from the sources and replace old tar's with appropriate tar's made from patched sources. Run vmware-config.pl and thi is it! Ehmm... I know that it didn't work for dhave but I think this should work.

Hi ,thanks

It work with 6.0.3 under kernel 2.6.25 and 2.6.25.1 .
but It do not works to 6.5B,
May you will make the patch for 6.5b ? please
and thanks so much .

Offline

#12 2008-05-13 16:04:34

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Re: Working Vmware 2.6.25 patches

whererun wrote:

Hi ,thanks

It work with 6.0.3 under kernel 2.6.25 and 2.6.25.1 .
but It do not works to 6.5B,
May you will make the patch for 6.5b ? please
and thanks so much .

I'm sorry, but I'm not going to do that. First, I don't have enough time because of school leaving exams. Second, I don't have license and I've wasted free 30-days license for 6.0.3 to test.

Offline

#13 2008-05-13 16:13:23

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Working Vmware 2.6.25 patches

whererun wrote:

It work with 6.0.3 under kernel 2.6.25 and 2.6.25.1 .
but It do not works to 6.5B,
May you will make the patch for 6.5b ? please
and thanks so much .

If you're talking about the 6.5 beta, it runs fine under kernel 2.6.25 without patching -- or at least it did in my case.


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#14 2008-05-14 16:08:17

whererun
Member
Registered: 2008-05-01
Posts: 7

Re: Working Vmware 2.6.25 patches

dhave wrote:
whererun wrote:

It work with 6.0.3 under kernel 2.6.25 and 2.6.25.1 .
but It do not works to 6.5B,
May you will make the patch for 6.5b ? please
and thanks so much .

If you're talking about the 6.5 beta, it runs fine under kernel 2.6.25 without patching -- or at least it did in my case.

oh? 6.5B works under kernel 2.6.25 ?
but when rum vmware-config.pl can not configure any modules with vmnet 
vmmon and vmblock .
Can share your kernel .config for me ?  so thanks !

Offline

#15 2008-05-14 16:51:34

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Working Vmware 2.6.25 patches

whererun wrote:
dhave wrote:
whererun wrote:

It work with 6.0.3 under kernel 2.6.25 and 2.6.25.1 .
but It do not works to 6.5B,
May you will make the patch for 6.5b ? please
and thanks so much .

If you're talking about the 6.5 beta, it runs fine under kernel 2.6.25 without patching -- or at least it did in my case.

oh? 6.5B works under kernel 2.6.25 ?
but when rum vmware-config.pl can not configure any modules with vmnet 
vmmon and vmblock .
Can share your kernel .config for me ?  so thanks !

Sure, I can send or post my kernel config. I'm thinking that I might have had to run any-any-update116 on the 6.5 beta, but I'm not sure.

Do you want me to send you the config file in a PM, or by e-mail, or what's best for you? It's about 80 kbytes.


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#16 2008-05-15 00:25:25

whererun
Member
Registered: 2008-05-01
Posts: 7

Re: Working Vmware 2.6.25 patches

dhave wrote:
whererun wrote:
dhave wrote:

If you're talking about the 6.5 beta, it runs fine under kernel 2.6.25 without patching -- or at least it did in my case.

oh? 6.5B works under kernel 2.6.25 ?
but when rum vmware-config.pl can not configure any modules with vmnet 
vmmon and vmblock .
Can share your kernel .config for me ?  so thanks !

Sure, I can send or post my kernel config. I'm thinking that I might have had to run any-any-update116 on the 6.5 beta, but I'm not sure.

Do you want me to send you the config file in a PM, or by e-mail, or what's best for you? It's about 80 kbytes.

so thanks .
Can you sent a mail to me ?
whererun@gmail.com

and how to use run any-any-update116 on the 6.5 beta ?
I have try the any-any-update116 on 6.5 beta ,but it is not works.
how do  it ?  thank you very much!

Last edited by whererun (2008-05-15 00:30:51)

Offline

#17 2008-05-19 14:01:09

Kaso_Da_Zmok
Member
Registered: 2007-11-01
Posts: 19

Re: Working Vmware 2.6.25 patches

I installed WKS 6.5 Beta onto Arch 2.6.25 a minute ago and i did not need any any any patch.

The installer finished and when i started vmware it asked for root to compile all modules.

It even shows a GUI with the compile status.

Now running, no patch needed.

Last edited by Kaso_Da_Zmok (2008-05-20 16:42:47)

Offline

#18 2008-05-20 16:38:25

Kaso_Da_Zmok
Member
Registered: 2007-11-01
Posts: 19

Re: Working Vmware 2.6.25 patches

I have tested WKS 6.5 Beta , WKS 6.0.4 and Server 1.0.6 today under kernel 2.6.25 and all worked fine without any patching required.

WKS 604 and Server 1.0.6 are not yet available.

The only problem i had was with loaded bluetooth module i  couldn't power on VM under WKS 6.5 and WKS 6.0.4 but did not have any problem with WKS 6.0.3 + any any patches

After i removed bluetooth from startup and rebooted both wks 6.5 and 6.0.4 worked fine.

Don't know the release dates for wks 6.0.4 and server 1.0.6.

Last edited by Kaso_Da_Zmok (2008-05-20 16:40:30)

Offline

#19 2008-05-26 10:24:12

voidzero
Member
Registered: 2007-06-21
Posts: 108

Re: Working Vmware 2.6.25 patches

I don't get it. I just use the package from AUR. When trying to do makepkg I get this:

==> Starting build()...
patching file vmmon-only/include/vcpuset.h
Using 2.6.x kernel build system.
make: Map '/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only' wordt binnengegaan
make -C /lib/modules/2.6.25-ARCH/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Map '/usr/src/linux-2.6.25-ARCH' wordt binnengegaan
make[1]: Waarschuwing: taakserver onbeschikbaar: -j1 wordt gebruikt.  Voeg '+' toe aan de ouderregel.
  CC [M]  /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o
In bestand ingevoegd vanuit /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                     vanuit /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                     vanuit /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                     vanuit /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:37:5: let op: "VMW_HAVE_EPOLL" is niet gedefinieerd
/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:43:5: let op: "VMW_HAVE_EPOLL" is niet gedefinieerd
In file included from /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                 from /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                 from /var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:60: fout: conflicting types for 'poll_initwait'
include/linux/poll.h:65: fout: previous declaration of 'poll_initwait' was here
/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:198: let op: initialization from incompatible pointer type
make[2]: *** [/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o] Fout 1
make[1]: *** [_module_/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only] Fout 2
make[1]: Map '/usr/src/linux-2.6.25-ARCH' wordt verlaten
make: *** [vmmon.ko] Fout 2
make: Map '/var/abs/local/vmware/vmware-workstation-modules/src/vmware-distrib/lib/modules/source/vmmon-only' wordt verlaten


Sorry for the Dutch localisation. What should I do, in heaven's name?

Offline

#20 2008-05-26 10:54:53

voidzero
Member
Registered: 2007-06-21
Posts: 108

Re: Working Vmware 2.6.25 patches

And with the provided pkgbuild from this topic, it solves nothing.

==> Starting build()...
patching file vmmon-only/include/vcpuset.h
Using 2.6.x kernel build system.
make: Entering directory `/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only'
make -C /lib/modules/2.6.25-ARCH/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.25-ARCH'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o
In file included from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:60: error: conflicting types for 'poll_initwait'
include/linux/poll.h:65: error: previous declaration of 'poll_initwait' was here
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:198: warning: initialization from incompatible pointer type
make[2]: *** [/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.25-ARCH'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only'

Offline

#21 2008-05-27 11:31:39

firewalker
Member
From: Hellas (Greece).
Registered: 2006-06-05
Posts: 457

Re: Working Vmware 2.6.25 patches

Is there a patch for vmware-workstation 5.5.6 and kernel 2.6.25 ?


Γίνε ρεαλιστής, μείνε ονειροπόλος ...

Offline

#22 2008-06-02 21:30:42

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Working Vmware 2.6.25 patches

just tested vmware-workstation 6.0.4-93057 and the module package needs only vmblock.patch  made by 6xx.

http://blender6xx.ic.cz/pub/vmware/vmblock.patch

Last edited by wonder (2008-06-02 21:32:17)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#23 2008-06-05 00:35:37

whererun
Member
Registered: 2008-05-01
Posts: 7

Re: Working Vmware 2.6.25 patches

wonder wrote:

just tested vmware-workstation 6.0.4-93057 and the module package needs only vmblock.patch  made by 6xx.

http://blender6xx.ic.cz/pub/vmware/vmblock.patch

so thanks ,it works for vmware workstation 6.0.4-93057.

hope vmware workstation 6.5.0 final come soon .

Offline

#24 2008-06-08 06:54:54

6xx
Trusted User (TU)
Registered: 2006-11-26
Posts: 22
Website

Re: Working Vmware 2.6.25 patches

voidzero wrote:

And with the provided pkgbuild from this topic, it solves nothing.

==> Starting build()...
patching file vmmon-only/include/vcpuset.h
Using 2.6.x kernel build system.
make: Entering directory `/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only'
make -C /lib/modules/2.6.25-ARCH/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.25-ARCH'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o
In file included from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/vmci_kernel_defs.h:26,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./common/vmciContext.h:19,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.h:21,
                 from /pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:84:
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:60: error: conflicting types for 'poll_initwait'
include/linux/poll.h:65: error: previous declaration of 'poll_initwait' was here
/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.c:198: warning: initialization from incompatible pointer type
make[2]: *** [/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.25-ARCH'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/pub/1/homedirs/void/Desktop1/vmware-aur-stuff/src/vmware-distrib/lib/modules/source/vmmon-only'

Sorry for late response, I have not had much time.
I see that there is some problem, but because it builds for me, I'm not able to find solution.
You can look there if it helps you.

Offline

#25 2008-06-09 09:55:10

voidzero
Member
Registered: 2007-06-21
Posts: 108

Re: Working Vmware 2.6.25 patches

Okay, thanks 6xx, I'll look at that. smile

Offline

Board footer

Powered by FluxBB