You are not logged in.

#1 2008-05-08 22:58:46

Registered: 2008-05-08
Posts: 3

[SOLVED] Custom kernel, init fails.

I've been trying to get xen (community/xen package) working for quite some time now and I'm quite stuck. Raid support is built in to the dom0 kernel but it was missing support for my sata chipset (sata_nv) so it didn't see my drives. I downloaded the xenified kernel sources from and recompiled the kernel with the dom0 config in /boot/. Now it sees the drives but init crashes with.

(had to type this so I skipped quite a lot of the dump and there might be typos)

Unable to handle kernel NULL pointer dereference at 0000000000000000 RIP:
[<ffffffff805a0f08>] netlink_insert+0x58/0x110
Call Trace:
[<ffffffff805a12a5>] netlink_bind+0xc5/0x220
[<ffffffff80585c59>] sys_bin+0x69/0xa0
[<ffffffff805860bc>] sys_setsockopt+0x6c/0xc0
[<ffffffff8020a8d8>] system_call+0x69/0x6d
[<ffffffff8020a870>] system_call+0x0/0x6d

This doesn't happen with the kernel provided in the package and the only thing that has been changed from the provided configuration is the sata driver. I'm really lost with this, if somebody knows how to build a working xen dom0 kernel I could use some insight. If you need more info just ask thou I don't have much to give since I don't have any kind of logs.

EDIT: Actually it might happen even with the provided kernel, I'm not sure if it gets that far before failing because it can't find my hds.
EDIT2: Changed the topic to a little more descriptive one since my questions doesn't really have anything to do with raid 5 tongue.
EDIT3: Changed topic as below it doesn't seem to have anything to do with xen.

Last edited by virus2547 (2008-05-10 01:20:28)


#2 2008-05-09 22:50:27

Registered: 2008-05-08
Posts: 3

Re: [SOLVED] Custom kernel, init fails.

Ok so I compiled vanilla 2.6.18 kernel with the same config as the xen kernel and it crashes so maybe it's the config sad. If anyone has PKGBUILD or working config for 2.6.18 kernel it'd be nice. I'll post my config in a bit.


Last edited by virus2547 (2008-05-09 22:55:35)


#3 2008-05-10 01:25:11

Registered: 2008-05-08
Posts: 3

Re: [SOLVED] Custom kernel, init fails.

Ok I finally managed to boot in to XEN. I modified the PKGBUILD for the xen package to generate the generic XEN kernel (no different kernels for dom0 and domU). Here's the PKGBUILD I used.

pkgdesc="a Virtual Machine Monitor (VMM)"
arch=(i686 x86_64)
depends=('iproute' 'bridge-utils' 'python' 'sdl' 'zlib' 'e2fsprogs' 'mercurial' 'patch')
source=($pkgver.tar.bz2 \ … r.tar.bz2)

build() {
  cd $startdir/src/xen-3.1-testing.hg

  mv ../linux-$_kernelver.tar.bz2 .

  make KERNELS="linux-2.6-xen" world || return 1
  make KERNELS="linux-2.6-xen" DESTDIR=$startdir/pkg install || return 1

  ( cd $startdir/pkg/etc && mv init.d rc.d ) || return 1
  rm -f $startdir/pkg/usr/share/man/man1/qemu-img.1* \
        $startdir/pkg/usr/share/man/man1/qemu.1* \
        $startdir/pkg/lib/modules/$_kernelver-xen/build \

I also did mkinitcpio -k 2.6.18 -g /boot/kernel26xen.img, don't know if that's needed but I'm not going to test it now tongue.


Board footer

Powered by FluxBB