You are not logged in.

#1 2008-05-17 12:31:49

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 338

[SOVLED][DON'T KNOW REASON]resume failed with "invalid resume device"

On one of my computer, when I set resume=/dev/disk/by-uuid/274e7efe-957c-453e-9a00-12618cf298f2 ,i got this error message when booting up, but if I set it to resume=/dev/sda2 (same partition as swap), there is no problem to resume from hiberation. I am quite sure the uuid is correct. I have double-checked it and can successfully mount swap when booting up without hiberation. However since I work it allright I didn't pay much attention.
  But I met the same problem with other computer, the question is on this one I have set a lvm2 partition, so I am totally at lost, I don't have any clue to solve the problem, anyone could help me? Thanks very very much.

Last edited by ganlu (2008-05-18 00:28:35)

Offline

#2 2008-05-17 14:10:06

bender02
Member
From: Germany
Registered: 2007-02-04
Posts: 1,328

Re: [SOVLED][DON'T KNOW REASON]resume failed with "invalid resume device"

The problem might be that uuid is recorded inside the partition (I think, since it depends on the filesystem), and hibernating overwrites the contents of that partition (it just starts at the beginning and goes on). So it can be that during resume (and only then), the uuid on the swap partition cannot be read.

Offline

#3 2008-05-17 14:46:53

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 338

Re: [SOVLED][DON'T KNOW REASON]resume failed with "invalid resume device"

Could be, but both fstab and menu.1st don't have uuid set, so I guess there may be a bug something in our kernel or other related package? (Dont 'have problem with Fedora 9)

/dev/cdrom /media/cdrom   auto    ro,user,noauto,unhide   0      0
/dev/dvd /media/dvd   auto    ro,user,noauto,unhide   0      0
/dev/mapper/VolGroup00-LogVol00 / ext3 defaults 0 1
/dev/mapper/VolGroup00-LogVol01 swap swap defaults 0 0
UUID=b68eb068-637e-445a-80a7-bb2c60468a6f /boot ext3 defaults 0 1

and menu.1st:

title  Arch Linux
root   (hd0,0)
kernel /vmlinuz26 root=/dev/mapper/VolGroup00-LogVol00 resume=/dev/mapper/VolGroup00-logVol01 ro vga=792
initrd /kernel26.img

Offline

#4 2008-05-18 00:27:45

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 338

Re: [SOVLED][DON'T KNOW REASON]resume failed with "invalid resume device"

I solved the problem. According to lvdisplay information I changed the line: "resume=/dev/mapper/VolGroup00-logVol01" to "resume=/dev/VolGroup00/LogVol01", it works. though I don't know why grub (or kinit) can regnize the root partition, but don't know resume (swap) partition.
lvdisplay:

--- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol01
  VG Name                VolGroup00
  LV UUID                qskTxP-8qhX-AtMV-6Wq5-yuGL-0xIy-dryZGX
  LV Write Access        read/write
  LV Status              available
  # open                 2
  LV Size                1.00 GB
  Current LE             32
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           254:1

menu.1st:

title  Arch Linux
root   (hd0,0)
kernel /vmlinuz26 root=/dev/mapper/VolGroup00-LogVol00 resume=/dev/VolGroup00/LogVol01 ro vga=792
initrd /kernel26.img

Offline

Board footer

Powered by FluxBB