You are not logged in.

#1 2004-06-04 09:57:49

marco
Member
Registered: 2004-06-04
Posts: 18

Init hangs on boot for a long time

I have:
- Athlon Processor
- Asus A7V Board
- ArchLinux 0.6
- Kernel 2.6.6 (standard install)

When i installed AL on my box with Kernel 2.6.3, init hang on boot up for a few minutes when checking filesystems (three of them). I thought it was too much time, so i edited fstab to not-check on boot. When i rebooted, it turned out to pass check-filesys ok, but then hung at ´syncing sys-clock' or something for several minutes.
I then updated the system, including the new standard kernel (2.6.6) with no improvement. Lately, sometimes the kernel seems to hang after a while of waiting too (num-lock doesn´t work anymore).
You see: it´s only the base-pkg-install, that causes problems already; no special things installed or modified

Additional info:
- I ran linux successfully with several distros on this box
- Sometimes (!) the kernel writes into the output of INIT at bootup, like

> ArchLinux 0.6 (Widget)
[...]
   ------------------
:: Mounting root read-only
usbxx [...] found <<<<< kernel message
usb[...] <<<<<<<<<<
:: Checking filesystems
:: ...

- I had some DMA problems on some devices wich also caused errors and fail of the boot (pre-INIT)

hdg: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdg: dma_intr: error=0x84 { DriveStatusError BadCRC }

or

hde: timeout waiting for DMA

i could switch dma´s using hdparm though

:arrow: Do you see any solution for this problem i have?

thanks in advance...

    marco

Offline

#2 2004-06-04 10:16:30

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Init hangs on boot for a long time

Can you post your fstab...

Make sure that config files are Ok.. lilo/grub etc....

Someone may spot the problem you have by your post....

Do not worry you will be Ok....

HTH

Mr Green


Mr Green

Offline

#3 2004-06-04 10:29:01

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

Here´s fstab

none                   /proc         proc      defaults            0      0
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
sysfs                  /sys          sysfs     defaults            0      0
usbdevfs               /proc/bus/usb usbdevfs  defaults            0      0

/dev/cdroms/cdrom0     /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/cdroms/cdrom0     /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/floppy/0          /mnt/fl   vfat      user,noauto,unhide      0      0

/dev/discs/disc1/part3 swap swap defaults 0 0
/dev/discs/disc1/part2 / ext3 defaults 0 1
/dev/discs/disc1/part5 /home ext3 defaults 0 1
/dev/discs/disc2/part5 /data ext3 defaults 0 1

and Grub´s menu.lst

timeout   5
default   0
color light-blue/black light-cyan/blue

# (0) Arch Linux
title  Arch Linux  Kernel 2.6
root   (hd1,1)
kernel /boot/vmlinuz26 root=/dev/discs/disc1/part2 ro

i can´t see any problems in these files, so i didn´t post them before.

Offline

#4 2004-06-04 12:45:32

Bobonov
Member
From: Roma - Italy
Registered: 2003-05-07
Posts: 295

Re: Init hangs on boot for a long time

Another question, before your modify to the init script the system (beside disck check) was loading fast or not?

Offline

#5 2004-06-04 12:50:34

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Init hangs on boot for a long time

emmm have you got a dvd & cd drive .... because you have cdrom0 twice in your fstab ??

Mr Green


Mr Green

Offline

#6 2004-06-04 13:12:41

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: Init hangs on boot for a long time

Mr Green wrote:

emmm have you got a dvd & cd drive .... because you have cdrom0 twice in your fstab ??

That's default after Arch install.
I have it too, although I don't have a DVD... didn't remove it yet.

Offline

#7 2004-06-04 15:14:13

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Init hangs on boot for a long time

Try turning off apic acpi and apm (noapic acpi=off apm=off in kernel line in grub config). Check for errors in all log files in /var/log and post them too.

Offline

#8 2004-06-04 16:42:45

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Init hangs on boot for a long time

Is your disk1 drive the master on the #1 ide interface?
If that is how it is setup, then your grub.lst is wrong.
root (hd1,1)
should be
root (hd0,1)

If your cd drive is the master and your hard drive is the slave device, or if you have multiple drives on your system (ie you are using the second drive for this os), then the grub.lst you have should be fine.

Grub documentation


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#9 2004-06-04 16:43:13

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

Bobonov wrote:

Another question, before your modify to the init script the system (beside disck check) was loading fast or not?

Yes, it has always been so, even right after install.

I now:
- removed the dvd entry in fstab
- booted with noapic acpi=off apm=off

It did not boot any better than before. Recently, only one of about ten boots is successful. Those nine totally hang up the kernel.

You asked me for logs...
- I still sometimes have these DMA problems.
- In /var/log/messages: `net.agent[386]: how do I bring up interfaces on this distro?' and `net.agent[386]: add event not handled'
- In /var/log/errors: `Symbol table has incorrect version number'

:arrow: So, the problem isn't solved yet sad

Offline

#10 2004-06-04 16:51:15

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Init hangs on boot for a long time

I had also the

hdg: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdg: dma_intr: error=0x84 { DriveStatusError BadCRC }

messages, but the kernel reset ide and dma didn't timeout, so dma was enabled alright. It happened only at bootup and everything seemed to just work fine. Until my cdrom broke, pulling down the whole ide with it. The cdrom was on the same cable as the HD, and since it's gone I don't get those kernel warnings at bootup anymore. Mind that those errors were for my hd, not cdrom, even as it seems that they were caused by the cdrom. So I would try to boot with only one device on each ide channel and see how that goes.

Offline

#11 2004-06-04 17:54:12

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Init hangs on boot for a long time

so, it was as if the cdrom was trying to force pio for the whole bus that it was on?
thus making the hd go squirrely?
weird..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#12 2004-06-04 18:58:05

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Init hangs on boot for a long time

No, DMA on the hd worked just fine, I only got those seekcomplete and badcrc errors at bootup. I'm not sure if those errors were there because the mobo can't handle two devices or because the cdrom was buggy and did weird things like confusing the mobo, all I know is that the cdrom died and that the errors disappeared when the cdrom was gone.

marco, you seem to have installed hotplug, try uninstalling or temporary disabling it (e.g. by replacing/renaming /sbin/hotplug).

- In /var/log/errors: `Symbol table has incorrect version number'

May mean that your System.map isn't correct. Or perhaps the modules.symbols isn't correct, orsomething else. Are you using the default Arch kernel?

Offline

#13 2004-06-04 19:47:16

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Init hangs on boot for a long time

i have on occasion gotten those DMA errors but very rarely since the drive that was giving them failed (twice). once i bought a new one the errors stopped. having smart detection on can sometimes makes drives act squirrely


AKA uknowme

I am not your friend

Offline

#14 2004-06-04 21:41:07

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

It seems to have gotten alot worse. I can't boot anymore. Where INIT paused before, it freezes completely now. The kernel won't respond.
So I reinstalled Arch (i have a question about it, see below), and after that rebooted and - it froze again. Standard kernel, standard packages, standard everything. No modifications at all.
I still sometimes have those DMA errors (during install as well: `hde: timeout waiting for DMA'), but i still don't know whether it has anything to do with it or not...

i3839: what do you think, hotplug has to do with this?

Here's the question about install:
When i parition manually, i'll have to select the mountpoints after, right? I get asked for swap, root, and additionals. I don't get asked for /boot! Does that mean, i have to mention it at `additionals' or not at all? Might that be the reason for my problems (i did not consider it at `additionals')?

Offline

#15 2004-06-04 22:43:16

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Init hangs on boot for a long time

Maybe you just have hardware problem with your udma cable (bad crc errors)? Please try to remove it and plug it again or even better replace it with new the one if it's possible.
And add another option to kernel boot parameters: ide=nodma and reboot - any dma errors still? AFAIK you can also turn off dma for any given drive like this hdb=nodma - but first try to turn off dma for all ide devices.

Maybe google has some answers too - lots of links?
http://www.google.com/search?q=dma_intr … 8&oe=utf-8
http://groups.google.com/groups?q=dma_i … &scoring=d

Offline

#16 2004-06-04 23:51:29

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Init hangs on boot for a long time

marco wrote:

I don't get asked for /boot! Does that mean, i have to mention it at `additionals' or not at all? Might that be the reason for my problems (i did not consider it at `additionals')?

If I recall correctly (been a few days since an install  wink ), you first get asked for swap, then for /, then you get asked for anything else. Chooose the first partition then, and it will prompt for a mount point. I think I recall the /home was the default. Just change it to /boot.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#17 2004-06-04 23:52:43

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Init hangs on boot for a long time

As far as I know Arch doesn't use a seperate partition for boot, but even if that was the case, then still that wouldn't be the problem because you don't need /boot for anything (only the bootloader needs it).

Just that you know, reinstalling hardly ever helps fixing any problem with Linux, it's always better to find out what went wrong and fix it the good way. Getting rid of the problem by upgrading is another matter though.

To make debugging as easy as possible I would disable hotplug and other stuff, and boot with init=/bin/bash as kernel parameter. I would also try to boot with only the hd with root on it enabled (plug out the power cable of the other devices or something).

If it got worse and you didn't really changed anything, then it's probably some hardware problem. Instead of buying a new ide cable it's better to try the one that currently works for sure, or the other one at least.

Just try one thing at a time and don't do anything rash.

Offline

#18 2004-06-05 01:44:21

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Init hangs on boot for a long time

i understand grub can have trouble booting if you are trying to boot from a slave drive. i cannot remember if i read hear or on irc. but that is one thing i can think of when i look at your menu.lst


AKA uknowme

I am not your friend

Offline

#19 2004-06-05 07:34:34

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

Alright.

- I checked cables, but it didn't get better (did not alter the cable setting, just checked)
- i used ide=nodma ...

AND IT WORKED!!! THANK YOU LANRAT!!! big_smile

So i didn't check init=/bin/bash, since it worked. I also think (hd1,1) is okay, even though i don't know what it really means.

Now can anybody tell me, what could be wrong with my DMA stuff? The think is, i have a Asus A7V Mainboard which has an ATA66 AND an ATA100 controller. I can configure the ATA66 controler (dma, pio, ...) from the BIOS but i can't control anythin of ATA100 there, for a reason that is unknown to me. Here's my hardware 'plan':
ATA66 1 Master ASUS CD-S500/A /dev/cdrom
ATA66 1 Slave None
ATA66 2 Master WDC WD300BB-00AUA1 [unimportant win partition *sorry*]
ATA66 2 Slave PLEXTOR CD-R PX-W1210A /dev/cdrom1
ATA100 1 Master IBM-DTLA-307030 /, /home <<<< important partitions here
ATA100 1 Slave None
ATA100 2 Master WDC WD800BB-00CAA1 /data
ATA100 2 Slave None

so, because i boot from ATA100 1 Master, i cannot have that slave-grub problem you (sarah31) mentioned, can i?

I would like to thank all of you guys for helping me on this. You're really great!

But still my DMA problem seems not to be solved. I don't want to buy a new cable, if not absolutely necessary (costs about 30$ coz of UATA100). Uhh, i figured out that it is a kernel problem, isn't it? It's now definately not INIT. I think i'll build a custom kernel and i'll see whether that works or not. Maybe you have some more ideas?

Offline

#20 2004-06-05 11:24:35

Gyroplast
Member
From: Germany
Registered: 2002-09-03
Posts: 166
Website

Re: Init hangs on boot for a long time

Just a quick nudge in the right direction:

For decent DMA support, you should whack Google for a while with your exact mainboard model number or do whatever else is necessary to find out exactly what IDE chipset the board is using. Then you can go about and see if that chipset has any known problems, who's responsible for fixing it, etc. The Kernel mailing list often is a good google hit. wink

Since it worked with other distributions, there shouldn't be any unsolvable problems or waiting for Godot^Wkernel fixes. When you identified the culprit, and can run your system with DMA support just fine, make sure to TELL US, so we know the FIX as well, for any other poor chaps experiencing this problem. Consider it as service payment. smile


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert

Offline

#21 2004-06-05 11:37:57

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Init hangs on boot for a long time

TRy booting with dma enabled but without the Master WDC WD800BB-00CAA1 connected, perhaps they conflict in some way (different dma speeds etc).

Offline

#22 2004-06-05 19:54:10

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Init hangs on boot for a long time

Sorry for posting late but I couldn't do it ealier. I'm glad that you can now at least run arch.

Aha! Your mainboard has via chipset and promise raid controller, right? They may be the source of your problems (if you are sure that hardware - cables and hdds - is not the problem).

Now some proposals:

1. You can try to insctruct kernel to use dma 66 for given ides. replace ide=nodma with ide0=ata66 ide1=ata66 ... change it according to your hardware/bios setup. I never tried this so no guarantee it will help.

2. There are some more advanced suggestions for your mainboard from mandrake users:
http://www.mmmchen.de/a7v133_eng.html
http://216.239.59.104/search?q=cache:fT … lr=lang_en

3. Unofficial Asus A7V and Linux ATA100 Quasi-Mini-Howto http://www.geocities.com/ender7007/index.html

4. Collection of links about Asus A7V problems http://www.computer-hardware-directory. … oblem.html

5. Install kernel 2.4.26 (pacman -S kernel24 it can safely coexist with kernel26 in arch), add new grub config line,.... and try it. Problems with your mainboard seems to affect many linux users. Here is some fresh kernel bug for example: http://bugzilla.kernel.org/show_bug.cgi?id=2494

6. Asus mainboards have their own usenet group: http://groups.google.com/groups?hl=en&l … board.asus

That's it for now. Please tell us if anything of the above helps or not.

Offline

#23 2004-06-06 08:32:21

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

I've looked at all of your links, lanrat. Some of them i have already seen (I was asking google as well). Most interesting is the bugreports here:
http://bugzilla.kernel.org/show_bug.cgi?id=2494

It seems it's really a bug of the kernel. They had the problem with both the 2.6.3 kernel (standard arch 0.6) and the 2.6.6 (my upgrade, latest) and presumably the ones between. It has been asked for higher priority for this bug fix, so maybe in 2.6.7 we (owning a Promise ATA100 controller) won't have those problems anymore.
One strange thing though: All bugreports mentioned, that the errors only occured on heavy disk load. I had it already, when the kernel booted, so no programs were running. Well, INIT maybe.
:arrow: Does anyone know, whether there is heavy disk load on Arch startup (INIT)? Other distributions seem not to have problems on boot.

Well, lanrat, i haven't tried your suggestions yet (kernel24, ide0=...), but I will... And yeah, i didn't forget your tipp, i3839. Thanks.

For Gyroplast i have also the output of lspci:

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
00:04.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 10)
00:04.2 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:04.3 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:04.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0b.0 Ethernet controller: Macronix, Inc. [MXIC] MX987x5 (rev 20)
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20265 (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5961 (rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5941 (rev 01)

I'll look into your suggestions as soon as I can.
What would really interest me: Am i the only one on this board having these problems? Or say: Such a big problem with it?

Offline

#24 2004-06-06 10:13:01

marco
Member
Registered: 2004-06-04
Posts: 18

Re: Init hangs on boot for a long time

OK. I have tried several things you suggested me:
- parameters ide0=ata66 ide1=ata66: didn't work, same dma timeouts
- kernel24: SURPRISE, DIDN'T WORK ALSO! How's that?
- unplug Master WDC WD800BB-00CAA1: error, could not mount root anymore (???) "Unknown filesystem." (I think it was that message)

Well, the strangest thing seems to be the non-working kernel 2.4. The bug reports only mentioned 2.6.x and said, that 2.4 worked perfectly. This is something new then. Is it not?
Lanrat: Do you think I should post to http://bugzilla.kernel.org/show_bug.cgi?id=2494? I fear not to be geek enough to do that...

Offline

#25 2004-06-06 12:37:39

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Init hangs on boot for a long time

Yes! I think you should add your info to the bug report. Bug reports are not only for geeks :-) Nobody is going to kill you for that - everything suggests that this bug is also your case. Moreover the ide code developer asks for more information because he doesn't own this kind of hardware. I suggest posting there at least this info:

1. Archlinux with stock kernel 2.6.6/2.4.26: during boot errors with dma timeout - unable to boot at all or 1/10 is a successful booting.
2. Your lspci output and fstab
3. Workaround: set ide=nodma at kernel boot parameters.
4. Links to some pages describing detailed technical specification of your mainboard if you know them.

or something like that. Maybe others would suggest adding some more info.

Some people report to have same problems with 2.4 and even if they don't it's because their 2.4 kernels disable dma automatically so I think it's not different than setting ide=nodma. Those different results may be connected with different hardware configurations - I think some people suggest that errors stop when you do not use promise controller at all and all disks are controlled only by via chipset.

PS. You could also try adding ide2=ata66 and ide3=ata66. In twm's tur you can find smartmontools which could be helpful for diagnosing hardware, too.

Offline

Board footer

Powered by FluxBB