You are not logged in.

#1 2004-06-05 21:35:52

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

gcc 3.4 doesnt work with old *mm packages.
I really hope to have those packages updated soon by package maintainers. I understand that we have exams and I (and others maybe) can wait, but plz don't forget that. [btw new bugfix version of GTK+ was out, so I expect new version of *mm in this week]

no the *mm has a new seperate source file. see
www.gtkmm.org
that should also be added to the new pkg 'group'

thankszzzzzz

Offline

#2 2004-06-05 21:48:01

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

I've tried building the app from the tutorial (simple.cpp I think it is called) and I also got some errors. At first, I thought some dependencies were not met. I've rechecked everything and there was no problems with them.

Then, I looked at the GtkMM packages' version in the Arch Repository and I saw how old they are. They indeed should be updated. I see that the gtkmm1 (gtk1) packs are kept updated. Why doesn't it happen the same with the gtkmm (gtk2) packs?

Lots of thanks and good luck with your exams!

Offline

#3 2004-06-15 12:06:51

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

well..?
gtkmm app don't compile with gcc 3.4
we need the latest version. I don't understand who the maintainer is and why he's not building the new pkg.
I really hope that wxpython and gtkmm don't have the same maintainer because the first said to me he's travelling in America

Offline

#4 2004-06-15 12:16:54

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

Why don't you go see from the PKGBUILD's who the maintainer is?

Offline

#5 2004-06-15 15:36:48

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

never mind looking in the PKGBUILD it should show on the web page who maintains it and from there you can flag it out of date. some maintainers take a long time to get their act together (i posted bugs about transcode and related packages and i don't expect them to be "fixed" for some time ... um ..... actually a long time.)


AKA uknowme

I am not your friend

Offline

#6 2004-06-20 00:48:25

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: gtkmm (and *mm) extra old in AL (gcc 3.4 doesn't work)

There hasn't been much progress in gnome in arch last weeks. The problem with gtkmm is that the old versions worked with the newerk gnome. Currently we have only one package that depends on gtkmm and such, and breaks with the newer versions of gtkmm and libsigc++.

I told the maintainer there was no need to update these packages. But once arch migrated to gcc 3.4, there's need for updated packages to make these useful. The maintainer is very busy at the moment, so I'm taking up these builds very soon, you'll hear from me when I have them done (requires some extra things that are not in arch already, so it's not only increasing version numbers that matter)

Offline

Board footer

Powered by FluxBB