You are not logged in.

#1 2008-06-01 22:06:15

Bralkein
Member
Registered: 2004-10-26
Posts: 354

No loopback devices (/dev/loop#)[solved]

Hi,

I seem to be missing the /dev/loop0, /dev/loop1, etc. devices. This means that when I try to mount a filesystem image to a folder (with -o loop) mount complains about the missing loopback devices and the mount fails. Does anyone else have the same problem? Does this need to be reported? Thanks in advance.

edit: I found the problem myself. Sorry!

Last edited by Bralkein (2008-06-01 22:07:25)

Offline

#2 2008-06-02 15:37:05

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: No loopback devices (/dev/loop#)[solved]

would you mind explaining how you got it to work? I have the same problem. thanks

Offline

#3 2008-06-02 15:47:59

sirocco
Member
Registered: 2008-03-10
Posts: 147

Re: No loopback devices (/dev/loop#)[solved]

as root:
modprobe loop

Offline

#4 2008-06-02 16:10:32

bender02
Member
From: Germany
Registered: 2007-02-04
Posts: 1,328

Re: No loopback devices (/dev/loop#)[solved]

Or add 'loop' to the MODULES files in /etc/rc.conf. It has been explained on the frontpage news when the new kernel hit the core repo, and discussed a few times on the forums.

Offline

#5 2008-06-02 16:21:32

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: No loopback devices (/dev/loop#)[solved]

thanks, must have missed this...

Offline

#6 2014-06-22 21:45:15

digitally404
Member
Registered: 2013-11-24
Posts: 12

Re: No loopback devices (/dev/loop#)[solved]

@sirocco:
That solution is great and works... but only temporarily.

In order for the system to boot with the loopback devices permanently, just add a file called loopback-dev.conf under /etc/modules-load.d/ with the following contents:

loop

(Source https://wiki.archlinux.org/index.php/kernel_modules)

Offline

#7 2014-06-22 21:48:29

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,150
Website

Re: No loopback devices (/dev/loop#)[solved]


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB