You are not logged in.

#1 2004-06-09 14:30:44

From: Oslo, Norway
Registered: 2003-11-23
Posts: 169

Can't run or windowmaker-cvs from [gnustep]

This one is probably for tehdely as it relates to two packages I installed from his GNUstep repo.

I wanted to give the desktop manager a shot and installed it. Because it requires libwraster I installed windowmaker-cvs which, in contrast to the wmaker package from current, includes this library. This also meant an updated wmaker and that the was moved to the same place as other GNUstep apps on Arch, so this was fine with me.

But none of the apps worked! When I run /opt/GNUstep/System/Applications/ as root (or a normal user) X starts, but then exits without any abnormal messages, just as if Login exits before displaying a panel. I read somewhere that it needs to find a working XF86Config, but creating a link to XF86Config-4 didn't help.

After the upgrade, wmaker didn't work either. When running startx I get:

WMCreateFont: sans:pixelsize=12
wmaker fatal error: got signal 11

WMCreateFont: sans:pixelsize=12

Any ideas? No other packages from [gnustep] are installed.

All of your mips are belong to us!!


#2 2004-06-26 13:01:29

Registered: 2004-02-20
Posts: 148

Re: Can't run or windowmaker-cvs from [gnustep]

Yes, it is an embarrassing bug  :oops:

As of right now, in order to run GNUstep applications, you need my windowmaker-cvs, but you then can't use WindowMaker  wink

I am speaking to a WindowMaker dev right now about this; appears some stupidity of my own may be at fault  :shock:

Here is hoping for me sorting out either tomorrow or the day after  big_smile

[Arch GNUstep Repository] [ PKGBUILDS ]
Server =[/code]


Board footer

Powered by FluxBB