You are not logged in.

#1 2008-06-22 20:35:23

ThomasAdam
Member
From: Southampton, England
Registered: 2005-10-26
Posts: 147

rxvt-unicode with GNU screen (256 colour problem)

Hello all,

I'm wondering if someone can give me a few tips.  I've compiled rxvt-unicode with 256 colour support which is working fine.  However, trying to use urxvt with GNU Screen (which is also compiled to use 256 colours according to the PKGBUILD) seems to be failing.  You can see a screenshot of it here:

http://edulinux.homeunix.org/~n6tadam/s … erence.png

The top terminal shows urxvt displaying a full 256 colour pallette.  The lower urxvt instance is running screen, and the colour palette is not the same -- I'd expect it to be, wouldn't you?

In my ~/.screenrc I have:

term screen-256color

Set -- as is evident from the screenshot.  I have tried setting in my ~/.Xdefaults file the following (ensuring I run "xrdb -merge ~/.Xdefaults" afterwards):

URxvt*termName: rxvt-256color

But this seemingly has no effect.  Indeed, the reason I ask is because my ~/.vimrc is running a 256 colour scheme which works fine in urxvt outside of screen, as well as xterm.  Oddly enough though, the same vim colour scheme works fine with xterm running inside screen - it's just there's seemingly something with urxvt + screen which it doesn't like.

If anyone has any ideas, I'd be greatful, since I've tried everything I can think of.

Kindly,

-- Thomas Adam

Offline

#2 2008-06-23 03:30:01

N30N
Member
Registered: 2007-04-08
Posts: 273

Re: rxvt-unicode with GNU screen (256 colour problem)

Are you using the package from AUR? As I just checked with the 256colors2.pl script and it worked fine (even with TERM=screen).

I do keep the following in my .vimrc for when I'm using other peoples systems. wink

if &term =~# '^\(screen\|xterm\)$'
    set t_Co=256
endif

Offline

#3 2008-06-23 05:25:04

ThomasAdam
Member
From: Southampton, England
Registered: 2005-10-26
Posts: 147

Re: rxvt-unicode with GNU screen (256 colour problem)

N30N wrote:

Are you using the package from AUR? As I just checked with the 256colors2.pl script and it worked fine (even with TERM=screen).

I do keep the following in my .vimrc for when I'm using other peoples systems. wink

if &term =~# '^\(screen\|xterm\)$'
    set t_Co=256
endif

I am using that package yes -- and vim is already setup to use t_Co=256 in this case --- again, the colourscheme in Vim outside of screen works fine (setup to use 256 colours) within this terminal.  Inside it, it's bodged, as is evident from the colour cube screenshot I posted in my initial thread.

Any further ideas welcome,

-- Thomas Adam

Offline

#4 2008-06-23 17:55:09

N30N
Member
Registered: 2007-04-08
Posts: 273

Re: rxvt-unicode with GNU screen (256 colour problem)

I've done some tests and the only way I can reproduce the the the same colours your getting in screen is by setting TERM=rxvt (but the package has TERM=rxvt-256color by default). See if you have any success starting screen like so...

TERM=rxvt-256color screen

Edit: damn typos

Last edited by N30N (2008-06-23 19:35:48)

Offline

#5 2008-06-23 18:33:13

ThomasAdam
Member
From: Southampton, England
Registered: 2005-10-26
Posts: 147

Re: rxvt-unicode with GNU screen (256 colour problem)

N30N wrote:

Ok I've done some tests ant the only way I can reduce the the the same colours your getting in screen is by setting TERM=rxvt (but the package has TERM=rxvt-256color by default). See if you have any success starting screen like so...

TERM=rxvt-256color screen

Sigh --- still the same blocky colours.

What's even more perplexing is that using the same packages from AUR on my machine at work yields no problem.at all.  I start urxvt, I start screen, I get 256 colours in both.

Really frustrating -- *something* has to be different, but I am buggered if I know what.  AFAIK there really isn't anything, but there has to be.

-- Thomas Adam

Last edited by ThomasAdam (2008-06-23 18:47:24)

Offline

#6 2008-06-23 19:44:23

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: rxvt-unicode with GNU screen (256 colour problem)

I got this prob too, but to lazy atm to fix it.

pic

Guessing which of the sessions that are running in screen should be a no brainer...
$TERM is set to screen for screen, and rxvt-unicode when not.

Last edited by Mr.Elendig (2008-06-23 19:49:44)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#7 2008-06-24 06:32:43

dolby
Member
From: 1992
Registered: 2006-08-08
Posts: 1,581

Re: rxvt-unicode with GNU screen (256 colour problem)

How exactly did you compile urxvt with 256 color support? Did you use the PKGBUILD from AUR?


There shouldn't be any reason to learn more editor types than emacs or vi -- mg (1)
[You learn that sarcasm does not often work well in international forums.  That is why we avoid it. -- ewaller (arch linux forum moderator)

Offline

#8 2008-06-24 07:13:08

ThomasAdam
Member
From: Southampton, England
Registered: 2005-10-26
Posts: 147

Re: rxvt-unicode with GNU screen (256 colour problem)

dolby wrote:

How exactly did you compile urxvt with 256 color support? Did you use the PKGBUILD from AUR?

I did yes, which automatically includes the patching and ./configure'ing  - no tweaks on my part.

-- Thomas Adam

Offline

#9 2008-07-13 04:16:41

Evanlec
Member
From: NH, USA
Registered: 2007-12-16
Posts: 140
Website

Re: rxvt-unicode with GNU screen (256 colour problem)

so any more progress on this?
I'm experiencing this problem as well, though I don't have this problem if I use xterm
I'm running the rxvt-unicode-256color pkg from aur as well

Offline

#10 2008-07-13 11:48:42

rson451
Member
From: Annapolis, MD USA
Registered: 2007-04-15
Posts: 1,233
Website

Re: rxvt-unicode with GNU screen (256 colour problem)

i had this same problem today, and with the help of the everpresent MrElendig in #archlinux, i've found that the following line in .screenrc fixed it.

terminfo rxvt-unicode 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm'

archlinux - please read this and this — twice — then ask questions.
--
http://rsontech.net | http://github.com/rson

Offline

#11 2008-07-13 12:34:18

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: rxvt-unicode with GNU screen (256 colour problem)

I only pointed the way, you are the one who digged trough terminfo to get the options to set tongue


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#12 2008-11-15 07:12:44

andywxy
Member
From: Winnipeg, Canada
Registered: 2007-09-27
Posts: 36

Re: rxvt-unicode with GNU screen (256 colour problem)

For me the line rson451 has mentioned doesn't work, however I use this one solved the problem:

terminfo rxvt* 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm'

Offline

Board footer

Powered by FluxBB