You are not logged in.

#1 2008-07-06 01:31:27

windowbreaker
Member
Registered: 2008-06-18
Posts: 46

'pacman -Syu' messed up my system fonts (all square boxes now)

You can see a screenshot here http://i317.photobucket.com/albums/mm38 … enshot.png

I use gnome for my desktop.  What happened is that immediately after finished updating, all my fonts now look like square boxes.  Not sure how to fix this, but it's making it quite hard to use my desktop.  Any ideas how to fix this?

After rebooting, I tried re-running locale-gen in case that was the problem, but it didn't help.

Offline

#2 2008-07-06 02:01:14

crouse
Arch Linux f@h Team Member
From: Iowa - USA
Registered: 2006-08-19
Posts: 903
Website

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

What does your /etc/rc.conf file look like right at the top ??

mine is :

LOCALE="en_US.iso88591"
HARDWARECLOCK="localtime"
TIMEZONE="US/Central"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP="us.map.gz"
USECOLOR="yes"

Offline

#3 2008-07-06 02:36:19

windowbreaker
Member
Registered: 2008-06-18
Posts: 46

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Canada/Pacific"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

Also, I verified this is a system-wide issue, not my personal configuration.  I did this by creating a new user and starting gnome, same problem.  I also installed blackbox and the problem is not affecting blackbox at all.

Offline

#4 2008-07-06 04:43:35

windowbreaker
Member
Registered: 2008-06-18
Posts: 46

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

Well, I'm just removing all of 'gnome' and 'gnome-extra' and going to reinstall it all.  I don't even know if this will actually fix anything, but I don't know what else to try.

What a pain!!  I come from Slackware, so naturally I LOVED pacman on archlinux.  Until now, I havent' had a problem, but I gotta tell you, I hate to think this could happen whenever I upgrade my system.

So to all you Arch Guru's, what could I have done to prevent this?  Or better yet, what can I do in the future when I run 'pacman -Syu' to prevent such a f****** disaster???

Last edited by windowbreaker (2008-07-06 04:45:09)

Offline

#5 2008-07-06 16:43:00

carlocci
Member
From: Padova - Italy
Registered: 2008-02-12
Posts: 368

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

Windowsbreaker, maybe you could start by telling what packages you upgraded?
Do you have any fonts installed?
Did you perform some black magic with fonts?

Offline

#6 2008-07-06 17:53:20

hacosta
Member
From: Mexico
Registered: 2006-10-22
Posts: 422

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

I highly doubt reinstalling gnome would actually do anything, since blackbox is not affected, have you tried just choosing another font in gnome's font thing

Offline

#7 2008-07-07 21:58:45

heleos
Member
From: Maine, USA
Registered: 2007-04-24
Posts: 678

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

Not sure if you're still having the problem, but I recently had a similar problem. I believe it was related to pango. I ran pidgin from a console, and it said something about running a command in pango:

pango-querymodules '/etc/pango/pango.modules'

fixed it for me

EDIT:

When I tried to run it as normal user, it said permission denied. When I tried to use sudo, it also said permission denied. The only way I got it workng was to actually su - into root and run it.

Last edited by heleos (2008-07-07 22:00:25)

Offline

#8 2008-07-08 02:51:44

buttons
Member
From: NJ, USA
Registered: 2007-08-04
Posts: 620

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

I believe the command is

pango-querymodules > '/etc/pango/pango.modules'

And the > is why you can't do it from sudo.  Just doing something like

pango-querymodules > test
mv test /etc/pango/pango.modules

will work (assuming your user has write privs to the current folder)

Last edited by buttons (2008-07-08 02:52:18)


Cthulhu For President!

Offline

#9 2008-07-12 20:22:43

windowbreaker
Member
Registered: 2008-06-18
Posts: 46

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

hacosta wrote:

I highly doubt reinstalling gnome would actually do anything, since blackbox is not affected, have you tried just choosing another font in gnome's font thing

I fixed this by uninstalling gnome, all config files for pkg's removed, their dependencies, and all packages that depend on those - with the following command

pacman -Rscn gnome

This removed A LOT of packages.  Then I had to reinstall gnome and my fonts were once again readable. 

Before anyone tells me how stupid I was for doing that, or how there may have been a simpler theoritical solution - realize that I use my computer for work daily.  I had made a few posts and wasn't getting the help I needed so I had to figure something out.  I tried removing gnome and all it's packages without the '-n' option (config files), but that didn't work.  So I reloaded gnome, then retried with the '-n' option and that did work.

I googled this and apparently many other people had this problem with gnome (not Arch-specific), but nobody gave any workable solutions to any of them either.  Hopefully someone smarter than me can comment on the true cause of this, and maybe deduce a better solution - as I am sure some other poor sap will run into the same problem and surely come across this thread.

I appreciate everyone's input on this, and hopefully someone will chime in here with a much simpler solution that wont cause as much trouble as it did for me.

cheers.

Offline

#10 2008-07-13 02:41:28

tigrmesh
IRC Op
From: Florida, US
Registered: 2007-12-11
Posts: 794

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

Congratulations in fixing the problem.  Would you please mark this thread as solved?  Edit your first post.  Thank you.

Offline

#11 2009-04-19 23:02:51

sideside
Member
From: Saskatoon,SK,Canada
Registered: 2008-07-30
Posts: 22
Website

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

I had the same problem.    resynced gnome and GTK and a few other things.. and all my fonts when to  [] [] [] [] [] boxes.

the above code workes!  just had to run it and reboot and my fonts are back.

su root
pango-querymodules > '/etc/pango/pango.modules'

also filled my /tmp to the brim with 3gb of log files when this happened. Related or not, I had to delete them out before basically anything would work.



-=IN ARCH WE TRUST=-

Last edited by sideside (2009-04-19 23:03:18)

Offline

#12 2010-03-06 16:17:27

train
Member
Registered: 2007-03-17
Posts: 34

Re: 'pacman -Syu' messed up my system fonts (all square boxes now)

I had ridicoulously small fonts in gtk applications like firefox, thunderbird, gtk-demo, gtk-chtheme.

I played a bit with xrandr a few hours ago and just forgot about it, but this seems to have caused these problems.  The following command resolved my issues:

xrandr --dpi 96

Offline

Board footer

Powered by FluxBB