You are not logged in.

#1 2008-07-21 14:08:36

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Xfce SVN repo [closed]

After my recent DE disappointment (I'm looking at you, KDE 4.1!) I looked for a new DE, tried Xfce again and fell in love. But as I encountered a small bug that was already fixed in the svn repo, I wanted to use that - but there was no Arch repo! What shame! So here it is. wink

[muflax-xfce4-svn]
Server = http://www.stud.uni-karlsruhe.de/~uvcal/xfce4-svn/$ARCH/
#choose ARCH=i686 or ARCH=x86_64

It includes not all plugins from xfce4-goodies (I'm lazy, but perhaps I'll include the rest later. Just poke me enough if you miss anything. °ω°). They are just the official PKGBUILDs svn-ified and built, so there's nothing really noteworthy about them. You can use the groups xfce4-svn and xfce4-goodies-svn to install them. thunar-notrash includes a patch to circumvent the trash can because it's an abomination before the Lord. wink

I will try to update them daily (versionitis...). It only takes around 40 minutes to do a complete build (take that, KDE!), so I should find the time for it.

It's my first repo, so it might break occasionally. Have fun. ^^

Edit: The adress has slightly changed as I'm now building x86-pkgs as well.

Edit 2: If you have shutdown issues, check page 3, please. smile

Edit 3: The menu editor has been deprecated. Check http://wiki.xfce.org/howto/customize-menu on how to change the menu from now on.

Important edit 4: The release of Xfce 4.6 is almost here and marks the end of this repo. I don't use Xfce anymore, so I'm not in any position to make sure the whole thing even starts anymore. So there won't be any updates or bugfixes anymore after the final is out. (The last build will remain online for a while, though, mainly so you can use the libs to build it yourself.)
However, you don't have to give up on it completely. If you want, you can build the repo yourself. After all, a typical update only takes a few minutes and a full build should take less than 1 hour on most systems. If you want to do this, you can download the sources. This includes all PKGBUILDs and an automated build script, named update-*.py. Choose update-32-native.py or update-64.py, depending on your arch, and edit the PATH right at the top of the script. Execute it and voilà, you have your own repo! Just put PATH/repo-{32,64} in your pacman.conf and enjoy the cutting edge. wink
(There are also upload.sh and update-32.py, meant to be used with schroot and a 32bit chroot. You can ignore both.)

Last edited by muflax (2009-02-08 13:40:11)

Offline

#2 2008-07-21 14:36:53

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: Xfce SVN repo [closed]

Hmm...
It seems there were first xfce svn packages in unstable, maintained by Shadowhand, and he resigned :
http://archlinux.org/pipermail/arch-dev … 00387.html
Then they were moved to community, maintained by wizzo, and he resigned :
http://www.archlinux.org/pipermail/tur- … 06927.html
Then they were apparently moved to unsupported :
http://www.archlinux.org/pipermail/tur- … 07262.html
And now I can't find them anymore on aur.archlinux.org

It looks like no one wanted to lose these packages to prevent people from having to make them again, but no one wanted to maintain them either, so that is what eventually happened.
But I could be wrong, so if anyone has more information about what happened to these pkgbuild, please tell.


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#3 2008-07-21 14:43:06

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: Xfce SVN repo [closed]

Oh wait, I can't see them on the AUR interface, but I can still find them next to all other AUR pkgbuilds :
http://aur.archlinux.org/packages/

But how long are they going to stay there?


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#4 2008-07-22 04:05:01

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

As far as I'm aware: forever. ^^

Xfce-svn doesn't have a stable history of maintained packages. Perhaps it's a curse? I can already see parts of it, as Stuff Broke(tm).

So I changed the builds to also provide their xfce counterparts so you can just replace what you want to svn-ify and keep the rest stable. Should be online soon. [Done. Might require a clean cache, as I ignored pkgrel before.]

Last edited by muflax (2008-07-22 05:37:09)

Offline

#5 2008-08-09 16:36:37

Anonymo
Member
Registered: 2005-04-07
Posts: 418
Website

Re: Xfce SVN repo [closed]

I had to install the libwnck to startx into XFCE4.  Please keep up the good work.  Everything looks great.  Some stuff also has no icon, like show desktop and some stuff in the xfce menu like accesories just have a square with an X

squeeze won't start up:

$ squeeze

(squeeze:5042): GLib-GObject-WARNING **: attempt to register fundamental type `LSQCommandOption' with invalid type id (164462024)

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-WARNING **: attempt to register fundamental type `LSQCommandOption' with invalid type id (164462024)

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(squeeze:5042): GLib-GObject-WARNING **: cannot create new instance of invalid (non-instantiatable) type `<invalid>'
Segmentation fault

Last edited by Anonymo (2008-08-09 16:47:34)

Offline

#6 2008-08-09 20:06:38

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

The deps were copied from xfce4 (and svn-specific ones added), but I found a few missing myself. Could you tell me what exactly did not start without libwnck? xfwm4-svn? On my system, gnome-panel pulls it in, so xfce4-panel-svn might be another candidate. namcap confirms xfce4-panel-svn for me, so I added it there.

Unfortunatly, I have not installed all svn packages right now, and I started with installing xfce4 before, so I may overlook a few missing things. Like, I have all symbols. smile Could you check your ~/.xsession-errors if it tells you what symbols are missing exactly? I noticed an error about hicolor-icon-theme missing, so you might try installing that.

I can confirm the squeeze bug. (I use mc + unp, so I didn't notice. ^^) I can't find anything useful in the svn log, but I will try a few revisions to narrow it down, as normal squeeze does run.
Edit: Gotcha. peter's commit #27333, comment "Command options added (not completely finnished)" broke it. smile So, I take it, this is just temporary.

Last edited by muflax (2008-08-09 20:27:44)

Offline

#7 2008-09-14 17:50:36

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: Xfce SVN repo [closed]

You're missing one of the greatest innovations here, the new settings manager :-)
Here's a working PKGBUILD, notice that it replaces the old mcs manager, which development stopped some time ago and doesn't even fully work with the svn branch.

# Contributor: Corrado Primier <bardo@aur.archlinux.org>

pkgname=xfce4-settings-svn
pkgver=27863
pkgrel=1
pkgdesc="Settings manager for xfce"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.xfce.org/"
groups=('xfce4-svn')
depends=('exo-svn' 'libglade' 'libnotify' 'libwnck' 'libxfcegui4-svn' 'xfconf-svn')
makedepends=('subversion')
conflicts=('xfce-mcs-manager' 'xfce-mcs-manager-svn')
replaces=('xfce-mcs-manager' 'xfce-mcs-manager-svn')
source=()
md5sums=()

_svntrunk=http://svn.xfce.org/svn/xfce/xfce4-settings/trunk
_svnmod=xfce4-settings

build() {
  msg "Updating SVN entries for $_svnmod ..."

  cd $startdir/src
  svn co $_svntrunk $_svnmod
  cd $_svnmod

  msg "Finished update, starting build ..."
  ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
  make || return 1
  make DESTDIR=$startdir/pkg install
}

# vim:set ts=2 sw=2 et:

Could you also provide PKGBUILDs for the binaries you provide? They don't need to be in the AUR if you don't want to maintain them there, it'd just be nice to have them at hand if something needs to be fixed quickly.


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#8 2008-09-14 20:06:35

slumslayer
Member
From: Belgium
Registered: 2008-09-14
Posts: 66

Re: Xfce SVN repo [closed]

Thanks for the repo.

I've tried to build xfce4-settings-svn :

...
checking for xi >= 1.0.0... not found
*** The required package xi was not found on your system.
*** Please install xi (atleast version 1.0.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
...

But libxi is there ... hmm

$ pacman -Qs libxi
local/libxi 1.1.3-1
    X11 Input extension library
$ pkg-config --list-all | grep xi
xi                            Xi - X Input Extension Library

bardo, did you manage to build it ?

EDIT : I guess xfce4-mixer should depend on gstreamer0.10-base :

xfce4-mixer 
xfce4-mixer: error while loading shared libraries: libgstaudio-0.10.so.0: cannot open shared object file: No such file or directory

Last edited by slumslayer (2008-09-14 20:09:28)

Offline

#9 2008-09-14 21:32:52

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: Xfce SVN repo [closed]

Strange... the package build fine and works, otherwise I wouldn't have posted it.

checking for xi >= 1.0.0... 1.1.3
checking XI_CFLAGS...  
checking XI_LIBS... -lXi

Even stranger, my pkg-config doesn't list xi, even though I have /usr/lib/pkgconfig/xi.pc and I get the correct output from commands like 'pkg-config --libs xi'. What does this command return on your computer? Does it find it?


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#10 2008-09-14 21:49:49

slumslayer
Member
From: Belgium
Registered: 2008-09-14
Posts: 66

Re: Xfce SVN repo [closed]

$ pkg-config --libs xi
Package inputproto was not found in the pkg-config search path.
Perhaps you should add the directory containing `inputproto.pc'
to the PKG_CONFIG_PATH environment variable
Package 'inputproto', required by 'Xi', not found

Installing inputproto solved the problem. Thanks a lot. smile

Anyway, shouldn't libxi depends on inputproto ?

Offline

#11 2008-09-14 22:09:40

b9anders
Member
Registered: 2007-11-07
Posts: 681

Re: Xfce SVN repo [closed]

can you give a quick rundown of where svn is at compared to the stable version (news ettings manager aside)?

Offline

#12 2008-09-14 22:17:35

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: Xfce SVN repo [closed]

slumslayer wrote:

Anyway, shouldn't libxi depends on inputproto ?

It seems it does, at least in pkg-config's opinion. I'll check, and eventually open a ticket on the flyspray.

b9anders wrote:

can you give a quick rundown of where svn is at compared to the stable version (news ettings manager aside)?

You can get a brief presentation here: http://www.phoronix.com/scan.php?page=a … ce46_alpha wink

Last edited by bardo (2008-09-14 22:18:23)


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#13 2008-09-16 10:44:24

b9anders
Member
Registered: 2007-11-07
Posts: 681

Re: Xfce SVN repo [closed]

thanks. smile

Offline

#14 2008-09-16 10:52:07

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,368
Website

Re: Xfce SVN repo [closed]

shining wrote:

Hmm...
It seems there were first xfce svn packages in unstable, maintained by Shadowhand, and he resigned :
http://archlinux.org/pipermail/arch-dev … 00387.html
Then they were moved to community, maintained by wizzo, and he resigned :
http://www.archlinux.org/pipermail/tur- … 06927.html
Then they were apparently moved to unsupported :
http://www.archlinux.org/pipermail/tur- … 07262.html
And now I can't find them anymore on aur.archlinux.org

It looks like no one wanted to lose these packages to prevent people from having to make them again, but no one wanted to maintain them either, so that is what eventually happened.
But I could be wrong, so if anyone has more information about what happened to these pkgbuild, please tell.

As you pointed out, they were moved from [community] due to lack of a maintainer.  I though that someone was lined up to take over them in the AUR but it seems not to have happened.

shining wrote:

Oh wait, I can't see them on the AUR interface, but I can still find them next to all other AUR pkgbuilds :
http://aur.archlinux.org/packages/

But how long are they going to stay there?

Forever, provided no-one gets carried away cleaning up the filesystem.

Offline

#15 2008-09-16 13:29:36

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

Sorry for the late answer, a nasty math exam attacked me. wink

@bardo
Thanks for the build; I added it to the repo. smile
I don't use Xfce anymore (moved to awesome), so personally I only use and care about terminal and thunar. Once 4.6 is out I'll stop building. Also, I uploaded the PKGBUILDs and my ugly build script to http://www.stud.uni-karlsruhe.de/~uvcal … ild.tar.gz.

find -not -name "*.tar.gz" -and -not -path "*src*" -and -not -path "*pkg*" -exec cp --parents {} ~/build/ \;

Bash rocks. ^^

Edit: Arghs, I'm stupid. I tried a few CFLAGS and forgot that I'm not just building for my architecture. ^^ Fixed and rebuilding right now... Perhaps noone noticed... *hope*

Second edit: Also, xfdesktop and xfce4-appfinder don't build anymore.
Third edit: autoconf is the culprit. xfdesktop has been fixed; appfinder will be fixed soon, I guess.

Last edited by muflax (2008-09-21 11:20:41)

Offline

#16 2008-10-18 08:56:08

Paul-S
Member
From: Wales
Registered: 2008-02-04
Posts: 343

Re: Xfce SVN repo [closed]

Just wanted to say thanks muflax for the repo, its saved me a load of trouble updating from the source tarballs.

Cheers

Offline

#17 2008-10-18 12:01:09

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Xfce SVN repo [closed]

do these packages have relationship with the xfce 4.6? newer than 4.5.91?

i compiled the 4.5.91 and something wrong with the xfdesktop. cant right click, or xfdesktop will lock for a while.

Offline

#18 2008-10-18 18:00:08

Paul-S
Member
From: Wales
Registered: 2008-02-04
Posts: 343

Re: Xfce SVN repo [closed]

jarryson 4.5.91 is the first beta of 4.6. I had trouble upgrading from 4.4 to 4.6 alpha compiling from the source files.
So I just used pacman to remove 4.4 and added muflax's repo and it went fine.

Offline

#19 2008-10-24 22:48:06

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

Sure, done. smile Builds right now, should be online in a few minutes.

Offline

#20 2008-10-26 03:21:58

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Xfce SVN repo [closed]

Huh... Isn't the 4.6 beta supposed to have suspend and hibernate options in the logout dialog? sad

Edit: Also, BTW... xfce4-mixer depends on gstreamer. Whose base plugins in turn depend on gconf and other stuff, so that could get ugly.

Last edited by Gullible Jones (2008-10-26 03:35:12)

Offline

#21 2008-10-26 15:36:21

andrek
Member
From: Poland
Registered: 2007-12-27
Posts: 29

Re: Xfce SVN repo [closed]

I have a problem while upgrading my system with your repo.

:: libxfce4mcs-svn conflicts with libxfce4mcs. Remove libxfce4mcs? [Y/n] y
error: failed to prepare transaction (could not satisfy dependencies)
:: xfce-mcs-plugins: requires xfce-mcs-manager>=4.4.2

Any ideas? I've got xfce-mcs-manager installed.

Offline

#22 2008-10-26 21:26:19

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

MCS is deprecated. Use xfce4-settings-svn. If you can't than you're SOL. wink

Offline

#23 2008-10-28 18:42:51

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Xfce SVN repo [closed]

Hey Muflax do you take requests? If so... Can we have the battery plugin in the goodies group? big_smile

Offline

#24 2008-10-28 20:58:34

andrek
Member
From: Poland
Registered: 2007-12-27
Posts: 29

Re: Xfce SVN repo [closed]

And, oh, what's the deal with the menu editor? I don't see any such apps for editing the existing ugly menu.

Last edited by andrek (2008-10-29 19:00:10)

Offline

#25 2008-10-28 21:17:46

muflax
Member
From: Germany
Registered: 2008-07-21
Posts: 58

Re: Xfce SVN repo [closed]

@Gullible Jones

Sure, consider it done. smile

Edit: Small note: It includes a small patch to build it with newer kernels. I also removed the ugly ACPI hack from the PKGBUILD. I'm not sure how important it is, but you should never patch beyond building stuff downstream nor should it be directly in the PKGBUILD.

Last edited by muflax (2008-10-28 22:45:47)

Offline

Board footer

Powered by FluxBB