You are not logged in.

#1 2008-08-05 18:27:28

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Tried to install OSS - now I've lost all sound

Hello,

I've been having trouble with sound in Wine, so I thought I'd try installing OSS. I followed this guide, but when I booted back up, there was no sound at all. So, I re-edited /etc/rc.conf, but still no sound. When I run /etc/rc.d/alsa start, I get the following:

/

usr/sbin/alsactl: load_state:1573: No soundcards found...

I've run alsaconf, but it can no longer find my card. Running lspci reveals the sound card to be

Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)

However, lspci | grep snd gives no result at all.


Here is my /etc/rc.conf file:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Paris"
KEYMAP="fr-latin9"
CONSOLEFONT="Agafari-12"
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(8139cp 8139too mii slhc ac97_bus snd-mixer-oss snd-pcm-oss snd-page-alloc snd-pcm snd-timer snd snd-ac97-codec snd-intel8x0 snd-intel8x0m soundcore)
MODULES=(!usbserial scsi_mod sd_mod snd-ymfpci snd-pcm-oss lp parport parport_pc ide-scsi)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="myhost"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth1="dhcp"
INTERFACES=(lo eth1)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -------------------------------

Thanks a lot in advance.

Offline

#2 2008-08-05 18:32:29

esters
Member
Registered: 2006-11-04
Posts: 173

Re: Tried to install OSS - now I've lost all sound

When you installed oss-linux-free, did you disable the soundcore module ? "!soundcore" and just for saftey - alsa daemon (Btw you haven't pasted in your full rc.conf, DAEMONS entry is missing). If you haven't do that, reboot. And start OSS - /etc/rc.d/oss-linux-free start. I used this mething on both my two boxes, everything worked. I Hope this does.

Last edited by esters (2008-08-05 18:33:10)

Offline

#3 2008-08-05 19:09:07

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Re: Tried to install OSS - now I've lost all sound

Thank you. This works. It's strange, I did do everything it says in the Wiki - at least I thought I did.

Do I have to run /etc/rc.d/oss-linux-free start everytime I start the computer, or do I need to edit the rc.conf file? It says in the Wiki that the daemons part of rc.conf can be edited to make OSS start on boot up, but it doesn't say what the command is. Do I take it it's oss-linux-free?

Once again, thanks a lot!

Offline

#4 2008-08-05 19:09:54

esters
Member
Registered: 2006-11-04
Posts: 173

Re: Tried to install OSS - now I've lost all sound

Yes, you should put oss-linux-free in your /etc/rc.conf smile

Btw, just for interest, does your CONSOLEFONT in /etc/rc.conf supports UTF-8 ?

Last edited by esters (2008-08-05 19:10:44)

Offline

#5 2008-08-05 21:11:24

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Re: Tried to install OSS - now I've lost all sound

Thank you. That works.

does your CONSOLEFONT in /etc/rc.conf supports UTF-8 ?

Do you mean am I able to get accents in the terminal? The answer is yes I can.

Offline

#6 2008-08-05 23:28:00

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: Tried to install OSS - now I've lost all sound

Umm... Your rc.conf is a complete mess... Why do you have two MODULES lines?
Also no wonder oss4 doesn't work? You didn't remove alsa-lib and alsa-tools (since you could try to start the alsa daemon).
Second the snd modules are not blacklisted (put ! in front of every snd module and in front of the soundcore module)
And where the fuck is your daemons line?
Did you fallow step by step the wiki?


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#7 2008-08-06 05:57:37

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Re: Tried to install OSS - now I've lost all sound

I followed the Wiki to the letter, and I've never experienced any problems - until now. But I'm finding that OSS doesn't improve sound in Wine at all, so I'm thinking of changing it back to ALSA.

Offline

#8 2008-08-06 07:09:48

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: Tried to install OSS - now I've lost all sound

So... what's your problem now?
How to revert back to alsa or why there is no sound in wine with oss?
If it is the first just uninstall oss-linux-free and remove the blacklisted modules.
If it is the second:
1) Do you get sound in other applications
2) If you set in winecfg sound to oss when you click "Test Sound" button do you hear anything?


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#9 2008-08-06 19:52:44

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Re: Tried to install OSS - now I've lost all sound

Hello,

Sorry for the delay in replying - I've been out all day.

what's your problem now?

There's no problem. I was just saying that my experiment to change ALSA for OSS was unsuccessful, in that it didn't improve sound in Wine. There is sound in Wine, it's just that I can't get an application (Band-in-a-Box) to work in Archlinux no matter what I do - whereas I have managed it in Debian. Swapping to OSS was just an attempt to get this application going for me.
I have now switched back to ALSA without any trouble. The key, it seems, was to uninstall OSS first. I started this thread because my initial attempt to switch back resulted in total sound loss.
Dheart: I'm interested in what you were saying about my rc.conf file. I think you're right - it does appear to be in a mees, although for the life of me I can't imagine why as I never touch it. I have taken on board what you were saying about having two lines for the modules section, and I have reduced that to one line. But it does seem like there are a hell of a lot of modules being loaded up here! Can I get someone to look at it to see if I can cut it down a bit? Thanks! big_smile

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Paris"
KEYMAP="fr-latin9"
CONSOLEFONT="Agafari-12"
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(8139cp 8139too mii slhc ac97_buslp parport parport_pc snd-mixer-oss snd-pcm-oss snd-page-alloc snd-pcm snd-timer snd snd-ac97-codec snd-intel8x0 snd-intel8x0m soundcore !usbserial scsi_mod sd_mod snd-ymfpci snd-pcm-oss  ide-scsi soundcore)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="myhost"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth1="dhcp"
INTERFACES=(lo eth1)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng @network netfs crond cups vboxdrv @alsa @gdm  @hal)


# End of file

Offline

#10 2008-08-06 20:53:50

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: Tried to install OSS - now I've lost all sound

The SND modules are related to alsa and I don't think you can reduce them. When I switched to oss from alsa my udev uevents time dropped with two seconds thanks to the less modules loaded...
When I switched to oss4 I noticed:
a) A louder sound from just about any application without glitching.
b) My wine games no longer glitched (whereas with alsa it was hit and miss... sometimes it was horrible, some times there was no glitching (but that is thanks to my shitty hardware overheating in the summer, I think... Either way oss4 performs way better)


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#11 2008-08-06 23:39:36

esters
Member
Registered: 2006-11-04
Posts: 173

Re: Tried to install OSS - now I've lost all sound

Flapjack, you could try to enable OSS module in winecfg with - emulation mode, that fixed some issues with sound delaying on my arch box.

Offline

#12 2008-08-07 07:42:48

Flapjack
Member
Registered: 2008-05-08
Posts: 33

Re: Tried to install OSS - now I've lost all sound

Actually, I've just got Band-in-a-box working! It took me two months, but I got there in the end! For anyone who's interested, I found this little guide. Also, I've realised why my modules section is so long, or at least I have an idea. It's related to my previous attempts to get midi going - I did some modprobes snd - and I think that they must have found their way into the modules sections of rc.conf. In that case, I'll leave them there. They do no harm, and having them load when the computer boots up makes starting Band-in-a-Box simpler. As for emulation mode, I've never tried it - I'll give it a whirl.

Thanks for your help, guys!

Last edited by Flapjack (2008-08-07 07:43:26)

Offline

Board footer

Powered by FluxBB