You are not logged in.

#1 2008-08-13 03:27:14

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

ATI RV620 Audio

Hello all,

I have just gotten a new computer and I have everything working except for sound. lspci says this:
Code:

01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]

Following the Alsa Wiki....

Code:

$ ls -l /dev/snd/
total 0
crw-rw---- 1 root audio 116,  7 2008-08-12 10:28 controlC0
crw-rw---- 1 root audio 116, 10 2008-08-12 10:28 controlC1
crw-rw---- 1 root audio 116,  6 2008-08-12 10:28 hwC0D0
crw-rw---- 1 root audio 116,  9 2008-08-12 10:28 hwC1D0
crw-rw---- 1 root audio 116,  5 2008-08-12 10:28 pcmC0D0c
crw-rw---- 1 root audio 116,  4 2008-08-12 10:29 pcmC0D0p
crw-rw---- 1 root audio 116,  8 2008-08-12 10:28 pcmC1D3p
crw-rw---- 1 root audio 116,  3 2008-08-12 10:28 seq
crw-rw---- 1 root audio 116,  2 2008-08-12 10:28 timer

and last but not least hwd -s:

Code:

  Sound(a)   : 82801H ICH8 Family HD Audio Controller module: snd-hda-intel
  Sound(a)   : RV620 Audio device [Radeon HD 34xx Series] module: snd-hda-intel

The levels are unmuted and alsa seems to see everything, but it wont play any sound. Root or a normal user in the audio group cant play them. Any suggestions or help would be much appreciated!

Thank you,

Levi Lentz

Offline

#2 2008-08-14 06:27:38

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

So I found this website ( http://www.avalpa.com/assets/andrea/stu … dio15.html ) in which a guy has the same computer. He says that I need to upgrade the ALSA-Driver to the newest version. I notices that there is no alsa-driver in the AUR or in Pacman DB. I also noticed that the alsa-lib packages are not the newest versions. What does it mean for an Arch-user to update the ALSA-driver?

Offline

#3 2008-08-14 06:50:22

vogt
Member
From: Toronto, Canada
Registered: 2006-11-25
Posts: 389

Re: ATI RV620 Audio

It means getting the pkgbuilds for the alsa-lib and alsa-utils in the repos: http://wiki.archlinux.org/index.php/ABS, bumping the versions to 1.0.17, and then running makepkg...

Of course, in the unlikely case that the build or configuring options have changed between those versions, makepkg will fail, and the error messages will be helpful to somebody.

Offline

#4 2008-08-14 16:59:55

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

Hmm, I just did that. Have the newest versions of all the ALSA stuff from the repos. But Still no sound. The alsa-driver pkg from www.alsa-project.org recompiles a bunch of modules, should I make a PKGBUILD for the alsa-driver PKG? Or what pkg gives me the new modules? Thank you for your help.

Offline

#5 2008-08-14 23:21:01

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

GOT IT WORKING!

For anyone using this, I had to make a PKGBUILD for the alsa-driver, install it, and then reinstall kernel26. I also had to get the latest of all the alsa-lib,-utils,-oss, to get it to work. It doesnt play too loud, but it works. YAY! This lappy is definately a viable option for arch linux!.

Offline

#6 2008-08-21 00:54:08

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: ATI RV620 Audio

hello, i'm having the same problem, but i still can't listen to any sound.

lscpi: 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
hwd -s:   
Sound(a)   : 82801I ICH9 Family HD Audio Controller module: snd-hda-intel
Sound(a)   : RV620 Audio device [Radeon HD 34xx Series] module: snd-hda-intel

1) downloaded the alsa-driver from the alsa project the version 1.0.17, ./configure, make, sudo make install
2) sudo pacman -S kernel26
3) with abs, changed the version in the PKGBUILD and the respective md5sums: alsa-lib - 1.0.17a and alsa-utils - 1.0.17
4) installed the created packages
5) rebooted

still no sound, what am i missing?


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#7 2008-08-21 01:10:49

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

Well you did almost everything I did, but I also did alsa-oss to the newest version. Then install kernel26. Then run alsamixer. You will see a bunch of like vertical bars. You want to unmute all of them except the furthest left "Analog L" Leave that one muted. You should have sound. Post back and let me know if this worked.

Last edited by OneEyedPimp (2008-08-21 01:11:19)

Offline

#8 2008-08-21 01:49:40

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: ATI RV620 Audio

when i run alsamixer there's only two bars, master and pcm i think. I'll try again. Did you add any option to modprobe.conf or to alsa conf files?

some other commnads to compare:
                                                                             
[diaz@portatil ~]$ sudo lspci -s 00:1b.0 -vn
00:1b.0 0403: 8086:293e (rev 03)
        Subsystem: 1043:1878
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at fdef8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

[diaz@portatil ~]$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ID 663                                         
Codec: Motorola Si305

EDIT:
IT WORKS big_smile

changed to init 1, then reinstalled the alsa-driver, alsa-lib and alsa-utils, rebooted and then the stuff appears in alsamixer and it freaking works.

Last edited by Diaz (2008-08-21 02:08:05)


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#9 2008-08-21 04:06:03

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

Awesome. Maybe a bad install on the new pkgbuilds? I wonder why you had to install it in init 1...But I am glad you got it working. What type of computer is it? If I may ask...haha

Offline

#10 2008-08-21 15:06:54

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: ATI RV620 Audio

a almost new and shiny asus M51vr, with some too new hardware that i wish the new kernel were how to smile


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#11 2008-08-21 15:33:05

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

Awesom. Well congrats on the new lappy. And enjoy your new sound!

Offline

#12 2008-09-22 03:48:17

OneEyedPimp
Member
Registered: 2008-05-02
Posts: 103

Re: ATI RV620 Audio

Nope, the newest kernel and newest alsa files should do the trick. If you run alsa-mixer, and you see three instances of the same thing in there, mute the furthest one left and see if that does the trick for you.

Offline

Board footer

Powered by FluxBB