You are not logged in.

#1 2008-08-18 16:58:20

technopower
Member
Registered: 2008-08-18
Posts: 2

"Failed to execute login command" SLiM login

Hi guys,

First off, I am a complete newbie at Arch (and linux in general) so forgive me if I come off as ignorant or blunt. That said, I decided to try out arch linux because I've heard many things about its complete customization ability and that I just wanted to try something thats lightweight compared to my previous Ubuntu install.

Anyway, I pretty much followed the exact steps on the beginner guide; installed xorg, nvidia drivers, alsa-utils, and the "awesome" window manager. I ran the 'startx' command to see if everything works, and sure enough, it booted into X Windows with the awesome window manager running.  So my next step would be to get a graphical login manager installed, and I picked SLiM, and editted the /etc/inittab as per the SLiM guide, rebooted, tried to login and it comes up with the error in the title, and blanks out to the command line and restarts slim.

So I think there is a problem with my login_cmd  in the slim.conf. I do not have a .xinitrc file and instead I use "/etc/X11/xinit/xinitrc" do initialize X Windows. What is the correct login_cmd I should have to get past this error, and am I missing something else? I will post my xinitrc and slim.conf later.

Thanks for all your replies!

Offline

#2 2008-08-18 17:12:36

technopower
Member
Registered: 2008-08-18
Posts: 2

Re: "Failed to execute login command" SLiM login

GNU nano 2.0.7                             File: /etc/X11/xinit/xinitrc                                                                 

#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs
exec awesome

# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
login_cmd           exec /bin/sh - login /etc/X11/xinit/xinitrc

Last edited by technopower (2008-08-18 17:21:04)

Offline

#3 2008-08-19 21:46:50

lmsguerr
Member
From: Loulé-Algarve-Portugal
Registered: 2008-05-20
Posts: 46

Re: "Failed to execute login command" SLiM login

Same here... But i had it working!!!! sad

And now for some reason unknown it fails to login...

Last edited by lmsguerr (2008-08-19 21:47:36)


Linux /  4.1.6-1-ARCH-ck / x86_64 / AMD Phenom(tm) II X4 955 Processor

Offline

#4 2008-08-22 10:08:24

lmsguerr
Member
From: Loulé-Algarve-Portugal
Registered: 2008-05-20
Posts: 46

Re: "Failed to execute login command" SLiM login

Finally solved!

had to create ~/.xinitrc with "exec xfce4-session" or copy /etc/skel/.xinitrc to ~/ and remove uncomment on line "exec xfce4-session" (comment others..)
Not mandatory for me... but can also do edit /etc/inittab as root and change the following lines to:

# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

and if using SLiM, uncomment the following line:

#x:5:respawn:/usr/bin/slim >& /dev/null

http://wiki.archlinux.org/index.php/Beg … figuring_X
http://wiki.archlinux.org/index.php/SLIM
http://archux.com/page/installing-and-setting-xfce

Last edited by lmsguerr (2008-08-22 10:17:02)


Linux /  4.1.6-1-ARCH-ck / x86_64 / AMD Phenom(tm) II X4 955 Processor

Offline

Board footer

Powered by FluxBB