You are not logged in.

#1 2008-08-30 12:55:21

Registered: 2008-08-29
Posts: 8

Arch Install Image lacks LVM Support?


in the Wiki's Beginner's Guide to Arch as well as in the Installation Guide it is alleged that the install kernel
supports LVM and MD.

Well, this can't be quite true, or at least the LVM support, which relies on the Linux Device Mapper is broken.

Since I have given up Linux Installations on obsolete partitions completely in favour of LVM
(for its unparalleled storage maintenance flexibility, well maybe apart from ZFS)
I also expect from a decent distro's installer that it allows me to create an LVM setup during installation.

First I thought this was due to some bug on the CD image I got as a gift from the Arch exhibitors at FrOsCon 2008.
So I have just downloaded the Core 2008.06 ISO image for i686 and booted from that CD.
But this images shows the same lack of LVM support.

I had run script and had its dump written to a USB stick during my futile install attempt (see below).
Of course, I could also first install Arch into a conventional old-style partition and afterwards copy the OS
onto later created LVs.
But this is unnecessarily tedious in comparison to most current Linux distros whose kernels and kernel modules
from their rescue or install mode let you do all this.
Don't get me wrong, I am not expecting a a wizard or some shiny GUI here, in fact I am an avid user of the shell.
But for such rudimentary setup task where I don't fumble with exotic HW I don't feel terribly inclined to
mess around with drivers and having to build my own installation kernel.
For the folks who are into that there are distros like Gentoo or Linux From Scratch I suppose.

Below, some part of script's dump:

Script started on Sat 30 Aug 2008 12:00:45 PM CDT
[root@archlive ~]# uname -a
Linux archlive 2.6.25-ARCH #1 SMP PREEMPT Sat Jun 14 18:07:19 CEST 2008 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz GenuineIntel GNU/Linux
[root@archlive ~]# pvscan
  PV /dev/sda8   VG vgvz    lvm2 [9.32 GB / 0    free]
  PV /dev/sda7   VG vgmix   lvm2 [18.63 GB / 2.63 GB free]
  PV /dev/sda5   VG vgfc    lvm2 [18.63 GB / 344.00 MB free]
  Total: 3 [46.59 GB] / in use: 3 [46.59 GB] / in no VG: 0 [0   ]
[root@archlive ~]# vgscan
  Reading all physical volumes.  This may take a while...
  Found volume group "vgvz" using metadata type lvm2
  Found volume group "vgmix" using metadata type lvm2
  Found volume group "vgfc" using metadata type lvm2
[root@archlive ~]# lvs
  /proc/misc: No entry for device-mapper found
  Is device-mapper driver missing from kernel?
  Failure to communicate with kernel device-mapper driver.
  LV           VG    Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  lv_depot     vgfc  -wi---   9.80G                                      
  lv_home      vgfc  -wi--- 256.00M                                      
  lv_opt       vgfc  -wi--- 512.00M                                      
  lv_root      vgfc  -wi---   1.00G                                      
  lv_tmp       vgfc  -wi--- 512.00M                                      
  lv_usr       vgfc  -wi---   5.00G                                      
  lv_usr_local vgfc  -wi--- 256.00M                                      
  lv_var       vgfc  -wi---   1.00G                                      
  lv_iso       vgmix -wi---   6.00G                                      
  lv_store     vgmix -wi---   1.00G                                      
  lv_xubuntu   vgmix -wi---   5.00G                                      
  lv_zenwalk   vgmix -wi---   4.00G                                      
  lv_iso       vgvz  -wi---   9.32G                                      
[root@archlive ~]# lsmod
Module                  Size  Used by
nls_cp437               5888  1 
vfat                   10880  1 
fat                    45984  1 vfat
usb_storage            84800  1 
ext3                  124040  0 
jbd                    44052  1 ext3
mbcache                 7172  1 ext3
snd_seq_oss            30336  0 
parport_pc             34884  1 
snd_seq_midi_event      6656  1 snd_seq_oss
snd_seq                48432  4 snd_seq_oss,snd_seq_midi_event
pcmcia                 33068  0 
snd_seq_device          6796  2 snd_seq_oss,snd_seq
snd_intel8x0m          13964  0 
snd_intel8x0           29084  0 
joydev                 10048  0 
ppdev                   7556  0 
snd_ac97_codec         97828  2 snd_intel8x0m,snd_intel8x0
8139cp                 19328  0 
snd_pcm_oss            38656  0 
snd_mixer_oss          14848  1 snd_pcm_oss
ac97_bus                2048  1 snd_ac97_codec
snd_pcm                68228  4 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
8139too                22784  0 
yenta_socket           23436  2 
rsrc_nonstatic         11264  1 yenta_socket
pcmcia_core            33172  3 pcmcia,yenta_socket,rsrc_nonstatic
snd_timer              19848  2 snd_seq,snd_pcm
mii                     4992  2 8139cp,8139too
psmouse                36880  0 
lp                      9444  0 
parport                31596  3 parport_pc,ppdev,lp
pcspkr                  2816  0 
serio_raw               5508  0 
snd                    46628  10 snd_seq_oss,snd_seq,snd_seq_device,snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               6496  1 snd
snd_page_alloc          8072  3 snd_intel8x0m,snd_intel8x0,snd_pcm
i2c_i801                9232  0 
i2c_core               19348  1 i2c_i801
shpchp                 29460  0 
pci_hotplug            26276  1 shpchp
container               3712  0 
video                  16656  0 
output                  3200  1 video
intel_agp              23740  1 
agpgart                28244  1 intel_agp
sg                     27188  0 
evdev                   9472  0 
thermal                15260  0 
processor              32096  2 thermal
fan                     4356  0 
button                  6416  0 
battery                10372  0 
ac                      4484  0 
rtc_cmos                9120  0 
rtc_core               15516  1 rtc_cmos
rtc_lib                 2944  1 rtc_core
loop                   14212  4 
unionfs                70756  1 
squashfs               40968  2 
isofs                  32036  1 
zlib_inflate           18560  2 squashfs,isofs
sr_mod                 15300  1 
cdrom                  33952  1 sr_mod
sd_mod                 23320  2 
pata_acpi               4992  0 
ata_generic             5636  0 
ata_piix               17668  1 
libata                142096  3 pata_acpi,ata_generic,ata_piix
ehci_hcd               33804  0 
uhci_hcd               22288  0 
scsi_mod               92204  5 usb_storage,sg,sr_mod,sd_mod,libata
dock                    7952  1 libata
usbcore               129776  4 usb_storage,ehci_hcd,uhci_hcd
[root@archlive ~]# mkdir -p /mnt/tmp{1,2,3,4,5}
[root@archlive ~]# mount /dev/vgmix/lv_iso /mnt/tmp1
mount: you must specify the filesystem type
[root@archlive ~]# ^Gset -o vi
[root@archlive ~]# mount /dev/vgmix/lv_iso /mnt/tmp1
mount: special device /dev/vgmix/lv_iso does not exist
[root@archlive ~]# find /lib/modules/$(uname -r) -type f -name dm\*
[root@archlive ~]# lvscan
  /proc/misc: No entry for device-mapper found
  Is device-mapper driver missing from kernel?
  Failure to communicate with kernel device-mapper driver.


#2 2008-08-30 14:43:21

Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Arch Install Image lacks LVM Support?

modprobe dm-mod is all you need. I installed my lvm system from the 2008.06 iso with no problems. See the lvm page in our wiki for more details.


#3 2008-08-30 15:40:59

Registered: 2008-08-29
Posts: 8

Re: Arch Install Image lacks LVM Support?

Hi tomk,

really? I thought I tried this (but I may well haven't?)

Anyway, meanwhile I downloaded the FTP Arch Image 2008.03
and there LVM support worked fine,
so that I could prepare my install target.
But then I stepped into another trap.
After having configured my NIC I first tried to select a mirror FTP server to fetch the packages.
In the end I must have tried them all to no avail.
On the console F5 I could see that the anonymous login to every FTP server worked well
but they all ended in not being able to retrieve the package list.
It always said "Cannot find packages.txt".
Have they relocated the packages.txt file to some other dir on the FTP mirrors?
I also tried the quickinstall after setup hadn't worked.
But this time I restricted my futile attempts to a not too far away FTP mirror,
viz. tu-chemnitz.
Anyway, the outcome was the same.
Do you think it will work better with fetching packages.txt from running install from 2008.06 image?
(provided the modprobe dm-mod will create the device files this time)


#4 2008-08-30 16:14:21

Registered: 2008-08-29
Posts: 8

Re: Arch Install Image lacks LVM Support?

Hi again tomk,

I have to apologize for my totally unfounded rant that started this thread.

You were absolutely right. Once I loaded dm-mod I had full LVM support on 2008.06 likewise.
It was even less typing because one could omit the every LVM command preceding lvm
as opposed to 2008.03.

But here I still had trouble fetching the packages from quickinst while setup must have successfully
fetched packages.txt because it continued to offer category menus, where I aborted for now.
I would however prefer using quickinst because I already mounted /boot and the LVs for / and /var
from my USB flash drive.
I cannot recall whether setup would allow only for specifying mount points but skipping FS creation.

I will come back later...

Last edited by archIbald (2008-08-30 16:14:52)


Board footer

Powered by FluxBB