You are not logged in.

#1 2008-08-31 22:39:46

xd-0
Member
From: Sweden
Registered: 2007-11-02
Posts: 327
Website

netgear wg111v3 usb adapter for wireless network [Solved]

After hours of googling I turn to you for help. I can't get an netgear usb adapter to work.

lsusb gives me "Bus 002 Device 006: ID 0846:4260 NetGear, Inc. WG111v3 802.11g Adapter [realtek RTL8187B]"
The method I've tried so far is to run the installation with wine, and then copy the inf cat and sys file. Then I installed ndiswrapper and ran:

sudo ndiswrapper -i WG111v3.inf
depmod -a
sudo modprobe ndiswrapper

But still i get nothing from iwconfig:

>iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

I've also read http://wiki.archlinux.org/index.php/Wireless without getting any further.
All help on this topic would be appreciated.

Last edited by xd-0 (2008-09-05 09:09:42)

Offline

#2 2008-08-31 23:09:02

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 429

Re: netgear wg111v3 usb adapter for wireless network [Solved]

I have exactly the same usb stick as you, have you tried bringing the wlan0 interface up first? (ifconfig wlan0 up), as that should allow you to see the interface through iwconfig.

Offline

#3 2008-09-01 07:19:36

xd-0
Member
From: Sweden
Registered: 2007-11-02
Posts: 327
Website

Re: netgear wg111v3 usb adapter for wireless network [Solved]

Nice to see someone that have the same adapter smile

> sudo ifconfig wlan0 up
wlan0: unknown interface: No such device

As you can see it doesn't see the device. Can you describe how you did to get the adapter to work?

edit:

ndiswrapper -l gives:
wg111v3 : driver installed
        device (0846:4260) present
Also I run 64bit arch if that makes any difference.

Last edited by xd-0 (2008-09-01 09:55:05)

Offline

#4 2008-09-02 19:21:51

xd-0
Member
From: Sweden
Registered: 2007-11-02
Posts: 327
Website

Re: netgear wg111v3 usb adapter for wireless network [Solved]

Nobody that can give me any pointers on how I can get the my wireless working (eg. correct module installed)?
All help, wether it's a link to people with similar problems or a more, are appreciated.

Offline

#5 2008-09-05 09:11:33

xd-0
Member
From: Sweden
Registered: 2007-11-02
Posts: 327
Website

Re: netgear wg111v3 usb adapter for wireless network [Solved]

Ok solved it. It was 64 bit that caused the trouble. Had to reinstall arch on 32 bits to make it work. It shows just how important it is that more people start using 64bit. Sad though that Im dependent on wireless.

Offline

#6 2008-09-05 10:06:43

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 429

Re: netgear wg111v3 usb adapter for wireless network [Solved]

Sorry for slow response mate, and yeah I run the wireless adaptor on my laptop which is 32bit so never had any problems.  You could download the 64bit drivers (if there are any) and they would work on arch64.

Edit: Made no sense first time round.

Last edited by SiC (2008-09-05 10:07:20)

Offline

#7 2008-09-05 10:28:04

xd-0
Member
From: Sweden
Registered: 2007-11-02
Posts: 327
Website

Re: netgear wg111v3 usb adapter for wireless network [Solved]

np smile

Say what do you use for networkmanager that supports wpa?
I've tried both gnome-network-manager and wicd with no succes. At the moment I am going to try netcfg and wpa_supplicant. But it would be nice with a graphicl application.

Offline

Board footer

Powered by FluxBB