You are not logged in.

#1 2008-09-05 06:55:12

staticvoid
Member
Registered: 2008-01-22
Posts: 160

problem with locales [SOLVED]

ran locale -a and got:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
C
POSIX

then I notticed I was getting these errors openning apps:

(pcmanfm:3952): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

Nothing seems wrong visually, but I want to be sure its fixed under ground, whatever it is wink.

/etc/rc.conf :
LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="America/Los_Angeles"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"


ciao!

static-----****-*-*-*-*-****----*-*-**-

Last edited by staticvoid (2008-09-09 16:49:20)


this is my sig

Offline

#2 2008-09-05 07:03:55

Allan
Supreme Leader
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,758
Website

Re: problem with locales [SOLVED]

Offline

#3 2008-09-05 12:06:21

ZenMystic
Member
Registered: 2008-08-25
Posts: 25

Re: problem with locales [SOLVED]

Thanks Allan,  off topic, but I looked for "Locale" recently, but didn't think to look under "C", "Configuring Locales".

Offline

#4 2008-09-07 19:17:26

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

Still having trouble with this : /

[nathan@archy ~]$ locale-gen
Generating locales...
Generation complete.
[nathan@archy ~]$ source ~/.bashrc
[nathan@archy ~]$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
C
POSIX
[nathan@archy ~]$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_EN.utf8
LC_CTYPE="en_EN.utf8"
LC_NUMERIC="en_EN.utf8"
LC_TIME="en_EN.utf8"
LC_COLLATE=C
LC_MONETARY="en_EN.utf8"
LC_MESSAGES="en_EN.utf8"
LC_PAPER="en_EN.utf8"
LC_NAME="en_EN.utf8"
LC_ADDRESS="en_EN.utf8"
LC_TELEPHONE="en_EN.utf8"
LC_MEASUREMENT="en_EN.utf8"
LC_IDENTIFICATION="en_EN.utf8"
LC_ALL=
[nathan@archy ~]$

I'm just not understanding the error message. Does "Using the fallback 'C' locale." mean its not gonna use en_US.utf8?

[nathan@archy ~]$ OOO_FORCE_DESKTOP=gnome soffice

(process:6206): Gdk-WARNING **: locale not supported by C library

(soffice:6206): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

this is my sig

Offline

#5 2008-09-07 19:39:35

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,172

Re: problem with locales [SOLVED]

Try running locale-gen as root?

Offline

#6 2008-09-07 21:33:25

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

Yea, then I restarted X.

Now I do have a problem, I want to use nmapfe but it won't open:

[nathan@archy ~]$ nmapfe 
Traceback (most recent call last):
  File "/usr/bin/nmapfe", line 32, in <module>
    from zenmapCore.UmitOptionParser import option_parser
  File "/usr/lib/python2.5/site-packages/zenmapCore/UmitOptionParser.py", line 26, in <module>
    from zenmapCore.I18N import _
  File "/usr/lib/python2.5/site-packages/zenmapCore/I18N.py", line 26, in <module>
    LC_ALL = locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.5/locale.py", line 478, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

: /. How is my locale not supported? I speak spanish... should I change it to a spanish locale?? with tildes and stuff ? no comprendo amigos.

Last edited by staticvoid (2008-09-07 21:34:38)


this is my sig

Offline

#7 2008-09-07 22:48:00

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,172

Re: problem with locales [SOLVED]

I don't understand...did editing /etc/locale-gen to include your locale(s) and running locale-gen as root help? Did you also set global default in rc.conf? Reboot?

Offline

#8 2008-09-08 00:46:35

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

I don't have a /etc/locale-gen file. rc.conf reads:

LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="US/Pacific"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

And locale-gen as root did not help, even after reboot. still gives me a "locale.Error: unsupported locale setting"
Do I need that file you mentioned?

SV


this is my sig

Offline

#9 2008-09-08 03:08:34

B-Con
Member
From: USA
Registered: 2007-12-17
Posts: 553
Website

Re: problem with locales [SOLVED]

I may have a solution:

I was having similar problems. I assume all of this is a result of the recent locale upgrades.

From pacman.log :

[2008-09-05 00:00]   ==> ATTENTION INTERNATIONAL USERS:
[2008-09-05 00:00]   ==>
[2008-09-05 00:00]   ==> Locales are no longer included in the glibc package.
[2008-09-05 00:00]   ==> They are generated by /usr/sbin/locale-gen depending on the contents
[2008-09-05 00:00]   ==> of /etc/locale.gen.
[2008-09-05 00:00]   ==> glibc will try to autodetect the required locales now, if you need
[2008-09-05 00:00]   ==> additional locales, please enable them in /etc/locale.gen and run
[2008-09-05 00:00]   ==> /usr/sbin/locale-gen
[2008-09-05 00:00]   ==>
[2008-09-05 00:00]   ==> Check /etc/locale.gen.pacnew for new supported locales
[2008-09-05 00:00]   ==>  
[2008-09-05 00:00] Generating locales...
[2008-09-05 00:00] Generation complete.

However, there was never a locale.gen.pacnew created.

At any rate, I double-checked /etc/locale.gen and discovered that my settings were different and no longer matched what was in rc.conf. On my laptop my selected locale had been changed from en_US.utf8 to en_CA.utf8 . On my desktop, I had no option selected.

On both machines, setting the locale back to en_US.utf8 and running locale-gen as root fixed the problem.

Offline

#10 2008-09-08 18:25:13

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

Could you post your /etc/locale.gen so I can create one from example? I now see that this is my problem! smile

StaticVoiddd**--**-*-*--


this is my sig

Offline

#11 2008-09-09 00:59:58

carlocci
Member
From: Padova - Italy
Registered: 2008-02-12
Posts: 368

Re: problem with locales [SOLVED]

/etc/locale.gen is the file
locale-gen is the command

They are both in glibc, so you must have them.
You can reinstall glibc: pacman -S glibc

Offline

#12 2008-09-09 03:13:18

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

Sweet, now I have that file. Before I did not.

[nathan@archy ~]$ sudo vi /etc/locale.gen 
[nathan@archy ~]$ sudo locale-gen
Generating locales...
  en_US.ISO-8859-1... done
Generation complete.

But maybe I still need to reboot?

[nathan@archy ~]$ nmapfe 
Traceback (most recent call last):
  File "/usr/bin/nmapfe", line 32, in <module>
    from zenmapCore.UmitOptionParser import option_parser
  File "/usr/lib/python2.5/site-packages/zenmapCore/UmitOptionParser.py", line 26, in <module>
    from zenmapCore.I18N import _
  File "/usr/lib/python2.5/site-packages/zenmapCore/I18N.py", line 26, in <module>
    LC_ALL = locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.5/locale.py", line 478, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

this is my sig

Offline

#13 2008-09-09 06:02:22

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

Nope still having trouble. What is the deal here?

[nathan@archy ~]$ nmapfe 
Traceback (most recent call last):
  File "/usr/bin/nmapfe", line 32, in <module>
    from zenmapCore.UmitOptionParser import option_parser
  File "/usr/lib/python2.5/site-packages/zenmapCore/UmitOptionParser.py", line 26, in <module>
    from zenmapCore.I18N import _
  File "/usr/lib/python2.5/site-packages/zenmapCore/I18N.py", line 26, in <module>
    LC_ALL = locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.5/locale.py", line 478, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
[nathan@archy ~]$

and now urxvt too

[nathan@archy ~]$ urxvt
urxvt: default locale unavailable, check LC_* and LANG variables. Continuing.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_EN.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.
[nathan@archy ~]$

and

[nathan@archy ~]$ pac rxvt-unicode
warning: rxvt-unicode-9.05-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (1): rxvt-unicode-9.05-1  

Total Download Size:    0.00 MB
Total Installed Size:   4.91 MB

Proceed with installation? [Y/n] y
checking package integrity...
(1/1) checking for file conflicts                   [#############################################################################] 100%
(1/1) upgrading rxvt-unicode                        [#############################################################################] 100%
[nathan@archy ~]$ urxvt
urxvt: default locale unavailable, check LC_* and LANG variables. Continuing.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_EN.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.
[nathan@archy ~]$

URXVT's error was more comprendable to me :]

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_EN.utf8"
    are supported and installed on your system.

my locale-gen file NOW says

....#en_SG ISO-8859-1 
en_US.UTF-8 UTF-8
#en_US ISO-8859-1 
#en_ZA.UTF-8 UTF-8 
#en_ZA ISO-8859-1 ....

and my /etc/rc.conf file says:

LOCALE="en_US.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="US/Pacific"

oh and by the way: my time is wrong!

this is the only arch install I have really struggled this much with : / (3rd install)

hmm

What is wrong? I have given all the info i do believe. I have run locale-gen and rebooted and reinstalled stuff a lot. and I read the wiki on it.

http://imagebin.org/index.php?mode=image&id=26072


this is my sig

Offline

#14 2008-09-09 09:01:31

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,046

Re: problem with locales [SOLVED]

LANG = "en_EN.utf8"

Where does that come from?
What's the output of locale and locale -a?


1000

Offline

#15 2008-09-09 16:48:53

staticvoid
Member
Registered: 2008-01-22
Posts: 160

Re: problem with locales [SOLVED]

[nathan@archy ~]$ locale -a
C
POSIX
en_US.utf8

Ok, I got it working. After all that... GUESS WHAT WAS IN MY .bashrc ??

export LANG=en_EN.utf8

Thats what was messing things up. When I deleted it, programs open.

Now I have a problem with my timezone and with openoffice (export 00 gnome or whatever only works from cli, not in .bashrc.)

sv


this is my sig

Offline

Board footer

Powered by FluxBB