You are not logged in.

#1 2008-10-04 18:32:55

Oxyd
Member
From: Czech Republic
Registered: 2008-01-17
Posts: 162

[Solved] qtconfig doesn't remember its settings

I want to adjust the fonts used by Qt4 applications -- when I fire up qtconfig (/usr/bin/qtconfig) I can make the changes and they apply to qtconfig's window but not to other apps' windows.  The next time I open qtconfig it's back to its previous settings.  This isn't an issue with Qt3's config (/opt/qt/bin/qtconfig) and my Qt3 apps look the way I want them.

It looks like there must be something preventing qtconfig to write the new configuration to some file -- but I haven't got an idea what file this should be and where and what could prevent it.  Any ideas on where I should start looking are welcome. smile

EDIT: rm ~/.config/Trolltech.conf and re-configuring Qt via qtconfig did the job. smile

Last edited by Oxyd (2008-10-05 17:05:55)


“UNIX systems generally have a good, though not impeccable, record for software reliability. The typical period between software crashes […] is well over a fortnight of continuous operation.” ~ Dennis M. Ritchie, The UNIX Time-sharing System--A Retrospective

Offline

#2 2008-10-06 09:58:05

Slug0
Member
Registered: 2008-07-22
Posts: 15

Re: [Solved] qtconfig doesn't remember its settings

Thanks for the solution, I was wondering this too smile

Apparently the configuration file was write protected for some reason.

Offline

#3 2009-06-26 21:06:49

pichulines
Member
From: Spain
Registered: 2009-06-26
Posts: 22
Website

Re: [Solved] qtconfig doesn't remember its settings

Thanks, it worked also for me. It seems the file is read only.

Offline

#4 2009-06-27 00:09:05

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: [Solved] qtconfig doesn't remember its settings

Wasn't read-only for me, seems only some people had it like that. Dunno why.

Offline

#5 2010-02-11 08:44:15

xiaweitang
Member
Registered: 2010-01-03
Posts: 61

Re: [Solved] qtconfig doesn't remember its settings

"sudo qtconfig" solves the problem.

Offline

#6 2011-12-22 16:09:52

akumixx
Member
Registered: 2011-05-03
Posts: 59

Re: [Solved] qtconfig doesn't remember its settings

None of those two methods worked for me.
In my case there is symbol font set in the qt and I can't use qt apps, because I dont see any font, only symbols.
No sudo or deleting helped, I really need forexample skype.
How to fix it ?

//EDIT:
[Partial Fix]
Other than gtk theme needs to be used. If you have symbol fonts as me. then it is the first rolling menu, and choose first, then go to second tab and change first rolling menu(it is fonts). Then click exit up right and one of the three appeared button says yes, save configuration.

In this example, there is a font change.
But theme change needs to be done first.
http://hosting11.imagecross.com/image-h … qtFont.png

Last edited by akumixx (2011-12-23 12:36:28)

Offline

#7 2011-12-23 02:45:25

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,158

Re: [Solved] qtconfig doesn't remember its settings

akumixx,
This thread is getting a little long-in-the-tooth (it is almost 2 years since the last post)  We tend to discourage posting to old threads because a lot can change in two years -- the symptoms may be the same, but the root cause may be different.  In this case, I think this is still relevant and, since you are posting solutions,  I will leave the thread open for now.

Generally, if you are having a problem with a contemporary installation and you find a relevant old thread, it is better to open a new thread and reference the old one.  This keeps outdated information from muddying the waters.

Oh, BTW -- Welcome to Arch Linux smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB