You are not logged in.

#1 2008-10-10 21:19:07

colbert
Member
Registered: 2007-12-16
Posts: 809

Openoffice 3.0 freezing

~ > /opt/openoffice/program/scalc 

(process:5289): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init() prior to this function

(process:5289): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:5289): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:5289): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init() prior to this function

(process:5289): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:5289): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init() prior to this function

(process:5289): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

This happens when I open any of the file/edit/tools etc. menus and it freezes right there.

Offline

#2 2008-10-10 21:22:33

Xinix
Member
Registered: 2008-03-14
Posts: 83

Re: Openoffice 3.0 freezing

try adding this to /etc/profile: export OOO_FORCE_DESKTOP=gnome

Restart X after

Offline

#3 2008-10-10 21:26:28

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Openoffice 3.0 freezing

I had that line commented out of my ~/.bashrc, I uncommented it and ran scalc again, it works fine but it takes on my real dark GTK theme which I prefer it not to sad

Offline

#4 2008-10-10 21:53:54

karoshi
Member
From: Marburg
Registered: 2008-02-26
Posts: 182

Re: Openoffice 3.0 freezing

Well, my Desktop looks kind of weird after starting OpenOffice3:

officemx7.th.pngthpix.gif

It happened after switching Desktops. Right from the start the openoffice menus didnt work, symbols didnt show up, etc.

I'm using 32bit & KDEmod. Konsole didnt tell me anything.

Everything looks fine in TWM.

Last edited by karoshi (2008-10-10 21:59:51)


It's a bug planet!

Offline

#5 2008-10-10 22:32:54

QwertyManiac
Member
Registered: 2008-10-05
Posts: 6

Re: Openoffice 3.0 freezing

I faced visual problems in KDE 4.1 while running OpenOffice.org 2.4 too. That was on Gentoo though and I run GNOME now on ArchLinux. But once I close OOo, all visual glitches would disappear, or when I click that "Show desktop" widget, it repaints the desktop and fixes the glitches too.

Edit: With Emerald as the WM (And compiz running), OpenOffice.org 3.0 shows a thick white border instead of using the colors of the WM theme. And putting the cursor on the titlebar makes it flicker. Guess its some problem with how OOo draws itself on the screen. It doesn't like anything but default setup and definitely not window compositing.

Last edited by QwertyManiac (2008-10-11 06:31:13)

Offline

#6 2008-10-11 00:42:12

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 244

Re: Openoffice 3.0 freezing

Hey, anyone knows why is support for kde dropped in Arch's openoffice!?!

Offline

#7 2008-10-11 01:19:58

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,112

Re: Openoffice 3.0 freezing

Thanks for this tip. I had been experiencing this problem every time I tried one of the OOo 3 previews or betas, but I never figured out the cause. I knew that there was no longer a special KDE interface for OOo 3, but I didn't know that not using the Gnome interface would cause problems.


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#8 2008-10-11 06:38:30

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Openoffice 3.0 freezing

Here's the related thread in the dev ML: http://archlinux.org/pipermail/arch-dev … 08553.html

Offline

#9 2008-10-11 09:13:26

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

sry, but this is a crappy release -.-
openoffice isn't working at all

Offline

#10 2008-10-11 09:20:45

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,946
Website

Re: Openoffice 3.0 freezing

Thanks for you fine description of the problems you are having. </sarcasm>

How are we supposed to fix your problem with that description?

Offline

#11 2008-10-11 09:35:00

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

it constantly crashes even if i enter export OOO_FORCE_DESKTOP=gnome before starting it.
swriter starts fine --> chose a new document --> crashes --> restarted --> tries to recover the document --> crashes because it's not able to recover it ... a vicious circle big_smile

Offline

#12 2008-10-11 10:00:43

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,946
Website

Re: Openoffice 3.0 freezing

Does removing ~/.openoffice* fix this?

Offline

#13 2008-10-11 10:11:00

Gonzakpo
Member
Registered: 2008-05-17
Posts: 45

Re: Openoffice 3.0 freezing

No, it doesn't. OOo here is incredible unstable (kde4). Maybe it's time to switch to koffice.

Offline

#14 2008-10-11 10:19:46

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

nope. i tried every fix, found on this forum, but none of them worked ....

Offline

#15 2008-10-11 10:20:46

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,946
Website

Re: Openoffice 3.0 freezing

Anything output of interest when starting it from a terminal?

Offline

#16 2008-10-11 10:30:03

karoshi
Member
From: Marburg
Registered: 2008-02-26
Posts: 182

Re: Openoffice 3.0 freezing

Allan wrote:

Anything output of interest when starting it from a terminal?

Nope. Just hole plasma totally freakes out. My clock disappears, colours invert (the whole desktop sometimes!). OpenOffice menues and icons only appear when i put the mouse over it.

P.S.: Nice new splash screen! But its the only thing that works smile


It's a bug planet!

Offline

#17 2008-10-11 10:31:42

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

Offline

#18 2008-10-11 10:33:37

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,961
Website

Re: Openoffice 3.0 freezing

Have you openjdk installed? If not and the installation of these fixes the problem, please report the bug. It's a missing dependency then.

Offline

#19 2008-10-11 10:40:21

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

thx for the reply, but openjdk6 didn't fix the problem. still have the same output without the java runtime thingy

Offline

#20 2008-10-11 10:48:09

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,946
Website

Re: Openoffice 3.0 freezing

Can you have a look through your home folder for something that would tell writer to recover a document?  It has to be there somewhere, but I have no idea where if not in ~/.openoffice.org/

Edit: look for a file Recovery.xcu

Offline

#21 2008-10-11 11:01:42

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

rm .openoffice.org/3/user/registry/data/org/openoffice/Office/Recovery.xcu

i think the problem is that it trys to recover the doc automatically after ooo has crashed

Offline

#22 2008-10-11 11:13:13

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: Openoffice 3.0 freezing

double post, but this was fixing the issue big_smile

http://bbs.archlinux.org/viewtopic.php? … 58#p432258

Offline

#23 2008-10-11 12:20:29

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819
Website

Re: Openoffice 3.0 freezing

arch0r wrote:

it constantly crashes even if i enter export OOO_FORCE_DESKTOP=gnome before starting it.
swriter starts fine --> chose a new document --> crashes --> restarted --> tries to recover the document --> crashes because it's not able to recover it ... a vicious circle big_smile

Same here. The desktop variable has been sitting in my ~/.bashrc for ages (since 2.x) and removing ~/.openoffice.org does not help.

[stijn@hermes ~]$ /opt/openoffice/program/swriter 
javaldx: Could not find a Java Runtime Environment! 
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
^C[stijn@hermes ~]$

Java isn't required is it?

Edit: as the thread linked to above suggests, installing libxslt takes care of the problem.

Last edited by B (2008-10-11 12:23:10)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#24 2008-10-11 12:24:20

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,946
Website

Re: Openoffice 3.0 freezing

B: Look in the link in the post above yours (or for the lazy - install libxslt)

Offline

#25 2008-10-11 13:39:37

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819
Website

Re: Openoffice 3.0 freezing

I just did, a minute before you posted tongue


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

Board footer

Powered by FluxBB