You are not logged in.

#1 2008-10-21 19:13:08

DingoMD
Member
Registered: 2008-10-21
Posts: 13

[SOLVED] DBus error when accessing "Windows Network"

I'm getting an error when trying to access "Windows Network" from Nautilus after last Gnome (2.22 -> 2.24) update:

Unable to mount location
DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Please tell me if you need me to post any more info/logs.
Thanks in advance wink

Last edited by DingoMD (2008-10-22 08:07:36)

Offline

#2 2008-10-21 19:29:14

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] DBus error when accessing "Windows Network"

i do have the same problem and i can't find any fix


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2008-10-21 20:41:16

Kirurgs
Member
Registered: 2008-10-20
Posts: 141

Re: [SOLVED] DBus error when accessing "Windows Network"

Mee too have the same problem, searching for fix, but no luck so far sad

edit: THIS IS SOLVED by installing smbclient and samba from testing repo!

Last edited by Kirurgs (2008-10-21 21:25:00)

Offline

#4 2008-10-21 21:32:12

DingoMD
Member
Registered: 2008-10-21
Posts: 13

Re: [SOLVED] DBus error when accessing "Windows Network"

Kirurgs wrote:

edit: THIS IS SOLVED by installing smbclient and samba from testing repo!

Hopefully those will get moved to extra soon. Thanks for your reply smile

Offline

#5 2008-10-21 21:46:54

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] DBus error when accessing "Windows Network"

thx for the tip. is working


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2010-04-01 08:35:35

Srigi
Member
Registered: 2007-08-04
Posts: 11

Re: [SOLVED] DBus error when accessing "Windows Network"

I'm bumping this thread, cos I have same issue as in 1st post. Cannot open shared folder (but can se it in Nautilus). Any ideas.

Offline

#7 2010-04-08 01:24:29

Fraterius
Member
Registered: 2008-12-03
Posts: 18

Re: [SOLVED] DBus error when accessing "Windows Network"

I have the same problem, witch doesn't occur when I downgrade to the previous version of samba and smbclient. Any ideas would be much appreciated.

Offline

#8 2010-04-08 03:27:46

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: [SOLVED] DBus error when accessing "Windows Network"

Srigi wrote:

I'm bumping this thread, cos I have same issue as in 1st post. Cannot open shared folder (but can se it in Nautilus). Any ideas.

Fraterius wrote:

I have the same problem, witch doesn't occur when I downgrade to the previous version of samba and smbclient. Any ideas would be much appreciated.

Are the two of you getting the same error message or having a similar problem? If it's a simlar problem, please open a new thread with any relevant information. If it's the same, then posting here is fine.

Offline

#9 2010-04-08 20:12:50

Fraterius
Member
Registered: 2008-12-03
Posts: 18

Re: [SOLVED] DBus error when accessing "Windows Network"

I got the same error as in first post, so all is fine, except there's no cure for it wink. Am I the only person that have such issue after upgrading samba?

Offline

#10 2010-04-13 00:18:19

timegonebomb
Member
Registered: 2010-04-13
Posts: 2

Re: [SOLVED] DBus error when accessing "Windows Network"

I'm having the problem as well, on a computer that I just installed arch on. After a quick google search, I realized that it isn't an arch specific issue (no surprise there, thats why I love arch), but rather an upstream issue. The bug appears to stem from gvfs, at least according to an ubuntu bug report on the issue. I noticed in my case, that if I kill the process gvfsd-smb-browse (the one using like 80% of cpu), that everything works fine afterwards (after restarting nautilus).

Hopefully this gets fixed in a later update.

Offline

#11 2010-04-13 01:59:15

dmartins
Member
Registered: 2006-09-23
Posts: 318

Re: [SOLVED] DBus error when accessing "Windows Network"

Are those with a problem using share level security on the samba server?
Have you tried accessing the share using smbclient? (smbclient //server/share)

I have been receiving the original dbus error for some time now.
I am using share level security on the server.
Using smbclient results in a segfault. Using nautilus also results in an error from libsmbclient which can be seen in one of the log files.

[mythtv@tvee ~]$ smbclient //sirschmoopy/shared
Enter mythtv's password: 
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.1]
Server not using user level security and no password supplied.
Segmentation fault

There is a samba bug which looks similar but it only affects people with ipv6 disabled. I have disabled and enabled ipv6 several times and the errors persist.

I think it may be related to this bug: https://bugzilla.samba.org/show_bug.cgi?id=7250
I haven't tried the patch provided yet.


-- Dan

Offline

#12 2010-04-13 05:00:47

timegonebomb
Member
Registered: 2010-04-13
Posts: 2

Re: [SOLVED] DBus error when accessing "Windows Network"

Shame on me for not providing details.

Anyhow, I am using share level security (its windows vista). Truthfully samba isn't set up on this machine yet. I'm using smbclient version 3.5.2. which works perfectly from the commandline to access the vista machine. I don't get any errors or segfaults like you do. The only problem i have at this point is with nautilus/gnome.

Sounds like you have the problem that I have, but in addition to it, you have a whole other problem with samba. Good luck though. hmm

Last edited by timegonebomb (2010-04-13 05:06:03)

Offline

#13 2010-04-13 08:31:12

simba
Member
Registered: 2010-04-13
Posts: 6

Re: [SOLVED] DBus error when accessing "Windows Network"

I have the same issue with DBus error and segmentation fault.
Global update didn't help.
The only solving for now is not to use "share" security mode and wait for fixing this bug.

Offline

#14 2010-04-13 13:51:33

honki
Member
Registered: 2005-11-04
Posts: 16

Re: [SOLVED] DBus error when accessing "Windows Network"

there's a fix in samba-git. see: http://gitweb.samba.org/?p=samba.git;a= … 2d98001ce7

bugreport and updated pkgbuild: http://bugs.archlinux.org/task/19077

Offline

Board footer

Powered by FluxBB