You are not logged in.

#1 2004-08-02 17:22:20

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

gtk and gnome

Gtk-theme-switch does not work in gnome. But it work in fluxbox and other wm. Why?

Offline

#2 2004-08-02 17:24:09

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: gtk and gnome

gnome has a special tool to edit theme/icon...-stuff that overrides switch2


The impossible missions are the only ones which succeed.

Offline

#3 2004-08-02 17:56:48

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: gtk and gnome

I need switch1, for xmms.

Offline

#4 2004-08-02 18:42:46

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: gtk and gnome

about switch1 i'm not sure, because i do not use gnome, sorry


The impossible missions are the only ones which succeed.

Offline

#5 2004-08-02 19:06:19

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: gtk and gnome

Ok, i solve this problem by edit ~.gtkrc. But i have another problem: my AL set to KOI8-R. In gnome all gtk1 (and only gtk1 - gtk2 and other in koi8) programs in unknown code page. That i can edit to bring on koi8 in gtk1 in gnome?
PS: I use fluxbox, but i want to try gnome.

Offline

#6 2004-08-02 21:56:38

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: gtk and gnome

i dont know for sure, but as far i know, you can try to set the locale to your language - maybe gtk1 needs it

EDIT:
did some googling, yes! gtk1 needs LANG and LC set right
http://idea.hosting.lv/a/i18n/


The impossible missions are the only ones which succeed.

Offline

#7 2004-08-03 13:18:07

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: gtk and gnome

thnx!
PS: now i have another problem - any help button(that locate in menu then right-click on Applications menu for example) return this error:
Cannot display help document
Details: There was an error launching the default action command associated whith this location.
There i can change the default action command?

Offline

#8 2004-08-03 14:14:57

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: gtk and gnome

no idea about this - sorry


The impossible missions are the only ones which succeed.

Offline

#9 2004-08-03 20:50:12

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtk and gnome

Net@Worm wrote:

I need switch1, for xmms.

tell the world what you changed and it worked! smile
also consider writing a wiki.archlinux.org page about it

thanks in advance man
tell us what you did

Offline

#10 2004-08-03 22:59:00

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: gtk and gnome

1. To zeppelin: If you mean how I have forced it to work in gnome it is very simple:
in ~/.gtkrc-1.2-gnome2 (it must be created, if not - create) add line

include "/home/networm/.gtkrc.mine"

and do

cat .gtkrc > .gtkrc.mine

It works for me.
PS: .gtkrc - file where switch store path to gtk1 theme(exmpl.: include "/usr/share/themes/G26/gtk/gtkrc").

2. I have another problem with gnome wink. When I add in applications:///Multimedia (for example) the new program, she does not appear in the this folder and applications-menu, but it appear after restart gnome. how to correct it?

Offline

#11 2004-08-04 18:05:42

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtk and gnome

Net@Worm wrote:

2. I have another problem with gnome wink. When I add in applications:///Multimedia (for example) the new program, she does not appear in the this folder and applications-menu, but it appear after restart gnome. how to correct it?

I thought that was normal for GNOME. It could be a way to force GNOME to scan for new items without restarting, but I' don't know it.

thanks for the tip btw.
[i only found this in the wiki of AL: http://wiki.archlinux.org/index.php/Gno … 20tweaking ]
btw do you plan/want to write a quick tip about the 1. in wiki?
under the Hints&Tips section..

Offline

#12 2004-08-04 18:58:33

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtk and gnome

first of all I had to comment out include "/home/nk/.gtkrc.mine"
in .gtkrc.mine [or else it would take ages for a gtk1 widget to be drawn {i bet a inf loop or sth}]
so it looks like this now:
include "/usr/share/themes/Delightfully-Smooth/gtk/gtkrc"
#include "/home/nk/.gtkrc.mine"


But for GTK2 apps {gtk1 apps don't show this} I now get this stuff:

GLib-GObject-CRITICAL **: file gobject.c: line 1579 (g_object_unref): assertion `G_IS_OBJECT (object)' failed
/usr/share/themes/Delightfully-Smooth/gtk/gtkrc:36: error: unexpected identifier `GtkWidget', expected character `}'

any ideas?

Thanks

Offline

#13 2004-08-04 19:08:05

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: gtk and gnome

Have you installed switch2? If no install it and choose your theme. If it installed look .gtkrc-2.0 file in your home directory, he must look like this:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/G26/gtk-2.0/gtkrc"

include "/home/networm/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT

Offline

#14 2004-08-05 12:33:35

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtk and gnome

It doesn't fix it.
I use gnome theme system to change my themes.
I never use switch2, I'm not sure if it does or not the same
with gnome theme manager.
but anyways it didn't help

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Allegro/gtk-2.0/gtkrc"

include "/home/nk/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT
.gtkrc-2.0 (END)
# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Delightfully-Smooth/gtk/gtkrc"

#include "/home/nk/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT
.gtkrc.mine (END)
# Autowritten by gnome-settings-daemon. Do not edit

include "/home/nk/.gtkrc.mine"
.gtkrc-1.2-gnome2 (END)
# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Delightfully-Smooth/gtk/gtkrc"

include "/home/nk/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT
.gtkrc (END)

with all that GNOME themes don't behave too well I must say. [it crushes sometimes]

Offline

#15 2004-08-05 13:01:54

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gtk and gnome

what follows is a success story in less than 5 minutes:
{or why I like GNU/Linux and GNOME philosophy so much}

CTRL + ALT + BACKSPACE
removed  .gtkrc* from my home directory
rm .gnome2/session [or else gnome would go crazy] 2 panels etc [weird stuff how such stuff happend, but it SO EASY to fix them]

did
startx and I was up!
I now have:

# Autowritten by gnome-settings-daemon. Do not edit

include "/home/nk/.gtkrc.mine"
.gtkrc-1.2-gnome2 (END)

and

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Delightfully-Smooth/gtk/gtkrc"
# -- THEME AUTO-WRITTEN DO NOT EDIT
.gtkrc.mine (END)

and I'm up with an experience of themes I never had before! (gtk1 themes and gtk2 themes so cool) [I bet I had some bad stuff remained all over from the gnome26 unstable days]

so yet again my signature says it all

ps.
at last xmms menus are drawn beautifully

Offline

Board footer

Powered by FluxBB