You are not logged in.

#1 2008-11-30 22:36:42

peart
Member
From: Kanuckistan
Registered: 2003-07-28
Posts: 510

XFCE4 shutdown stopped working after update

Hello Archers,

I use XFCE, and when I try to shut down using the panel button, my X session ends, and I'm left on the console, with the following error message:

** (xfce4-session:2398): WARNING **: xfsm-shutdown-helper .c:176: Failed to contact HAL: org.freedesktop.hal.power-management.shutdown no <-- (action, result)

This just started today after the big xorg update.  What I find puzzling is that I've been using testing for several months, and everything worked fine until today.  Anyway, has anyone else come across this problem, and is there a known solution?

Also, I just noticed I have about 50 console-kit-daemon processes running.  I've seen a previous thread about this, so I'll search and hopefully find a solution.

Offline

#2 2008-11-30 23:21:22

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: XFCE4 shutdown stopped working after update

Same here, worked fine the last few weeks (?) and my machine suddenly doesn't want to reboot anymore.

Offline

#3 2008-11-30 23:52:24

Allan
is always right
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,463
Website

Re: XFCE4 shutdown stopped working after update

I added this in my /etc/PolicyKit/PolicyKit.conf

<config version="0.1">
    <define_admin_auth group="wheel"/>

    <match user="root">
        <return result="yes"/>
    </match>

    <match action="org.freedesktop.hal.storage.mount-removable">
        <return result="yes"/>
    </match>

    <match action="org.freedesktop.hal.power-management.suspend">
        <return result="yes"/>
    </match>

    <match action="org.freedesktop.hal.power-management.hibernate">
        <return result="yes"/>
    </match>

    <match action="org.freedesktop.hal.power-management.shutdown">
        <return result="yes"/>
    </match>

        <match action="org.freedesktop.hal.power-management.reboot">
        <return result="yes"/>
    </match>

    <match action="org.freedesktop.hal.power-management.lcd-panel">
        <return result="yes"/>
    </match>
</config>

Though there is probably a better way to do this..,

Offline

#4 2008-12-01 00:16:52

TecnoVM64
Member
From: Santiago, Chile
Registered: 2007-06-02
Posts: 45

Re: XFCE4 shutdown stopped working after update

Same issue here, I have no idea why D:

Offline

#5 2008-12-01 00:25:45

peart
Member
From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: XFCE4 shutdown stopped working after update

Hey Allan,

I figured that ConsoleKit or PolicyKit would be the culprit, but I was looking at the first, not the second.  Thanks for the info.  I just reverted to hal-0.5.11-4 for now because I really don't want 64 console-kit-daemon threads running big_smile

Offline

#6 2008-12-16 10:54:27

MindTooth
Member
From: Norway
Registered: 2008-11-11
Posts: 331

Re: XFCE4 shutdown stopped working after update

I have the same issue. Read that using the testing version of HAL would fix it. But the fact is that it was the testing version that crashed the system.

Birger smile

Offline

#7 2008-12-16 16:50:48

peart
Member
From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: XFCE4 shutdown stopped working after update

Hey MindTooth,

I found a bug report on the new hal (and PoliciyKit/ConsoleKit), and in it it says to modify your .xinitrc (if you use it) :

exec ck-launch-session xfce4-session

When using the new hal from testing, you just have to add the ck-launch-session part after exec to get a ConsoleKit session.  This has solved my logout problem without adding anything to the other config files.

HTH

Edit: do not post before having 1st coffee

Last edited by peart (2008-12-16 17:11:38)

Offline

#8 2008-12-17 09:53:46

MindTooth
Member
From: Norway
Registered: 2008-11-11
Posts: 331

Re: XFCE4 shutdown stopped working after update

Hmm. So I should use xfce4-session instead of startxfce4?

Birger smile

Offline

#9 2008-12-17 11:40:48

Allan
is always right
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,463
Website

Re: XFCE4 shutdown stopped working after update

I don't.   My .xinitrc has

exec ssh-agent ck-launch-session startxfce4

You can also add the pam module to (e.g.) slim but that does not work completely (suspend when I close the laptop screen being an issue).

Offline

#10 2009-11-10 16:33:57

fileunderwater
Member
Registered: 2009-11-08
Posts: 21

Re: XFCE4 shutdown stopped working after update

The xinitrc-solution is not working for me. Any other suggestions?

I'm getting the same error:

** (xfce4-session:1519): WARNING **: xfsm-shutdown-helper .c:234: Failed to contact HAL: org.freedesktop.hal.power-management.shutdown no <-- (action, result)

but right above it I'm getting (however before the message that HAL is used for shutdown):

(xfce4-settings-helper:1910): GLIB-GObject-CRITICAL **: g_param_spec_flags: assertion 'G_TYPE IS_FLAGS (flags_type)' failed

(xfce4-settings-helper:1910): GLIB-GObject-CRITICAL **: g_object_class_install_property: assertion 'G_IS_PARAM_SPEC (pspec)' failed

are they related?


And finally; Thank you all for a great forum and wiki. I'm pretty new to linux, but went with Arch because I wanted to build from the ground-up (both system and knowledge-wise). Installation took a while but went smoothly thanks to the great guides available. I'm running on a Dell latitude D600 and haven't had any major problems so far. Still have some tweaking and learning to do though.

Last edited by fileunderwater (2009-11-10 16:57:00)

Offline

#11 2009-11-10 17:08:53

grey
Member
From: Europe
Registered: 2007-08-23
Posts: 679

Re: XFCE4 shutdown stopped working after update


Good ideas do not need lots of lies told about them in order to gain public acceptance.

Offline

#12 2009-11-10 20:46:14

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,612

Re: XFCE4 shutdown stopped working after update

I don't even have any ck-launch-session, just exec startxfce4, I don't know if anything on testing will break this but since the first time that this problem showed up a few months ago that I have this working just fine, mind you that I don't have any graphical login manager.

/etc/PolicyKit/PolicyKit.conf :

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">
    <match action="org.freedesktop.hal.storage.*">
        <return result="yes"/>
    </match>
    <match action="org.freedesktop.hal.power-management.*">
        <return result="yes"/>
    </match>
</config>

.bash_profile :

. $HOME/.bashrc
if [[ $(tty) == /dev/tty1 ]]; then
startx &> /dev/null &
logout
fi

Edit:
I stand corrected, the latest hal update required me to add ck-launch-session to my .xinitrc so I can shutdown/reboot without inputting a password.

Last edited by R00KIE (2009-11-11 13:59:00)


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#13 2009-11-10 22:53:42

fileunderwater
Member
Registered: 2009-11-08
Posts: 21

Re: XFCE4 shutdown stopped working after update

grey wrote:

Yes, I've tried those xfce solutions and they dont work for me. I've also tried the PolicyKit soluton posted here recently, but that didn't work either. Still getting the "Failed to contact HAL" message. Really annoying, but not essential. I can still logout X and reboot/shutdown from the prompt using sudo.

Offline

Board footer

Powered by FluxBB