You are not logged in.

#1 2004-08-05 21:14:16

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

something causing fluxbox hang at X exit

i have tried both the my own compiled CVS version and the fluxbox-devel package from unstable and they both crash when i click exit on the menu and the cpu maxes out.  this has not been happening until today.  i upgraded to xorg and several other big libs so i'm not sure if it may be related???

Offline

#2 2004-08-05 21:41:58

ghostwalker
Member
From: Tacoma, WA
Registered: 2004-07-28
Posts: 140

Re: something causing fluxbox hang at X exit

I am using the cvs from flux.org with no problems. It exits correctly. They did an update yesterday.

Walt


P4 2.8Ghz @ 2.8Ghz SL6WT
Zalman CNPS7000-Cu
865PE Neo-2 LS BIOs 2.4
512mb Mushkin Level II
160GB Maxtor HD
Geforce 4 440MX
Antec 3700 1 exhaust and 1 intake fans
Linux 2.6.x
Linux user 314187
ArchLinux

Offline

#3 2004-08-05 23:13:14

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: something causing fluxbox hang at X exit

something must be making fluxbox hang if both the CVS and AL version are doing it.  any suggestions?

i have tried starting X with fluxbox as the only app running but it stilll hangs at exit sad

Offline

#4 2004-08-06 00:35:55

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 707
Website

Re: something causing fluxbox hang at X exit

In the cvs and devel version of fluxbox, if you "exit" through a menu, your X will freeze.  Here's you solution:  ALT-CTRL-BKSPACE.


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#5 2004-08-06 00:50:54

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: something causing fluxbox hang at X exit

There is another thread on this
http://bbs.archlinux.org/viewtopic.php?p=36125#36125

Here is the solution.  In your $HOME/.fluxbox/init change

session.screen0.slit.autoHide: False

to

session.screen0.slit.autoHide: True

This fixes the problem.

Only a few people are having the problem, so the developer is having trouble fixing it as he can't reproduce it on his machines.

It's always good to do a search on the forums before posting the problem.

As I said, it only seems to hit some people--note that one of the posters here hasn't had the problem.

Offline

#6 2004-08-06 08:59:17

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: something causing fluxbox hang at X exit

cheers everyone

scottro - i always search the boards before i post and as a moderator of the VL forum myself I completely appreciate the importance of doing so.

and i'd like to add that another thing i appreciate as a mod is well-titled threads that remain on topic, i dunno how many times i tell our board users how important it is for people to be able to find what they need using the search.  "fluxbox-devel 0.9.9 question" does not cut the mustard with me and i reserve the right to have missed it in my search  wink

Offline

#7 2004-08-06 09:44:10

_PickledOnion_
Member
From: Lincoln,UK
Registered: 2004-07-31
Posts: 21
Website

Re: something causing fluxbox hang at X exit

I also have this problem (and it is a specifc Arch Linux problem as it works perfectly well on lfs/gentoo/fedora/suse/etc).

I appreciate the 'fix' posted above by scottro but it's a work around that reduces the effectiveness of one of the main reasons I use fluxbox, i.e. the slit.

Hiding it is not an option as I have things there that I need to keep an eye on all the time. Does anyone have a solution that does not involve actually removing the fully working functions of fluxbox such as a constantly viewable slit or the exit command?

Also, is there any information the devs need from those of us who do have this problem?

Thanks

[edit]

I see there is more on this on the fluxbox-devel thread. I'll put anything else in that thread.

Still no solution though  sad

[/edit]


pickledonion AT gmail.com

Offline

#8 2004-08-06 10:24:52

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: something causing fluxbox hang at X exit

i use the slit for gkrellm and i use gkrellm for a reason - it's annoying to have it on autohide sad

Offline

#9 2004-08-06 15:55:28

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: something causing fluxbox hang at X exit

Heh, you're a Vector mod?  I like Vector actually, play with it sometimes, but these days don't have time.

Offline

#10 2004-08-06 18:48:08

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: something causing fluxbox hang at X exit

i was!  our bbs seem to have vanished  :cry:

Offline

#11 2004-08-08 17:43:06

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: something causing fluxbox hang at X exit

As I posted on the other thread as well, the developer has modified the PKGBUILD to fix the problem--however, he's doing it by autohiding the slit)
This will, at least, work for those who don't need the slit always showing.

Also, he's finally gotten a box where he can reproduce the problem--so help is on the way.  smile

Offline

Board footer

Powered by FluxBB