You are not logged in.

#1 2004-08-06 19:03:19

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

ncftp long file name problem

in my old distro i used ncftpput to put screenshots and other items straight onto my ftp server.  here is an example of the rox wrapper i used:

#!/bin/bash
BASE=/home/dtw/images/screenshots

    ncftpput -f $BASE/.login.cfg -b /public_html/dtw/share "$1";
        ncftpbatch -d;

and i get an error that says

this program needs long filenames, sorry.

and it doesn't work - any ideas?

Offline

#2 2004-08-06 19:55:19

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: ncftp long file name problem

perhaps there is a configure option that was not used when building ncftp that had gone unnoticed until now. I recommend filing a bug or contacting the maintainer. Sometimes file length options need to be specified. or perhaps something else is going on that is compressing many file names into one?


AKA uknowme

I am not your friend

Offline

#3 2004-08-06 20:38:05

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

Re: ncftp long file name problem

i'm hoping it's a config option that needs setting.  how can i check that? and how can i revist information that appears at install time?  for example, gshield tells you how to set your iptables=gshield firewall rules - how do i get that titbit back for if i change my rules??

Offline

#4 2004-08-06 22:45:58

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: ncftp long file name problem

dibblethewrecker wrote:

i'm hoping it's a config option that needs setting.  how can i check that?

In console, as root (this works for the packages in the repositories)

abs
cd /var/abs/category/yourpkg

for example, you'll find the kernel26 PKGBUILD at "/var/abs/kernels/kernel26/PKGBUILD".

dibblethewrecker wrote:

and how can i revist information that appears at install time?

You can't.

dibblethewrecker wrote:

for example, gshield tells you how to set your iptables=gshield firewall rules - how do i get that titbit back for if i change my rules??

1. execute "/etc/firewall/gShield.rc" again # this flushes the old chains & loads the new settings
2. "iptables-save > /etc/iptables/iptables.rules" # this saves the rules for the iptables daemon (that comes with Arch) to load them

Hmm.. I did the gShield package available on the forums. The initial gShield.rc script was supposed to be started by init.d (or whatever it is called on another systems) - this way the gShield.conf file would have been read at every start of the machine. I think I tried creating a wrapper for gShield.rc to get the same behaviour, but then its output doesn't look bright. Some like:

Starting gShield... [BUSY]
Flushing chains.
Loading NAT rules
Loading Allowed ports...
...
Starting gShield... [DONE]

DONE didn't even appear instead of BUSY, it appeared on another line, as far as I remember. Then I decided the best thing to do is to use the already present daemon "iptables" that comes with Arch. Of course, now that I think of it, I could patch gShield.rc in the PKGBUILD to automatically save the rules with iptables-save.

Offline

#5 2004-08-06 23:57:21

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: ncftp long file name problem

IceRAM wrote:
dibblethewrecker wrote:

and how can i revist information that appears at install time?

You can't.

Well sure you can by using the web interface for the CVS and browsing into the directory for whatever package and looking at the <packagename>.install file.

for example:

http://cvs.archlinux.org/cgi-bin/viewcv … root=Extra


AKA uknowme

I am not your friend

Offline

#6 2004-08-07 09:47:48

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: ncftp long file name problem

sarah31 wrote:

Well sure you can by using the web interface for the CVS and browsing into the directory for whatever package and looking at the <packagename>.install file.

Never thought about this such out of hand (but unique) method.  big_smile
(I don't recheck the install messages at all, they're usually necessary for the first time run)

Offline

#7 2004-08-07 10:21:23

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

Re: ncftp long file name problem

cheers guys!  does pay to be able to back track!  i really like you gShield fix - my old distro just provided the packages and no clues how to use it and i worked it out for myself.  the big prob with the init.d method was i use ppp and if ppp wasn't up when gShield.rc ran it would block the ppp port and you couldn't dial out - but i had it so gShield ran when ip-up was run when i ran ppp - your method is lots better tho!  i was going to recommend it on our forum but it has gone  :cry:

i think i have made the switch to arch now anyway  big_smile

Offline

#8 2004-08-11 14:37:36

dtw
Forum Fellow
From: London, UK
Registered: 2004-08-03
Posts: 4,428
Website

Re: ncftp long file name problem

i checked the configure options for ncftp and i can see no mention of longfile names.  i am very confused by the behaviour of this package.  for some reason i can't even batch ftp jobs with ncftpput, this should be unaffected by the long file names prob as that is affecting ncftpbatch - it's very annoying!

.:edit:.

OK - some success - it seems ncftpbatch is the problem ncftpput works fine without the -b or -bb commands but doesn not work at all with them - anyone  else having problems with ncftpbatch?

Offline

Board footer

Powered by FluxBB