You are not logged in.

#1 2008-12-25 06:32:20

3lusive
Member
Registered: 2008-04-07
Posts: 26

Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

I compiled and booted into 2.6.28 and switched xorg.conf back to
EXA.

Ok, it worked a little bit better but it did not WOW me.  So, I compiled by hand the
latest intel driver and DAMN! very smooth in Compiz... "lightening fast"  I don't have
any 3d games to compare but, some "artifacts" that were happening on startup of the
AWN dock are GONE.   I can play a movie trailer and drag it around with wobbly windows
and it looks awesome.

Here's what I did.... 
use./autogen.sh --prefix=/usr  or ./configure --prefix=/usr where appropriate.

[1] pthread-stubs
git clone git://anongit.freedesktop.org/xcb/pthread-stubs
./autogen.sh --prefix=/usr

[2] xf86driproto
git clone git://anongit.freedesktop.org/xorg/proto/xf86driproto
./autogen.sh --prefix=/usr
make install (its just headers so there's nothing to compile)

[3] Dec 22 version of libdrm (the latest)
http://dri.freedesktop.org/libdrm/libdrm-2.4.3.tar.bz2

[4] Intel driver
http://xorg.freedesktop.org/archive/ind … 9.1.tar.gz
./configure --prefix=/usr

Transitions everything now in Compiz is smooth, smooth, smooth....!!!!!!

Enjoy!!!!


[ANNOUNCE] xf86-video-intel 2.5.99.1     Mon Dec 15 17:43:30 PST 2008
http://lists.freedesktop.org/archives/x … 00714.html

Offline

#2 2008-12-25 06:56:46

3lusive
Member
Registered: 2008-04-07
Posts: 26

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Intel Linux Graphics Performance Q4'08
Published on December 23, 2008  Written by Michael Larabel

http://www.phoronix.com/scan.php?page=a … q408&num=1

Offline

#3 2008-12-26 01:22:45

Damnshock
Member
From: Barcelona
Registered: 2006-09-13
Posts: 414

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Can't wait for it to hit the repos... big_smile (I'm just too lazy and busy right now to install it myself)


My blog: blog.marcdeop.com
Jabber ID: damnshock@jabber.org

Offline

#4 2008-12-26 04:08:58

crayxt
Member
Registered: 2008-12-19
Posts: 37

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Hi all,
where can I get PKGBUILD for this kernel? I've already downloaded kernel archive


Всем выйти из Сумрака!!!

Уважение - это когда чтобы поприветствовать человека вытаскиваешь оба наушника.
my blog

Offline

#5 2008-12-26 04:20:19

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

For those who'd like some PKGBUILDs in order of compilation and install, these are what I used and it works quite well. smile

libpthread-stubs

pkgname=libpthread-stubs
pkgver=0.1
pkgrel=1
pkgdesc="stubs missing from libc for standard pthread functions"
arch=('i686' 'x86_64')
url="http://xcb.freedesktop.org/"
license=('MIT')
source=(http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2)
md5sums=('774eabaf33440d534efe108ef9130a7d')

build() {
  cd "$srcdir/$pkgname-$pkgver"

  ./configure --prefix=/usr
  make || return 1
  make DESTDIR="$pkgdir/" install
}

libdrm

pkgname=libdrm
pkgver=2.4.3
pkgrel=1
pkgdesc="Userspace interface to kernel DRM services"
arch=(i686 x86_64)
depends=('glibc' 'libpthread-stubs')
options=('!libtool' 'force')
url="http://dri.freedesktop.org/"
source=(http://dri.freedesktop.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR="${pkgdir}" install || return 1
}

libxcb

pkgname=libxcb
pkgver=1.1.93
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
depends=('xcb-proto>=1.2' 'libxdmcp' 'libxau')
makedepends=('pkgconfig' 'libxslt' 'python')
options=('!libtool')
license=('custom')
source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd ${srcdir}/${pkgname}-${pkgver}
  libtoolize --force --copy || return 1
  aclocal || return 1
  autoconf || return 1
  automake --add-missing || return 1
  ./configure --prefix=/usr --enable-xinput || return 1
  make || return 1
  make DESTDIR=${pkgdir} install || return 1
  install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
  install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}

libx11

pkgname=libx11
pkgver=1.1.99.2
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
depends=('libxcb>=1.1.90.1' 'kbproto>=1.0.3')
makedepends=('xproto>=7.0.13' 'xextproto>=7.0.3' 'xf86bigfontproto>=1.1.2' 'xtrans>=1.2.1' 'kbproto>=1.0.3' 'inputproto>=1.4.4' 'xorg-util-macros')
options=('!libtool')
license=('custom:XFREE86')
source=(${url}/releases/individual/lib/libX11-${pkgver}.tar.bz2
        xorg.sh)
md5sums=()

build() {
  cd ${srcdir}/libX11-${pkgver}

  libtoolize --force --copy || return 1
  aclocal || return 1
  autoconf || return 1
  automake --add-missing || return 1

  ./configure --prefix=/usr \
              --with-xcb || return 1
  make || return 1
  make DESTDIR=${pkgdir} install || return 1

  install -m755 -d ${pkgdir}/etc/profile.d
  install -m755 ${srcdir}/xorg.sh \
                ${pkgdir}/etc/profile.d/ || return 1
  install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}
  install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}

xorg.sh

export XDG_DATA_HOME=$HOME/.local/share
export XDG_CONFIG_HOME=$HOME/.config
export XDG_CACHE_HOME=$HOME/.cache

if [ -z $XDG_DATA_DIRS ]; then
        export XDG_DATA_DIRS=/usr/share:/usr/local/share
else
        export XDG_DATA_DIRS=/usr/share:/usr/local/share:$XDG_DATA_DIRS
fi

if [ -z $XDG_CONFIG_DIRS ]; then
        export XDG_CONFIG_DIRS=/etc/xdg
else
        export XDG_CONFIG_DIRS=/etc/xdg:$XDG_CONFIG_DIRS
fi

dri2proto-git

pkgname=dri2proto-git
pkgver=20081228
pkgrel=1
pkgdesc="X11 OpenGL extension wire protocol"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
license=('custom')
replaces=('dri2proto')
provides=('dri2proto=1.99.3.99' 'dri2proto-git')
conflicts=('dri2proto')
groups=('xorg')
source=()
md5sums=()

_gitroot="git://anongit.freedesktop.org/xorg/proto/dri2proto"
_gitname="dri2proto"

build() {

 msg "Connecting to git.freedesktop.org GIT server...."

  if [ -d $startdir/src/$_gitname ] ; then
  cd $_gitname && git pull origin
  msg "The local files are updated."
  else
  git clone $_gitroot
  fi

  msg "GIT checkout done or server timeout"
  msg "Starting make..."

cd $startdir/src/$_gitname

  sh autogen.sh --prefix=/usr
  make || return 1
  make DESTDIR=${startdir}/pkg install || return 1
}

xf86driproto-git

pkgname=xf86driproto-git
pkgver=20081228
pkgrel=1
pkgdesc="Xf86driproto"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
license=('custom')
replaces=('xf86driproto')
provides=('xf86driproto=2.0.4.99' 'xf86driproto-git')
conflicts=('xf86driproto')
groups=('xorg')
source=()
md5sums=()

_gitroot="git://anongit.freedesktop.org/xorg/proto/xf86driproto"
_gitname="xf86driproto"

build() {

 msg "Connecting to git.freedesktop.org GIT server...."

  if [ -d $startdir/src/$_gitname ] ; then
  cd $_gitname && git pull origin
  msg "The local files are updated."
  else
  git clone $_gitroot
  fi

  msg "GIT checkout done or server timeout"
  msg "Starting make..."

cd $startdir/src/$_gitname

  sh autogen.sh --prefix=/usr
  make || return 1
  make DESTDIR=${startdir}/pkg install || return 1
}

libgl-git

pkgname=libgl-git
pkgver=20081224
pkgrel=1
pkgdesc="Mesa DRI OpenGL library and drivers from GIT repository"
arch=(i686 x86_64)
license=('custom')
url="http://mesa3d.sourceforge.net"
depends=('libxxf86vm' 'libdrm>=2.4.3' 'libx11>=1.1.99.2')
makedepends=('imake' 'glproto' 'git')
provides=('libgl=7.2.99')
conflicts=('libgl')
source=()
md5sums=()
_gitroot="git://anongit.freedesktop.org/git/mesa/mesa"
_gitname="mesa"

build() {
  cd ${startdir}/src/
  msg "Connecting to git.freedesktop.org GIT server...."

  if [ -d $startdir/src/$_gitname ] ; then
  cd $_gitname && git pull origin
  msg "The local files are updated."
  else
  git clone $_gitroot
  fi

  msg "GIT checkout done or server timeout"
  msg "Starting make..."

  cd $startdir/src/
  cp -r ${startdir}/src/$_gitname ${startdir}/src/$_gitname-build || return 1
  cd $startdir/src/$_gitname-build/

  CONFIG="linux-dri-x86"
  if [ "${CARCH}" = "x86_64" ]; then
    CONFIG="linux-dri-x86-64"
    sed -i -e "s/lib64/lib/g" ${startdir}/src/$_gitname-build/configs/${CONFIG}
  fi

  echo "EXTRA_LIB_PATH =" >> configs/${CONFIG}
  echo "OPT_FLAGS = ${CFLAGS}" >> configs/${CONFIG}
  echo "SRC_DIRS = glx/x11 mesa" >> configs/${CONFIG}
  rm -f include/GL/glut*h
  echo "USING_EGL = 0" >> configs/${CONFIG}
  echo "PROGRAM_DIRS =" >> configs/${CONFIG}
  echo "MKDEP = makedepend" >> configs/${CONFIG}
  echo "DRI_DIRS =" >> configs/${CONFIG}
  echo "DRI_DRIVER_SEARCH_DIR = /usr/lib/xorg/modules/dri" >> configs/${CONFIG}
  echo "ARCH_FLAGS += -DGLX_USE_TLS" >> configs/${CONFIG}
  echo "X11_INCLUDES = `pkg-config --cflags-only-I x11`" >> configs/${CONFIG}
  #echo "DEFINES += -DUSE_XCB" >> configs/${CONFIG}
  #echo "X11_INCLUDES += `pkg-config --cflags-only-I xcb` `pkg-config --cflags-only-I x11-xcb` `pkg-config --cflags-only-I xcb-glx`" >> configs/${CONFIG}
  #echo "GL_LIB_DEPS += `pkg-config --libs xcb` `pkg-config --libs x11-xcb` `pkg-config --libs xcb-glx`" >> configs/${CONFIG}

  make ${CONFIG} || return 1
  mkdir -p ${startdir}/pkg/usr
  make INSTALL_DIR=${startdir}/pkg/usr install

  rm -rf ${startdir}/pkg/usr/include

  mkdir -p ${startdir}/pkg/usr/lib/xorg/modules/extensions
  cd ${startdir}/pkg/usr/lib/xorg/modules/extensions
  ln -sf libGLcore.xorg libGLcore.so
  ln -sf libglx.xorg libglx.so
  rm -r $startdir/src/$_gitname-build
}

mesa-git

pkgname=mesa-git
pkgver=20081224
pkgrel=1
pkgdesc="Mesa OpenGL Library from GIT repository"
url="http://www.mesa3d.org"
license=""
arch=(x86_64 i686)
depends=('libgl>=7.2.99' 'glproto' 'gcc' 'libxt')
makedepends=('imake' 'git')
conflicts=('mesa-apps' 'mesa')
replaces=('mesa-apps' 'mesa')
provides=('mesa=7.2.99')
backup=()
install=
source=()
md5sums=()

_gitroot="git://anongit.freedesktop.org/git/mesa/mesa"
_gitname="mesa"

build() {

 msg "Connecting to git.freedesktop.org GIT server...."

  if [ -d $startdir/src/$_gitname ] ; then
  cd $_gitname && git pull origin
  msg "The local files are updated."
  else
  git clone $_gitroot
  fi

  msg "GIT checkout done or server timeout"
  msg "Starting make..."

cd $startdir/src

  cp -r $startdir/src/$_gitname $startdir/src/$_gitname-build
  cd $startdir/src/$_gitname-build

# Any patches you may want to add go here

 cd $startdir/src/$_gitname-build

CONFIG="linux-dri-x86"
  if [ "${CARCH}" = "x86_64" ]; then
    CONFIG="linux-dri-x86-64"
    sed -i -e "s/lib64/lib/g" ${startdir}/src/$_gitname-build/configs/${CONFIG}
  fi

  echo "EXTRA_LIB_PATH =" >> configs/${CONFIG}
  echo "OPT_FLAGS = ${CFLAGS}" >> configs/${CONFIG}
  echo "SRC_DIRS = glx/x11 glu glw" >> configs/${CONFIG}
  rm -f include/GL/glut*h
  echo "USING_EGL = 0" >> configs/${CONFIG}
  echo "PROGRAM_DIRS =" >> configs/${CONFIG}
  echo "MKDEP = makedepend" >> configs/${CONFIG}
  echo "DRI_DIRS =" >> configs/${CONFIG}
  echo "DRI_DRIVER_SEARCH_DIR = /usr/lib/xorg/modules/dri" >> configs/${CONFIG}
  echo "ARCH_FLAGS += -DGLX_USE_TLS" >> configs/${CONFIG}
  echo "X11_INCLUDES = `pkg-config --cflags-only-I x11`" >> configs/${CONFIG}

  make ${CONFIG} || return 1
  mkdir -p ${startdir}/pkg/usr
  make INSTALL_DIR=${startdir}/pkg/usr install
  install -m644 include/GL/*.h ${startdir}/pkg/usr/include/GL/
  cp -r include/GL/*  ${startdir}/pkg/usr/include/GL/


  rm -f ${startdir}/pkg/usr/lib/libGL.so*
  cd progs/xdemos
  make glxinfo glxgears
  mkdir -p ${startdir}/pkg/usr/bin
  install -m755 glxinfo glxgears ${startdir}/pkg/usr/bin/

  cd ${startdir}/src/gl-manpages-1.0.1
  ./configure --prefix=/usr
  make || return 1
  make DESTDIR=${startdir}/pkg install

  rm -r $startdir/pkg/usr/lib/xorg/
  rm -r $startdir/src/$_gitname-build

}

intel-dri-git

pkgname=intel-dri-git
pkgver=20081224
pkgrel=1
pkgdesc="Mesa DRI drivers for Intel chipsets"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
depends=('libdrm>=2.4.3' 'mesa>=7.2.99' 'expat>=2.0')
makedepends=('libdrm>=2.4.3' 'imake' 'mesa>=7.2.99' 'glproto>=1.4.9')
options=('!libtool')
conflicts=('intel-dri')
provides=('intel-dri=7.2.99')
source=()
md5sums=()
license=('custom')

_gitroot="git://anongit.freedesktop.org/git/mesa/mesa"
_gitname="mesa"

build() {
  cd ${startdir}/src/
  msg "Connecting to git.freedesktop.org GIT server...."

  if [ -d $startdir/src/$_gitname ] ; then
  cd $_gitname && git pull origin
  msg "The local files are updated."
  else
  git clone $_gitroot
  fi

  msg "GIT checkout done or server timeout"
  msg "Starting make..."

  cd $startdir/src/
  cp -r ${startdir}/src/$_gitname ${startdir}/src/$_gitname-build || return 1
  cd $startdir/src/$_gitname-build/

  CONFIG="linux-dri-x86"
  if [ "${CARCH}" = "x86_64" ]; then
    CONFIG="linux-dri-x86-64"
    sed -i -e "s/lib64/lib/g" ${startdir}/src/$_gitname-build/configs/${CONFIG}
  fi

  echo "EXTRA_LIB_PATH =" >> configs/${CONFIG}
  echo "OPT_FLAGS = ${CFLAGS} -fno-strict-aliasing" >> configs/${CONFIG}
  echo "SRC_DIRS = glx/x11 mesa" >> configs/${CONFIG}
  rm -f include/GL/glut*h
  echo "USING_EGL = 0" >> configs/${CONFIG}
  echo "PROGRAM_DIRS =" >> configs/${CONFIG}
  echo "MKDEP = makedepend" >> configs/${CONFIG}
  echo "DRI_DIRS = i810 i915 i915tex i965" >> configs/${CONFIG}
  echo "DRI_DRIVER_SEARCH_DIR = /usr/lib/xorg/modules/dri" >> configs/${CONFIG}
  echo "DRI_DRIVER_INSTALL_DIR = /usr/lib/xorg/modules/dri" >> configs/${CONFIG}
  echo "ARCH_FLAGS += -DGLX_USE_TLS" >> configs/${CONFIG}
  echo "X11_INCLUDES = `pkg-config --cflags-only-I x11`" >> configs/${CONFIG}

  make realclean
  make ${CONFIG} || return 1
  mkdir -p ${startdir}/pkg/usr
  cd drivers/dri
  make DESTDIR=${startdir}/pkg install || return 1
  rm -rf ${startdir}/pkg/usr/local
}

inputproto

pkgname=inputproto
pkgver=1.5.0
pkgrel=1
pkgdesc="X11 Input extension wire protocol"
arch=(i686 x86_64)
license=('custom')
url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd ${srcdir}/${pkgname}-${pkgver}
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR=${startdir}/pkg install || return 1

  install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
  install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}

pixman

pkgname=pixman
pkgver=0.13.2
pkgrel=1
pkgdesc="Pixman library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org"
license=()
depends=('glibc')
options=('!libtool')
source=(http://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  ./configure --prefix=/usr --disable-static || return 1
  make || return 1
  make DESTDIR="${pkgdir}" install || return 1
}

randrproto

pkgname=randrproto
pkgver=1.2.99.3
pkgrel=1
pkgdesc="X11 RandR extension wire protocol"
arch=('i686' 'x86_64')
license=('custom')
url="http://xorg.freedesktop.org/"
source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd ${srcdir}/${pkgname}-${pkgver}
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR=${pkgdir} install || return 1
  install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}
  install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}

xorg-server

pkgname=xorg-server
pkgver=1.5.99.901
pkgrel=1
pkgdesc="X.Org X servers"
arch=('i686' 'x86_64')
license=('custom')
url="http://xorg.freedesktop.org"
depends=('libx11>=1.1.99.2' 'libxkbui>=1.0.2' 'libgl' 'libxfont>=1.3.3' 'openssl>=0.9.8h' 'libxxf86misc>=1.0.1' 'libpciaccess>=0.10.5' 'libxv>=1.0.4' 'libxaw>=1.0.4' 'pixman>=0.11.10' 'hal>=0.5.11' 'xcursor-themes' 'xkeyboard-config>=1.3' 'xorg-server-utils' 'xorg-utils' 'xorg-fonts-misc' 'xbitmaps' 'libdrm>=2.3.1' 'diffutils' 'xf86-input-evdev')
makedepends=('glproto>=1.4.9' 'xf86driproto>=2.0.4' 'mesa>=7.2.99' 'randrproto>=1.2.99.3' 'renderproto>=0.9.3' 'scrnsaverproto>=1.1.0' 'fontsproto>=2.0.2' 'videoproto>=2.2.2' 'compositeproto>=0.4' 'trapproto>=3.4.3' 'resourceproto>=1.0.2' 'xineramaproto>=1.1.2' 'evieext>=1.0.2' 'libxkbfile>=1.0.5' 'libxmu>=1.0.4' 'libxpm>=3.5.7' 'libxxf86dga>=1.0.2' 'inputproto>=1.4.4' 'xcmiscproto>=1.1.2' 'bigreqsproto' 'libdrm=2.4.3' 'xtrans' 'pixman>=0.13.2' 'inputproto>=1.5.0')
options=('!libtool')
provides=('x-server')
groups=('xorg')
install=xorg-server.install
source=(${url}/releases/individual/xserver/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"

  # Fix dbus config path
  sed -i -e 's/\$(sysconfdir)/\/etc/' config/Makefile.*  || return 1

  ./configure --prefix=/usr \
              --enable-ipv6 \
              --enable-dri \
              --disable-dmx \
              --enable-xvfb \
              --enable-xnest \
              --enable-composite \
              --enable-xcsecurity \
              --enable-xorg \
              --enable-xtrap \
              --enable-xevie \
          --enable-xephyr \
              --enable-glx-tls \
              --enable-xorgcfg \
          --enable-kdrive \
              --enable-install-setuid \
              --enable-config-hal \
          --enable-config-dbus \
          --disable-xfbdev \
          --disable-xfake \
          --disable-xsdl \
          --disable-kdrive-vesa \
          --disable-dri2 \
              --disable-xprint \
              --disable-static \
              --sysconfdir=/etc/X11 \
              --localstatedir=/var \
              --with-default-font-path=/usr/share/fonts/misc,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/TTF,/usr/share/fonts/Type1 \
              --with-xkb-path=/usr/share/X11/xkb \
              --with-xkb-output=/var/lib/xkb \
              --with-dri-driver-path=/usr/lib/xorg/modules/dri || return 1

  make || return 1
  make DESTDIR="${pkgdir}" install || return 1

  rm -rf "${pkgdir}/var/log" || return 1

  install -m755 -d "${pkgdir}/etc/X11" || return 1
  install -m755 -d "${pkgdir}/var/lib/xkb" || return 1

  # No longer needed, but as nvidia-utils mangles these files,
  # keep them like this so they can be restored
  mv "${pkgdir}/usr/lib/xorg/modules/libwfb.so" \
     "${pkgdir}/usr/lib/xorg/modules/libwfb.so.1.4" || return 1

  # Needed for non-mesa drivers, libgl will restore it
  mv "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.so" \
     "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.xorg" || return 1

  mv "${pkgdir}/usr/lib/xorg/modules/extensions/libdri.so" \
     "${pkgdir}/usr/lib/xorg/modules/extensions/libdri.xorg" || return 1

  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}

xorg-server.install

post_install() {
  rm -f usr/lib/xorg/modules/libwfb.so
  ln -sf libwfb.so.1.4 usr/lib/xorg/modules/libwfb.so

  cmp usr/lib/xorg/modules/extensions/libdri.so usr/lib/xorg/modules/extensions/libglx.xorg >/dev/null 2>&1 && rm -f usr/lib/xorg/modules/extensions/libdri.so

  # If the symlink is dead or non-existent, remove it and make a new one
  if [ ! -e usr/lib/xorg/modules/extensions/libdri.so ]; then
    rm -f usr/lib/xorg/modules/extensions/libdri.so
    ln -sf libdri.xorg usr/lib/xorg/modules/extensions/libdri.so
  fi
}

post_upgrade() {
  if [ "`vercmp $2 1.4.99.906`" -lt 0 ]; then
    cat << _EOF

  Input device handling has changed in xorg-server 1.5.
  Please read http://wiki.archlinux.org/index.php/Xorg_input_hotplugging.

_EOF
  fi
  post_install
}

post_remove() {
  rm -f /usr/lib/xorg/modules/libwfb.so

  # If the symlink is dead, remove it
  if [ ! -e usr/lib/xorg/modules/extensions/libdri.so ]; then
    rm -f usr/lib/xorg/modules/extensions/libdri.so
  fi
}

xf86-video-intel

pkgname=xf86-video-intel
pkgver=2.5.99.2
pkgrel=1
pkgdesc="X.org Intel i810/i830/i915/945G/G965+ video drivers"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
depends=('intel-dri>=7.2.99' 'libpciaccess>=0.10.5' 'libdrm>=2.4.3')
makedepends=('pkgconfig' 'xorg-server>=1.5.99.3' 'xf86driproto>=2.0.4' 'glproto>=1.4.9' 'mesa>=7.2.99' 'libdrm=2.4.3')
conflicts=('xorg-server<1.5.99.3' 'xf86-video-i810')
replaces=('xf86-video-i810')
options=('!libtool' 'force')
groups=('xorg-video-drivers')
source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2)
md5sums=()

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  ./configure --prefix=/usr \
              --enable-dri || return 1
  make || return 1
  make DESTDIR="${pkgdir}" install || return 1
}

xf86-input-evdev

pkgname=xf86-input-evdev
pkgver=2.1.0
pkgrel=1
pkgdesc="X.org evdev input driver"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
license=('custom')
depends=('glibc')
makedepends=('pkgconfig' 'xorg-server>=1.5.99.3' 'inputproto>=1.5.0' 'randrproto>=1.2.99.3')
options=('!libtool')
groups=('xorg-input-drivers')
source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2)
md5sums=('a6070ead29b2d81b5b386a96df2661b8')

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR="${pkgdir}" install || return 1
  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}

Last edited by mutlu_inek (2009-01-15 02:45:22)

Offline

#6 2008-12-26 05:35:43

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

crayxt wrote:

Hi all,
where can I get PKGBUILD for this kernel? I've already downloaded kernel archive

This is a pretty good guide: http://wiki.archlinux.org/index.php/Cus … n_with_ABS

Offline

#7 2008-12-26 07:00:24

blitux
Member
From: Mendoza, Argentina
Registered: 2008-10-09
Posts: 21

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Damnshock wrote:

Can't wait for it to hit the repos... big_smile (I'm just too lazy and busy right now to install it myself)

Me neither tongue

When do you think this "awesomness" will hit the repos (including the new kernel)?
We're all anxious to see the new graphic's memory manager (GEM) working like a charm (and ext4 too...)


-=[ bLiTux ]=-

Offline

#8 2008-12-26 09:17:03

crayxt
Member
Registered: 2008-12-19
Posts: 37

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Who knows, when the new kernel will be available in repo's?

Simply I've a laptop with Intel onboard graphic card wink


Всем выйти из Сумрака!!!

Уважение - это когда чтобы поприветствовать человека вытаскиваешь оба наушника.
my blog

Offline

#9 2008-12-26 13:35:08

dav7
Member
From: Australia
Registered: 2008-02-08
Posts: 674

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Compiz...can be smooth...on Intel chipsets...?!?!

o.o

Release it already!
I WANTS MAI TIME MACHINE sad

Last edited by dav7 (2008-12-26 13:35:51)


Windows was made for looking at success from a distance through a wall of oversimplicity. Linux removes the wall, so you can just walk up to success and make it your own.
--
Reinventing the wheel is fun. You get to redefine pi.

Offline

#10 2008-12-26 13:40:43

andre.ramaciotti
Member
From: Brazil
Registered: 2007-04-06
Posts: 649

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

I'm glad to know it. After my recent disapointment with nvidia, is good to know that intel now has a good performance.


(lambda ())

Offline

#11 2008-12-26 14:05:54

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 498

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.


Excuse my poor English.

Offline

#12 2008-12-26 17:11:06

borix
Member
Registered: 2007-12-01
Posts: 17

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Hi, I would have an question. I upgraded all the packages(from the PKGBUILDs mentioned above) and I have a little problem with freetype(actualy I haven't got libfreetype.so(from directore /usr/lib/xorg/modules/fonts/)) so I would like to ask what package provides that libfreetype.so.

Offline

#13 2008-12-26 18:02:39

woifi
Member
Registered: 2008-11-04
Posts: 8

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

$ pacman -Qo /usr/lib/libfreetype.so
/usr/lib/libfreetype.so is owned by freetype2 2.3.7-1

hth,

woifi

ps: i can't wait for the packages too big_smile

Offline

#14 2008-12-26 23:04:17

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

mutlu_inek wrote:
crayxt wrote:

Hi all,
where can I get PKGBUILD for this kernel? I've already downloaded kernel archive

This is a pretty good guide: http://wiki.archlinux.org/index.php/Cus … n_with_ABS

Hmm... I had another look at the guide and it is kinds screwed up atm. I used my own PKGBUILDs which I based on that guide a long while back and which have changed here and there since. But they do work in the sense that they provide a vanilla kernel which can live next to the Arch kernel. For those who'd like to play with it. Keep in mind, though, this might be buggy and render your computer unbootable.

PKGBUILD

pkgname=kernel2628-LINUS
pkgver=2.6.28
pkgrel=1
pkgdesc="The Linux Kernel 2.6.28 and modules (IDE support)"
url="http://www.kernel.org"
depends=('module-init-tools')
install=kernel26linus.install
arch=(i686 x86_64)
license=('GPL')

##### add any patch sources to this section
source=(config ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
    kernel26linus.install
    kernel26linus.preset)

# Function to grab var from src
getvar() {
  old=$(cat Makefile | grep "^$1")
  echo $(echo ${old/"$1 ="/} | sed -e "s/[ ]*\(.*\)[ ]*/\1/g")
  return 0
}

build() {
  cd $startdir/src/linux-$pkgver

  ##### Uncomment and apply any patches here
  #patch -Np1 -i ../patchname || return 1

  # get rid of the 'i' in i686
  carch=`echo $CARCH | sed 's|i||'`
  cat ../config | sed "s|#CARCH#|$carch|g" >./.config

  ##### Load config - uncomment your preferred config method
  #yes "" | make config
  #make oldconfig || return 1
  make menuconfig
  #make xconfig
  #make gconfig

  #To check for config mismatches, choose this option,
  #but none of the above. This option will ignore previously
  #compiled modules and recompile everything. Run this in a
  #colsole with lots of scrollback or route the output to a file.
  #make 'CONFIG_DEBUG_SECTION_MISMATCH=y'

  ##### NO USER CHANGES BELOW HERE #####

  # save the current pkgname
  old_pkgname=$pkgname

  # set pkgname for build purposes - DO NOT alter!
  pkgname=kernel26

  # save the updated config to build with today's date
  cp ./.config $startdir/config-$(date +%b%d\-%Hh)

  # get EXTRAVERSION from Makefile to create a unique pkgname and /usr/src directory
  _kernextra=$(getvar "EXTRAVERSION")
  # grab the 2.6.x.y version suffix from pkgver
  _y="`echo $pkgver | cut --delim "." --fields 4`"
  # remove .y version suffix from _kernextra
  _kernextra="`echo $_kernextra | sed "s|\.$_y||g"`"

  # Read the full kernel version info from new config to use in pathnames and pkgname
  . ./.config

  # Kernel custom - to create a unique pkgname (see below)
  _kerncust="${_kernextra}${CONFIG_LOCALVERSION}"
  # Kernel release - will be the same as Makefile
  _kernrel="${pkgver}${_kerncust}"
  # Get the pkgver suffix for unique pkgname and /boot file suffices
  _pkgversuf="`echo $pkgver | sed "s|2.6.||g" | sed "s|\.||g"`"
  # Set /boot file suffices from kernel release and pkgver suffix
  _kernboot="${_pkgversuf}${_kerncust}"

  # Set a new pkgname from  kernel release and pkgver suffix
  pkgname="${pkgname}${_pkgversuf}${_kerncust}"

  # build!
  echo
  echo -n "Do you want to make clean (default YES)? (YES/NO): "
  read choice
  echo
  echo -n "Press any key to start make or CTRL+C to quit"
  read anykey

  if [ "${choice}" = "NO" ] ; then
      make bzImage modules || return 1
  else
    make clean bzImage modules || return 1
  fi

  mkdir -p $startdir/pkg/{lib/modules,boot}
  make INSTALL_MOD_PATH=$startdir/pkg modules_install || return 1
  cp System.map $startdir/pkg/boot/System.map26${_kernboot}
  cp arch/i386/boot/bzImage $startdir/pkg/boot/vmlinuz26${_kernboot}
  install -D -m644 Makefile  $startdir/pkg/usr/src/linux-${_kernrel}/Makefile
  install -D -m644 kernel/Makefile $startdir/pkg/usr/src/linux-${_kernrel}/kernel/Makefile
  install -D -m644 .config $startdir/pkg/usr/src/linux-${_kernrel}/.config
  install -D -m644 .config $startdir/pkg/boot/kconfig26${_kernboot}
  install -D -m644 include/config/kernel.release $startdir/pkg/usr/src/linux-${_kernrel}/.kernelrelease

  mkdir -p $startdir/pkg/etc/mkinitcpio.d
# install -D -m644 include/config/kernel.release $startdir/pkg/etc/mkinitcpio.d/kernel26linus.kver
# sed -i "s/${pkgver}${_kerncust}/ALL_kver='${pkgver}${_kerncust}'/" $startdir/pkg/etc/mkinitcpio.d/kernel26linus.kver
  echo ALL_kver=\'${pkgver}${_kerncust}\' > $startdir/pkg/etc/mkinitcpio.d/kernel26linus.kver
  install -D -m644 $startdir/src/kernel26linus.preset $startdir/pkg/etc/mkinitcpio.d/kernel26linus.preset

  mkdir -p $startdir/pkg/usr/src/linux-${_kernrel}/include
  mkdir -p $startdir/pkg/usr/src/linux-${_kernrel}/arch/i386/kernel
  for i in acpi asm-generic asm-x86 config linux math-emu media net pcmcia scsi sound video; do
    cp -a include/$i $startdir/pkg/usr/src/linux-${_kernrel}/include/
  done
  # copy files necessary for later builds, like nvidia and vmware
  cp Module.symvers $startdir/pkg/usr/src/linux-${_kernrel}
  cp -a scripts $startdir/pkg/usr/src/linux-${_kernrel}
  mkdir -p $startdir/pkg/usr/src/linux-${_kernrel}/.tmp_versions
  cp arch/x86/Makefile $startdir/pkg/usr/src/linux-${_kernrel}/arch/i386/
  cp arch/x86/Makefile_32.cpu $startdir/pkg/usr/src/linux-${_kernrel}/arch/i386/
  cp arch/x86/kernel/asm-offsets.s $startdir/pkg/usr/src/linux-${_kernrel}/arch/i386/kernel/
  # copy in Kconfig files
  for i in `find . -name "Kconfig*"`; do
    mkdir -p $startdir/pkg/usr/src/linux-${_kernrel}/`echo $i | sed 's|/Kconfig.*||'`
    cp $i $startdir/pkg/usr/src/linux-${_kernrel}/$i
  done
  cd $startdir/pkg/usr/src/linux-${_kernrel}/include && ln -s asm-x86 asm
  chown -R root.root $startdir/pkg/usr/src/linux-${_kernrel}
  cd $startdir/pkg/lib/modules/${_kernrel} && \
    (rm -f source build; ln -sf /usr/src/linux-${_kernrel} build)

  # Correct the pkgname in our PKGBUILD - this allows correct gensync operation
  # NOTE: pkgname variable must be declared with first 10 lines of PKGBUILD!
  cd $startdir
  sed -i "1,11 s|pkgname=$old_pkgname|pkgname=$pkgname|" ./PKGBUILD
}

kernel26linus.install

KERNEL_VERSION=2.6.28-LINUS

post_install () {
  # updating module dependencies
  echo ">>> Updating module dependencies. Please wait ..."
  depmod $KERNEL_VERSION 
  # generate init ramdisks
  echo ">>> MKINITCPIO SETUP"
  echo ">>> ----------------"
  echo ">>> If you use LVM2, Encrypted root or software RAID,"
  echo ">>> Ensure you enable support in /etc/mkinitcpio.conf ."
  echo ">>> More information about mkinitcpio setup can be found here:"
  echo ">>> http://wiki.archlinux.org/index.php/Mkinitcpio"
  echo ""
  echo ">>> Generating initial ramdisk, using mkinitcpio.  Please wait..."
  /sbin/mkinitcpio -p kernel26linus
}

post_upgrade() {
  pacman -Q grub &>/dev/null
  hasgrub=$?
  pacman -Q lilo &>/dev/null
  haslilo=$?
  # reminder notices
  if [ $haslilo -eq 0 ]; then
    echo ">>>"
    if [ $hasgrub -eq 0 ]; then
      echo ">>> If you use the LILO bootloader, you should run 'lilo' before rebooting."
    else
      echo ">>> You appear to be using the LILO bootloader. You should run"
      echo ">>> 'lilo' before rebooting."
    fi
    echo ">>>"
  fi

  if grep "/boot" /etc/fstab 2>&1 >/dev/null; then
    if ! grep "/boot" /etc/mtab 2>&1 >/dev/null; then
      echo "WARNING: /boot appears to be a seperate partition but is not mounted"
      echo "         This is most likely not what you want.  Please mount your /boot"
      echo "         partition and reinstall the kernel unless you are sure this is OK"
    fi
  fi

  if [ "`vercmp $2 2.6.13`" -lt 0 ]; then
    # important upgrade notice
    echo ">>>"
    echo ">>> IMPORTANT KERNEL UPGRADE NOTICE"
    echo ">>> -------------------------------"
    echo ">>> As of kernel 2.6.13, DevFS is NO LONGER AVAILABLE!"
    echo ">>> If you still use DevFS, please make the transition to uDev before"
    echo ">>> rebooting.  If you really need to stay with DevFS for some reason,"
    echo ">>> then you can manually downgrade to an older version:"
    echo ">>>"
    echo ">>> # pacman -U http://archlinux.org/~judd/kernel/kernel26-scsi-2.6.12.2-1.pkg.tar.gz"
    echo ">>>"
    echo ">>> If you choose to downgrade, don't forget to add kernel26-scsi to your"
    echo ">>> IgnorePkg list in /etc/pacman.conf"
    echo ">>>"
    echo ">>> (NOTE: The following portion applies to uDev users as well!)"
    echo ">>>"
    echo ">>> If you use any DevFS paths in your GRUB menu.lst, then you will not"
    echo ">>> be able to boot!  Change your root= parameter to use the classic"
    echo ">>> naming scheme."
    echo ">>>"
    echo ">>> EXAMPLES:"
    echo ">>> - change root=/dev/discs/disc0/part3 to root=/dev/sda3"
    echo ">>> - change root=/dev/md/0 to root=/dev/md0"
    echo ">>>"
  fi
  # generate new init ramdisk
  if [ "`vercmp $2 2.6.18`" -lt 0 ]; then
    echo ">>> --------------------------------------------------------------"
    echo ">>> |                          WARNING:                          |"
    echo ">>> |mkinitrd is not supported anymore in kernel >=2.6.18 series!|"
    echo ">>> |              Please change to Mkinitcpio setup.            |"
    echo ">>> --------------------------------------------------------------"
    echo ">>>"
  fi
  # updating module dependencies
  echo ">>> Updating module dependencies. Please wait ..."
  depmod $KERNEL_VERSION
  echo ">>> MKINITCPIO SETUP"
  echo ">>> ----------------"
  if [ "`vercmp $2 2.6.18`" -lt 0 ]; then
    echo ">>> Please change your bootloader config files:"
    echo ">>> Grub: /boot/grub/menu.lst | Lilo: /etc/lilo.conf"
    echo "-----------------------------------------------------"
    echo "| - initrd26.img to kernel26linus.img               |"
    echo "| - initrd26-full.img to kernel26linus-fallback.img |"
    echo "-----------------------------------------------------"
  fi
  if [ "`vercmp $2 2.6.19`" -lt 0 ]; then
    echo ""
    echo ">>> New PATA/IDE subsystem - EXPERIMENTAL"
    echo ">>> ----------"
    echo ">>> To use the new pata drivers, change the 'ide' hook "
    echo ">>> to 'pata' in /etc/mkinicpio.conf HOOKS="
    echo ">>> The new system changes: /dev/hd? to /dev/sd?"
    echo ">>> Don't forget to modify GRUB, LILO and fstab to the"
    echo ">>> new naming system. "
    echo ">>> eg: hda3 --> sda3, hdc8 --> sdc8"
    echo ""
    echo ">>> piix/ata_piix (Intel chipsets) - IMPORTANT"
    echo "----------"
    echo ">>> If you have enabled ide/pata/sata HOOKs in /etc/mkinitcpio.conf" 
    echo ">>> the 'ata_piix' module will be used."
    echo ">>> This may cause your devices to shift names, eg:"
    echo ">>> - IDE: devices from hd? to sd?"
    echo ">>> - SATA: sda might shift to sdc if you have 2 other disks on a PIIX IDE port."
    echo ">>> To check if this will affect you, check 'mkinitcpio -M' for piix/ata_piix"
    echo ""
  fi

  echo ">>> If you use LVM2, Encrypted root or software RAID,"
  echo ">>> Ensure you enable support in /etc/mkinitcpio.conf ."
  echo ">>> More information about mkinitcpio setup can be found here:"
  echo ">>> http://wiki.archlinux.org/index.php/Mkinitcpio"
  echo ""
  echo ">>> Generating initial ramdisk, using mkinitcpio.  Please wait..."
if [ "`vercmp $2 2.6.19`" -lt 0 ]; then
  /sbin/mkinitcpio -p kernel26linus -m "ATTENTION:\nIf you get a kernel panic below
and are using an Intel chipset, append 'earlymodules=piix' to the
kernel commandline"
else
  /sbin/mkinitcpio -p kernel26linus
fi
if [ "`vercmp $2 2.6.21`" -lt 0 ]; then
  echo ""
  echo "Important ACPI Information:"
  echo ">>> Since 2.6.20.7 all possible ACPI parts are modularized."
  echo ">>> The modules are located at:"
  echo ">>> /lib/modules/$(uname -r)/kernel/drivers/acpi"
  echo ">>> For more information about ACPI modules check this wiki page:"
  echo ">>> 'http://wiki.archlinux.org/index.php/ACPI_modules'"
fi
}

op=$1
shift

$op $*

kernel26linus.preset

source /etc/mkinitcpio.d/kernel26linus.kver

ALL_config="/etc/mkinitcpio.conf"

PRESETS=('default' 'fallback')

default_image="/boot/kernel26linus.img"

fallback_image="/boot/kernel26linus-fallback.img" 
fallback_options="-S autodetect"

Last edited by mutlu_inek (2008-12-26 23:05:42)

Offline

#15 2008-12-27 01:04:18

Aprz
Member
From: Newark
Registered: 2008-05-28
Posts: 277

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Woo! Been waiting for 2.6.28. Didn't realize it came out 2 days ago, ugh! I just checked http://www.kernel.org/ a few minutes ago and I was like "Woo!" so downloading and will get back to you guys in a couple of hours. Unfortunately, I have to leave for work in a few minutes so can't post anything immediate. I'll post up some old comparisons of glxgears when intel drivers were using TTM and we'll see if GEM made any massive improvement. wink

Offline

#16 2008-12-27 01:26:38

xaiviax
Member
From: Michigan
Registered: 2008-11-04
Posts: 282

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

2.6.28 is now in testing

Offline

#17 2008-12-27 02:06:09

archlinuxsagi
Member
Registered: 2008-09-12
Posts: 259

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

xaiviax wrote:

2.6.28 is now in testing

yeaaaaah..

Offline

#18 2008-12-27 03:38:25

3lusive
Member
Registered: 2008-04-07
Posts: 26

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Dont bother with testing glxgears, it won't give you any decent information.  Its not a proper benchmark. 

There will be more improvements to intel driver, i'd say look for another speed increase around summer
2009.  At least this new improvement gets us out of the "i965 sucks on linux" stage.

Last edited by 3lusive (2008-12-27 03:44:01)

Offline

#19 2008-12-27 12:02:33

cywhale
Member
Registered: 2008-03-10
Posts: 31

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Thank you for this really informative thread, one question about Compiz Fusion: Did you notice any improvement in firefox scrolling speed using new kernel/driver?
CF effects always worked kind of smooth with my integrated Intel 855GM (ACER Travelmate C110) but sluggish, unusable slow firefox scrolling made me use pure metacity until now...

Offline

#20 2008-12-27 12:28:48

b9anders
Member
Registered: 2007-11-07
Posts: 681

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

I've finally upgraded to the new xorg now that the new kernel has hit testing. After generating a new minimal xorg.conf, I can finally get proper resolution and hotplugging. Compiz is running better than it did with the .27 kernel, but it's not quite as smooth as old kernel+old xorg. CPU usage is now some 8% higher than usual, all coming from xorg, which is what I attribute the small lag to.

I am wondering if there is anyone who know some tweaks to optomise performance here (I'm not too keen on rebuilding packages, as it is working ok for now). My xorg.conf looks like this:

Section "ServerLayout"
    Identifier    "X.org Configured"
    Screen        0 "Default Screen" 0 0
EndSection

Section "Files"
    ModulePath    "/usr/lib/xorg/modules"
#        FontPath    "/usr/share/fonts/Type1"
#        FontPath    "/usr/share/fonts/TTF"
#        FontPath    "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load        "xtrap"
EndSection

Section "Monitor"
    Identifier    "LCD 1280x800"
EndSection

Section "Device"
        Identifier    "GMA950"
        Driver        "intel"
        Option        "DRI"            "True"
        Option        "NoDDC"            "True"
    Option        "XaaNoPixmapCache"
        Option        "XAANoOffscreenPixmaps"    "True"
        Option        "EnablePageFlip"        "True"
        Option        "RenderAccel"           "True"
        Option        "AccelMethod"           "XAA"
#        Option        "AccelMethod"            "exa"
#        Option         "MigrationHeuristic"    "greedy"
#    Option        "ExaNoComposite"        "false"
    Option        "Monitor-LVDS"            "LCD 1280x800"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "GMA950"
    Monitor        "LCD 1280x800"
    DefaultDepth    24
EndSection

Section "DRI"
    Mode        0666
EndSection

Section  "Extensions" 
        Option        "Composite"        "on" 
        Option        "MIT-SHM"        "Yes"
EndSection

Offline

#21 2008-12-27 15:49:46

Slack
Member
From: Chile
Registered: 2008-10-27
Posts: 52

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

I tried kernel 2.6.28 from testing with intel driver 2.4.1 (extra) but I got a poor performance

Later I will try with the intel 2.5.x series (maybe)

Last edited by Slack (2008-12-27 15:50:41)


Excuse my poor english

Offline

#22 2008-12-27 15:56:41

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Slack wrote:

I tried kernel 2.6.28 from testing with intel driver 2.4.1 (extra) but I got a poor performance

Poor in how far and in comparison to what? Which chipset do you use? And what are your configs? b9anders's settings are very sensible, maybe you should try them.

Offline

#23 2008-12-27 16:56:43

b9anders
Member
Registered: 2007-11-07
Posts: 681

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

FWIW, cpu usage for whatever reason is now only about 1-2% higher than before, but nonetheless not quite the same smooth experience. I'll test a few more configurations and see how it works out.

Slack, love to hear how different it is for you with the 2.5 series in comparison if you get around to it. Been curious about UXA acceleration.

Last edited by b9anders (2008-12-27 17:34:00)

Offline

#24 2008-12-27 19:16:27

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

I can't build libgl-git. The last lines of the error:

dri2.c:289: error: invalid operands to binary + (have 'char *' and 'char *')
dri2.c:289: error: expected expression before ')' token
dri2.c:289: error: invalid operands to binary * (have 'char *' and 'char *')
dri2.c:289: error: called object '<erroneous-expression>' is not a function
dri2.c:289: warning: statement with no effect
dri2.c:289: error: request for member 'reqType' in something not a structure or union
dri2.c:289: error: 'X_DRI2CopyRegion' undeclared (first use in this function)
dri2.c:289: warning: statement with no effect
dri2.c:289: error: request for member 'length' in something not a structure or union
dri2.c:289: error: invalid operands to binary >> (have 'char *' and 'int')
dri2.c:289: warning: statement with no effect
dri2.c:289: error: invalid operands to binary + (have 'char *' and 'char *')
dri2.c:289: warning: statement with no effect
dri2.c:290: error: request for member 'reqType' in something not a structure or union
dri2.c:290: warning: statement with no effect
dri2.c:291: error: request for member 'dri2ReqType' in something not a structure or union
dri2.c:291: warning: statement with no effect
dri2.c:292: error: request for member 'drawable' in something not a structure or union
dri2.c:292: warning: statement with no effect
dri2.c:293: error: request for member 'region' in something not a structure or union
dri2.c:293: warning: statement with no effect
dri2.c:294: error: request for member 'dest' in something not a structure or union
dri2.c:294: warning: statement with no effect
dri2.c:295: error: request for member 'src' in something not a structure or union
dri2.c:295: warning: statement with no effect
dri2.c:297: error: 'rep' undeclared (first use in this function)
make[3]: *** [dri2.o] Error 1
make[3]: Leaving directory `/home/dheart/intel/libgl-git/src/mesa-build/src/glx/x11'
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/home/dheart/intel/libgl-git/src/mesa-build/src'
make[1]: *** [default] Error 1
make[1]: Leaving directory `/home/dheart/intel/libgl-git/src/mesa-build'
make: *** [linux-dri-x86-64] Error 2

My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#25 2008-12-27 20:11:44

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Intel i965 on 2.6.28 kernel --- results with xf86-video-intel 2.5.99.

Dheart wrote:

I can't build libgl-git.

Yeah, a commit yesterday broke compilation for me in the same way. I haven't investigated.

Offline

Board footer

Powered by FluxBB