You are not logged in.

#1 2008-12-28 00:54:16

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,501
Website

Cups -- keeps adding AuthInfoRequired automatically

Ok, this is driving me crazy. I've got two computers w/ Arch (one x86 one x86_64). The x86 computer continuously adds the line "AuthInfoRequired username,password" to the printers.conf file (directly after the line <DefaultPrinter CanonMX310>). I delete it, because I don't need everyone being asked for username and password all the time, and it causes some programs (like Firefox and Tuxpaint) to not print at all), but each time when cups is restarted, the line reappears in printers.conf. This doesn't happen with the x86_64 machine, and the two printers.conf files are otherwise identical. The two cupsd.conf files are also identical. Is there something else that is adding that line back in all the time??

Thanks!

Scott

/etc/cups/printers.conf

# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2008-12-27 16:08
<DefaultPrinter canon>
AuthInfoRequired username,password
Info Canon 310
Location Office
DeviceURI smb://HOME/192.168.0.100/canon
State Idle
StateTime 1230422925
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>
<Printer pdf>
Info Cups PDF Printer
Location Family Room
DeviceURI cups-pdf:/
State Idle
StateTime 1228869091
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

/etc/cups/cupsd.conf

#
# "$Id: cupsd.conf,v 1.1 2006/07/06 13:11:10 tpowa Exp $"
#
#   Sample configuration file for the Common UNIX Printing System (CUPS)
#   scheduler.  See "man cupsd.conf" for a complete description of this
#   file.
#

# Disable ssl by default, you have to generate own certs to use this feature eg. by this command:
# openssl req -new -x509 -keyout /etc/cups/ssl/server.key -out /etc/cups/ssl/server.crt -days 365 -nodes
# for other certs please refer to openssl manpage.
# Setting Encryption to not required by default
DefaultEncryption IfRequested


# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel info

# Administrator user group...
SystemGroup sys root lpadmin

# Only listen for connections from the local machine.
Listen localhost:631
# Socket disabled by default it makes KDE fail on CUPS
# Listen /var/run/cups/cups.sock
# To allow remote connections add for example
# Listen <yourserverip>:631

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
# By default only localhost connections are possible
<Location />
  Order allow,deny
  Allow localhost
</Location>

# Restrict access to the admin pages...
<Location /admin>
  # Encryption disabled by default
  #Encryption Required
  Order allow,deny
  Allow localhost
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Basic
  Require user @SYSTEM
  Order allow,deny
  Allow localhost
</Location>

# Set the default printer/job policies...
<Policy default>
  # Job-related operations must be done by the owner or an adminstrator...
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an adminstrator to authenticate...
  <Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
    AuthType Basic
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
# End of "$Id: cupsd.conf,v 1.1 2006/07/06 13:11:10 tpowa Exp $".
#

Offline

#2 2008-12-30 03:28:14

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,501
Website

Re: Cups -- keeps adding AuthInfoRequired automatically

Anyone have any ideas about this? Sorry for the bump . . . . it's making me batty!!

Thanks,

Scott

Offline

#3 2008-12-30 10:52:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,372

Re: Cups -- keeps adding AuthInfoRequired automatically

You access the printer through smb://HOME/192.168.0.100/canon .
Is 192.168.0.100 the x86_64 system ?

Also check ArchWiki Cups - Printer Sharing


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2008-12-30 18:20:11

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,501
Website

Re: Cups -- keeps adding AuthInfoRequired automatically

No, 192.168.0.100 is the Vista machine that the printer is attached to (sorry, I forgot to include that tidbit in the first post). Normally the printer sharing works great from both machines. The x86_64 machine never has the AuthInfoRequired line in printers.conf. When it magically appears in the printers.conf file on the x86 machine (after I delete that line), printing still works IF the application prompts for the username and paassword . . . some applications (firefox, tuxpaint) won't prompt and printing then fails silently.

There is no info in the wiki about the problem I'm experiencing. Go figure smile

Thanks,
Scott

Offline

#5 2008-12-30 22:08:58

bavardage
Member
Registered: 2008-02-17
Posts: 160

Re: Cups -- keeps adding AuthInfoRequired automatically

I had the problem that the line appeared  - I deleted it and it hasn't yet come back.
How many times have you deleted it and have had it return. What causes it to return? (CUPS restart for example)

Try deleting it, doing a /etc/rc.d/cups restart, and check if it's back.

Offline

#6 2008-12-31 05:33:47

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,501
Website

Re: Cups -- keeps adding AuthInfoRequired automatically

Deleted that line numerous times . . . most of the time it comes back immediately with a cups restart. Sometimes it seems to be ok for a bit, but always back by the next reboot.

Scott

Offline

#7 2009-03-24 06:36:14

patrickthebold
Member
Registered: 2008-12-15
Posts: 50

Re: Cups -- keeps adding AuthInfoRequired automatically

Did anyone figure this out?  It didn't use to happen to me and now it does, I can't think of anything I changed that would have affected it.

Offline

#8 2009-03-24 14:34:31

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,501
Website

Re: Cups -- keeps adding AuthInfoRequired automatically

I didn't figure it out, but I saved a copy of the printer.conf file without the AuthInfoRequired, and set up a small script run by cron every five minutes that checks if that line exists and copies my saved file to /etc/cups if it does. What a hack smile At least it works most of the time now!

Scott

Offline

#9 2009-03-24 14:43:19

perbh
Member
From: Republic of Texas
Registered: 2005-03-04
Posts: 765

Re: Cups -- keeps adding AuthInfoRequired automatically

*chuckles* Speaking like a true *nix warrior!

Offline

#10 2009-04-20 18:40:58

dufresnep
Member
Registered: 2008-02-03
Posts: 9

Re: Cups -- keeps adding AuthInfoRequired automatically

You may want to have a check at:
https://bugs.launchpad.net/bugs/283811

I have mix results about the workaround that consist to make the line become:
AuthInfoRequired none

Maybe it should just be:
AuthRequired none

Offline

#11 2009-07-01 19:22:29

patrickthebold
Member
Registered: 2008-12-15
Posts: 50

Re: Cups -- keeps adding AuthInfoRequired automatically

Mine works again.  I think I needed to include the username and password in the file
smb://username:password@blah.blah.blah

and comment out the troubling line.

Maybe this was fixed or maybe I just needed the right combination.

Offline

Board footer

Powered by FluxBB