You are not logged in.

#1 2009-01-23 00:36:37

Selection
Member
From: Dayton, OH
Registered: 2008-12-10
Posts: 34

Mplayer font.desc missing after update

So I just updated Mplayer and suddenly I'm getting an error at the start.

Cannot load bitmap font: /usr/share/mplayer/font/font.desc

When I went looking for the file I noticed that not only did the file not exist, but the folder didnt even exist.

Does anybody have an idea of how to get a replacement for this?

I tried reinstalling mplayer with no success.

Thanks in advance


Arch64 + Awesome on Compal FL92 Laptop ~ Intel Core 2 Duo 2.2ghz 4gig ram
All HAIL the tiling window manager.

Offline

#2 2009-01-23 03:23:13

KyleSLinux
Member
Registered: 2008-05-09
Posts: 2

Re: Mplayer font.desc missing after update

I'm having the same problem myself.  Anyone know of a fix? smile

Offline

#3 2009-01-23 03:36:44

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,430
Website

Re: Mplayer font.desc missing after update

File a bug report.

Offline

#4 2009-01-23 06:15:34

PheniX
Member
From: Martinique
Registered: 2009-01-23
Posts: 8

Re: Mplayer font.desc missing after update

Hello.
Recompiling mplayer with --enable-freetype  and
choosing a ttf font in mplayer's options solved the problem for me.

Offline

#5 2009-01-23 06:31:50

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Mplayer font.desc missing after update

PheniX wrote:

Hello.
Recompiling mplayer with --enable-freetype  and
choosing a ttf font in mplayer's options solved the problem for me.

freetype should be auto-detected by configure. At least on the subversion version it is:

 mplayer > ./configure --help | grep freetype
  --disable-freetype     disable FreeType 2 font rendering [autodetect]
  --with-freetype-config=PATH path to freetype-config

Offline

#6 2009-01-23 06:41:18

PheniX
Member
From: Martinique
Registered: 2009-01-23
Posts: 8

Re: Mplayer font.desc missing after update

Indeed, but I do not know why the available build in extra do not give me the opportunity to choose one ttf. sad
When i recompiled mplayer, i have this option.

Offline

#7 2009-01-23 06:43:51

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,430
Website

Re: Mplayer font.desc missing after update

PheniX wrote:

Indeed, but I do not know why the available build in extra do not give me the opportunity to choose one ttf. sad
When i recompiled mplayer, i have this option.

It was probably built on a system without whatever the auto-detect needs to enable this.  File a bug report.

Offline

#8 2009-01-23 06:45:57

PheniX
Member
From: Martinique
Registered: 2009-01-23
Posts: 8

Re: Mplayer font.desc missing after update

Ok. But i'm a neebies in bug report.
What severity which I has to put?
Sorry, I am going to look at the wiki. roll

Last edited by PheniX (2009-01-23 06:50:53)

Offline

#9 2009-01-23 06:49:12

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,430
Website

Re: Mplayer font.desc missing after update

Hmmm...  medium will do (I think that is the default).

Offline

#10 2009-01-23 07:29:20

KyleSLinux
Member
Registered: 2008-05-09
Posts: 2

Re: Mplayer font.desc missing after update

The --enable-freetype fixed my issue.  Oh how I love the ABS system big_smile

Offline

#11 2009-01-23 07:32:42

PheniX
Member
From: Martinique
Registered: 2009-01-23
Posts: 8

Re: Mplayer font.desc missing after update

Offline

#12 2009-01-28 15:42:44

strummer
Member
Registered: 2007-01-11
Posts: 87

Re: Mplayer font.desc missing after update

This is weird.. I don't see subtitles anymore if I watch a DVD.. When I play a movie with .srt or .sub files they are OK. And I have updated the player.


P4 530J, Arch Linux

Offline

#13 2009-03-08 15:38:11

strummer
Member
Registered: 2007-01-11
Posts: 87

Re: Mplayer font.desc missing after update

strummer wrote:

This is weird.. I don't see subtitles anymore if I watch a DVD.. When I play a movie with .srt or .sub files they are OK. And I have updated the player.

Have compiled mplayer and tried some other stuff (different fonts etc). Still no DVD subtitles neutral


P4 530J, Arch Linux

Offline

#14 2009-04-19 03:04:33

once
Member
From: Taiwan
Registered: 2006-09-12
Posts: 211

Re: Mplayer font.desc missing after update

got another problem here

Syntax error in font desc: ttcfCannot load bitmap font : /usr/share/fonts/TTF/uming.ttc

mplayer with .avi & .srt, any idea?

Offline

Board footer

Powered by FluxBB