You are not logged in.

#1 2009-01-30 01:05:39

rassah
Member
Registered: 2009-01-24
Posts: 8

Wake from standby

Hello

I have a small problem with suspend. When my laptop wakes from stanby, my screen is just completely black? It has just started happening recently, since i have never before experienced the problem, or any sort of standby problems in Arch.

I have tried to narrow down the problem, to be something with my kernel or kernel hooks, since when i boot my kernel fallback img, suspend and hibernate works perfectly.

Anyone who has an idea what it could be causing it?

im using kernel: 2.6.28-ARCH

Offline

#2 2009-01-30 14:42:50

rassah
Member
Registered: 2009-01-24
Posts: 8

Re: Wake from standby

So to be more clear, i think the problem lies in the differences, in something being loaded with the normal kernel, which doesnt load with the fallback kernel. So what im really asking is what is the diffences between the two kernels? And how could that be related to my standby problem?

Offline

#3 2009-01-30 14:47:53

jai134
Member
Registered: 2008-11-26
Posts: 234

Re: Wake from standby

Hello. I had problems with that too. When I did remove v86d from the hooks array my computer resumes from suspend without problems again.

Offline

#4 2009-01-30 15:08:51

rassah
Member
Registered: 2009-01-24
Posts: 8

Re: Wake from standby

hmm i dont have v86d in my hooks array, this is what it looks like:

HOOKS="base udev autodetect pata scsi sata keymap filesystems"

*UPDATE*
I tried removing the autodetect hook, and now it wakes from standby, how strange. What could be wrong with the autodetect hook, and what could the consequences be of excluding it in my hook array?

Last edited by rassah (2009-01-30 15:14:47)

Offline

#5 2009-01-30 15:25:11

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Wake from standby

For the sake of clarity, please note that the kernel is the same in both cases. The difference is in the initramfs images - the fallback image is generated without the autodetect hook (as you have already discovered).

Compare lsmod after a normal boot with lsmod after a fallback boot - you will see which modules are loaded in each case.

Offline

#6 2009-01-30 16:30:41

rassah
Member
Registered: 2009-01-24
Posts: 8

Re: Wake from standby

Hello tomk thanks for the clarification.

Ok im a bit confused now. It seems the problem wasnt the initramfs image, since it was still able to wake from standby although i used my normal initramfs image. It seems to actually be random?

Offline

#7 2009-01-31 02:18:40

semperfiguy
Member
Registered: 2007-12-03
Posts: 224

Re: Wake from standby

I am havini the same problem. I can no longer resume from standby. I only get a black screen.

Offline

#8 2009-02-01 17:23:57

xsytry
Member
From: Poznan, Poland
Registered: 2008-07-08
Posts: 21

Re: Wake from standby

I might have good news for you, guys. If you have an nvidia card in your laptop and the problem with suspend/hibernate is kinda recent, you should try nvidia 180.27 drivers. My T61 got the same problem  - went to sleep just fine, but didn't wake up. With new drivers it works again. smile
I got mine from aur, via nvidia-beta.


Do, or do not. There is no try. [Yoda]

Offline

#9 2009-02-01 17:56:26

Zibi1981
Member
From: Poland
Registered: 2008-01-31
Posts: 465

Re: Wake from standby

Well, on my GX600P I have never been successful with making s2RAM work, even on 180.27 sad

Last edited by Zibi1981 (2009-02-01 17:56:39)


"... being a Linux user is sort of like living in a house inhabited by a large family of carpenters and architects. Every morning when you wake up, the house is a little different. Maybe there is a new turret, or some walls have moved. Or perhaps someone has temporarily removed the floor under your bed."

MSI GT75 Titan 8RG

Offline

#10 2009-02-01 21:12:56

Ibex
Member
Registered: 2006-03-02
Posts: 127

Re: Wake from standby

xsytry wrote:

I might have good news for you, guys. If you have an nvidia card in your laptop and the problem with suspend/hibernate is kinda recent, you should try nvidia 180.27 drivers. My T61 got the same problem  - went to sleep just fine, but didn't wake up. With new drivers it works again. smile
I got mine from aur, via nvidia-beta.

Do you know when 180.27 will be in the repo's? I have the same problem smile.

Offline

#11 2009-02-01 21:32:20

xsytry
Member
From: Poznan, Poland
Registered: 2008-07-08
Posts: 21

Re: Wake from standby

Ibex wrote:

Do you know when 180.27 will be in the repo's? I have the same problem smile.

No idea.  If I were you I'd just install it from aur.


Do, or do not. There is no try. [Yoda]

Offline

#12 2009-02-03 11:04:05

ajb
Member
From: Poland
Registered: 2008-02-06
Posts: 31

Re: Wake from standby

I think i have similar issue. But only when computer is a bit longer in sleep state. Always when I'm trying to reach this black screen intentionally, I can't.

Do you have the same? short sleep causes problem to you? or only a bit longer?

Offline

#13 2009-02-03 14:42:26

tuxknight
Member
Registered: 2008-08-02
Posts: 5

Re: Wake from standby

got this page and there will be a solution without removing autodetect hook http://people.freedesktop.org/~hughsient/quirk/ i got it worked and i think i also got the same problem and from help from the pre given site i used this command
#pm-suspend --quirks-dpms-on
* before using this command refer pm-utils wiki (i think you use pm-utils)

Offline

#14 2009-02-14 23:18:33

TheGrudge
Member
Registered: 2006-06-15
Posts: 206
Website

Re: Wake from standby

I have the same problem (but only when X-Server is started), when running in normal console I can use pm-suspend.
I also have a NVIDIA card in my Macbook Pro v4, so I guess it is the graphics driver, too.


digiKam developer - www.digikam.org

Offline

#15 2009-02-19 00:50:27

MarcoRosso
Member
Registered: 2009-02-08
Posts: 49

Re: Wake from standby

I got this to work by turning off the autodetect in HOOKS as well. This a quick workaround. The wiki describes how to redo the kernel hooks and does a good job in doing it too. As well, there is a few benefits to disabling it; such as hard drives that are USB are mounted on boot big_smile. The only disadvantage that I found is that it takes a little bit longer to boot the system.

Updated Wiki accordingly.

Last edited by MarcoRosso (2009-02-19 01:01:13)

Offline

#16 2009-02-19 20:32:15

na12
Member
From: /home/serbia
Registered: 2008-12-23
Posts: 752

Re: Wake from standby

ajb wrote:

I think i have similar issue. But only when computer is a bit longer in sleep state. Always when I'm trying to reach this black screen intentionally, I can't.

Do you have the same? short sleep causes problem to you? or only a bit longer?

same problem,but I have ATI card

Offline

#17 2009-02-19 21:09:29

fwojciec
Member
Registered: 2007-05-20
Posts: 1,411

Re: Wake from standby

MarcoRosso wrote:

I got this to work by turning off the autodetect in HOOKS as well. This a quick workaround. The wiki describes how to redo the kernel hooks and does a good job in doing it too. As well, there is a few benefits to disabling it; such as hard drives that are USB are mounted on boot big_smile. The only disadvantage that I found is that it takes a little bit longer to boot the system.

Updated Wiki accordingly.

What you did, basically, is turn your regular image into the fallback image.  The only difference between fallback and regular boot images is that fallback is generated with autodetect hook disabled.

Offline

#18 2009-02-20 00:43:10

MarcoRosso
Member
Registered: 2009-02-08
Posts: 49

Re: Wake from standby

For a quick workaround this works, or seems to for me. Is there any issues with doing this? System performance, etc?

Offline

#19 2009-03-15 13:36:43

cywhale
Member
Registered: 2008-03-10
Posts: 31

Re: Wake from standby

Thank you very much for this thread and the provided workaround - ran into this issue myself and removing 'autodetect' worked fine, too.

The last question here has not been answered yet - are there any serious disadvantages in disabling the 'autodetect' hook?

Offline

#20 2009-03-17 01:48:52

semperfiguy
Member
Registered: 2007-12-03
Posts: 224

Re: Wake from standby

I am having the same problem with pm-suspend. I even removed the autodetect hook from mkinitcpio.conf and I still get the same problem. blank screen, no hard drive activity at all. Any suggestions?

Offline

#21 2010-02-22 19:00:36

vitoreiji
Member
Registered: 2009-09-04
Posts: 67

Re: Wake from standby

semperfiguy wrote:

I am having the same problem with pm-suspend. I even removed the autodetect hook from mkinitcpio.conf and I still get the same problem. blank screen, no hard drive activity at all. Any suggestions?

Are you sure you built the kernel image, ie you ran mkinitcpio -p kernel26?

Offline

#22 2010-02-22 19:01:50

vitoreiji
Member
Registered: 2009-09-04
Posts: 67

Re: Wake from standby

cywhale wrote:

The last question here has not been answered yet - are there any serious disadvantages in disabling the 'autodetect' hook?

No, but you do lose some performance on boot time.

Offline

#23 2010-02-22 20:44:42

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Wake from standby

vitoreiji - please don't post in old threads. Full details here. Have a look at the rest of the forum guidelines as well.

Closing.

Offline

Board footer

Powered by FluxBB