You are not logged in.

#1 2009-02-04 00:31:12

Spelchek
Member
Registered: 2009-01-27
Posts: 22

[SOLVED ]LXpanel keeps flashing rapidly in LXDE

I finally got Xorg and LXDE to work thanks to the help of the people in my last thread here. However, I have now ran into a different more annoying problem.
NOTE: This occured in a FRESH install of LXDE I have not made any modifications whatsoever.
When I run startx I can quickly get into LXDE and it looks quite nice. One thing I notice is that my LXpanel has two missing icons on the left hand side of the screen. There is the Computer icon, which opens the menu, the two missing icons, and then the show desktop icon. I click on the computer icon, the first time I got into LXDE it showed a menu and looked fine. The second time there was no menu, only a little white square. The major problem I now have occurred when I clicked on one of the two black icons. The LXpanel started flashing uncontrollably. Nothing I did, restarting X, rebooting the computer has solved this. When I run startx it brings me to LXDE with a VERY annoying flashing LXpanel.

TL;DR LXpanel is flashing uncontrollably on a fresh install of LXDE, it persists even if the computer is rebooted. There is also no menu when I click on the menu icon.
Any help on deciding my next course of action would be greatly appreciated.

Last edited by Spelchek (2009-02-05 01:38:15)

Offline

#2 2009-02-04 00:40:47

FunkNapkin
Member
From: Québec, Canada
Registered: 2009-01-19
Posts: 21

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I have the same problem on a fresh install, but I have more details. You could test to see if I'm talking about the same issue.
When I boot in LXDE without being connected to a network, everything works fine. The moment I connect to a network, the pannel flashes really fast and stops after a loooong time.
Hope this helps resolves the issue.
Also, if someone could tell me how to remove/disable the LXNM, I'd see if it solves the issue. I'm don't use it anyway and when I hover the mouse over it once it stops flashing, it shows strange information. I'm not on AL right now, so I can't say more about this.

Last edited by FunkNapkin (2009-02-04 00:57:39)


Arch64, Openbox & Awesome3

Offline

#3 2009-02-04 02:21:42

Spelchek
Member
Registered: 2009-01-27
Posts: 22

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I am also wondering if I could possibly reinstall LXpanel and what would be the safest way to do this without interfering with the rest of LXDE.

Offline

#4 2009-02-04 02:38:11

flowheat
Member
From: Pittsburgh, PA
Registered: 2008-09-23
Posts: 94

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I had this problem as well.  It is definitely the network plugin.  You can remove the code from the panel file.  If you're using a fresh install then lxpanel is booted with the -profile LXDE argument so you'll want to edit the file ~/.config/lxpanel/LXDE/panels/panel and comment out the section for the network manager.

Offline

#5 2009-02-04 02:56:54

Spelchek
Member
Registered: 2009-01-27
Posts: 22

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I have some interesting and potentially useful information on the problem I'm experiencing (I'm pretty sure mine doesn't have to do with the network manager)
I can run lxpanel in xterm and it works perfectly; however, the output contains some error messages.

(process:5703): Gtk=WARNING **: Locale not supported by C library.
Using the fall back 'C' locale.
** (lxpanel:5703): DEBUG: cache file_name = /home/user/.cache/menus/953ce9b7f6cb671d9ed9525c92e254f
lxpanel:X error: BadAlloc (insufficient resources for operation)
lxpanel: X error: BadDrawable (invalid Pixmap or Window parameter)
lxpanel: X error: BadPixmap (invalid Pixmap parameter)

I am pretty sure my computer can handle lxde since it can handle ubuntu 8.04 with gnome and I think my locale is just USA.

Offline

#6 2009-02-04 03:07:08

flowheat
Member
From: Pittsburgh, PA
Registered: 2008-09-23
Posts: 94

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

Mine gives the exact same errors on startup but otherwise behaves normally.  When I researched into what was causing those errors I didn't come across any solutions and since everything appears to work ok I'm just living with them for now.  LXDE just released beta2 of lxpanel 0.4.0 a few days ago.  I'm going to go ahead and take a look at that now.

http://blog.lxde.org/?p=205

Edit:

Wrong URL

Last edited by flowheat (2009-02-04 03:11:08)

Offline

#7 2009-02-04 03:23:59

Spelchek
Member
Registered: 2009-01-27
Posts: 22

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

Since we seem to be having the same problem, tell me how it works out for you. Also if I decide to try it out and want to go back to 3.11 can I just reinstall lxpanel via pacman and have it work and keep all the config settings?
Hope the beta is good.

Offline

#8 2009-02-04 04:15:46

Ronin-Sage
Member
Registered: 2008-10-24
Posts: 153
Website

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

Yeah, same thing used to happen to me...I forget how I resolved it :\

On a similar note, anyone experience the issue where the "start menu" doesn't open properly? It's never consistent(and seemingly random), but what happens is I'll log into a LXDE session and clicking the main menu button does almost nothing(save for the appearance of a small, grey box near the button, as if the menu was shrunk). Logging out and logging back in fixes it, but it's quite...well, embarrassing to have it happen as often as it does.

Offline

#9 2009-02-05 01:37:54

Spelchek
Member
Registered: 2009-01-27
Posts: 22

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I believe I have resolved the problem.
I edited the autostart file /etc/xdg/lxsession/LXDE/autostart
and changed the line
@lxpanel --profile *some other stuff*
to just
@lxpanel
Now when I login my lxpanel no longer flashes!

Offline

#10 2009-02-05 02:18:59

flowheat
Member
From: Pittsburgh, PA
Registered: 2008-09-23
Posts: 94

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

That's good news. 

If you run lxpanel from xterm do you still get the errors you posted earlier?

Offline

#11 2009-02-05 03:52:08

Spelchek
Member
Registered: 2009-01-27
Posts: 22

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

Yeah, I still do get those errors. I think it may have been a problem with the "profile" LXpanel was using.

Offline

#12 2009-02-08 10:30:47

tconnor9
Member
From: Townsville - Queensland
Registered: 2009-02-03
Posts: 5

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

flowheat wrote:

Mine gives the exact same errors on startup but otherwise behaves normally.  When I researched into what was causing those errors I didn't come across any solutions and since everything appears to work ok I'm just living with them for now.  LXDE just released beta2 of lxpanel 0.4.0 a few days ago.  I'm going to go ahead and take a look at that now.

http://blog.lxde.org/?p=205

Edit:

Wrong URL

Hi All,

I have tried the lxpanel beta (0.4.0) it does not correct the issue of the flashing panel.

i had changed the profile, this worked for a while but the problem began occuring again when i re-booted after adding an application launcher to the panel. Can anybody else confirm that they had indeed added an application to the panel before this error?

Offline

#13 2009-02-09 16:54:54

souls-seb
Member
Registered: 2006-09-30
Posts: 26

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

In ~/.config/lxde (I think it is), there's an 'LXDE' folder and a 'default' folder. When lxpanel flashes, it uses the 'default' profile, which in my case contained an invalid configuration and caused lxpanel to crash.
This fixed it for me:

cd ~/.config/lxde/
rm -r default
ln -s LXDE/ default

Offline

#14 2009-02-27 18:23:07

Hazuki
Member
From: Madison, WI
Registered: 2008-01-09
Posts: 13

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I'm getting this same error after following the above steps. From XTerm it says:

** (lxpanel:11020): DEBUG: cache file_name = /home/hazuki/.cache/menus/3367bf1757488ddf531ee82d6f5fa812
lxpanel : type is not XA_CARDINALlxpanel : type is not XA_CARDINALSegmentation fault

This happens with the lxpanel in the repos and from ABS, both the 0.3.9999 version.

Offline

#15 2009-02-27 18:27:15

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

symlinking 'default' to 'LXDE' only lasted through a few boots for me, then lxpanel simply broke with anything other than the global profile. I'm not sure if anything in LXDE right now is working properly.

Offline

#16 2009-02-27 19:19:06

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

There's hope, not every installation of LXDE produces these problems. My lxpanel hasn't ever blinked ... The only issue I have with it is, that sometimes it crashes, when I close pidgin, but it reloads automatically, so it's no big deal. My ~/.config/lxpanel/LXDE/panels/panel looks like this

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

Global {
    edge=top
    allign=center
    margin=0
    widthtype=percent
    width=100
    height=25
    transparent=1
    tintcolor=#000000
    alpha=0
    setdocktype=1
    setpartialstrut=1
    usefontcolor=1
    fontcolor=#ffffff
    background=0
    backgroundfile=/usr/share/lxpanel/images/background.png
}

Plugin {
    type = menu
    Config {
        image=/usr/share/archlinux/wmlogos/archlinux-wm-openbox.svg
        system {
        }
        separator {
        }
        item {
            command=run
        }
        separator {
        }
        item {
            image=gnome-logout
            command=logout
        }
    }
}

Plugin {
    type = taskbar
    expand=1
    Config {
        tooltips=1
        IconsOnly=0
        AcceptSkipPager=1
        ShowIconified=1
        ShowMapped=1
        ShowAllDesks=0
        UseMouseWheel=1
        UseUrgencyHint=1
        FlatButton=0
        MaxTaskWidth=150
        spacing=1
    }
}

Plugin {
    type = tray
}

Plugin {
    type = dclock
    Config {
        ClockFmt=%R
        TooltipFmt=%A %x
        BoldFont=0
    }
}

What else information can I give?

Last edited by Army (2009-02-27 19:19:49)

Offline

#17 2009-02-27 19:27:24

tjtag
Member
From: Odessa, Ukraine
Registered: 2009-02-21
Posts: 5

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

@skottish,
This is what I did to get rid of the flashing lxxpanel,  and this fix isn't for everyone, could you verify this and see if it fixes it for you ?

edit the PKGBUILD for lxpanel

edit  configure to match this, we are removing the netstatus plugin, that solved it for me, make sure to add the \ "  --prefix=/usr \"

source=(http://downloads.sourceforge.net/sourceforge/lxde/${pkgname}-${pkgver}.tar.gz)
md5sums=('ba966c76811f2057198470567099d97d')
build() {
    cd "$srcdir/$pkgname-$pkgver"
    ./configure --sysconfdir=/etc --prefix=/usr \
    --with-plugins=netstat,volume,volumealsa,cpu,deskno,batt,kbled,xkb,thermal || return 1
    make || return 1
    make DESTDIR="$pkgdir" install || return 1

Offline

#18 2009-02-27 19:44:51

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

Thanks tjtag. The flashing panel took about 10 seconds for me to fix thanks to the community here. It was the fact that it was reverting or ignoring configuration files no matter what I tried, or completely crashing. I went rounds with it for hours before I gave up. The computer that this was installed on isn't in my possession, so alpha-quality software is out of the question.

Offline

#19 2009-05-02 09:39:49

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

tjtag wrote:

--with-plugins=netstat,volume,volumealsa,cpu,deskno,batt,kbled,xkb,thermal || return 1

In my case I've got this message when building package lxpanel-svn:

Building dynamic plugins:
    volumealsa - Display and adjust volume of sound card for ALSA
    cpu - Display CPU loading
    deskno - Display desktop number
    batt - Monitor battery status
    kbled - Indicator for CapsLock, NumLock, and ScrLock
    xkb - Keyboard layout switcher
    thermal - Temperature monitor

so netstat plugin wasn't built. I had to change config line to

  ./configure --prefix=/usr \
          --sysconfdir=/etc \
          --localstatedir=/var \
          --disable-static \
          --with-plugins=xkb,netstat,volumealsa,cpu,deskno,batt,kbled,thermal \
          --enable-libiw || return 1

Now you can make netstat plugin. Enabling libiw do a trick.

Last edited by knedlyk (2009-05-02 10:03:58)

Offline

#20 2009-05-17 08:53:52

yellowtrolley
Member
Registered: 2009-05-17
Posts: 4

Re: [SOLVED ]LXpanel keeps flashing rapidly in LXDE

I get lxpannel flashing only when Eterm is running. I can't find any trace in the logs files.

Offline

Board footer

Powered by FluxBB