You are not logged in.

#1 2004-08-29 09:23:45

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 351

Erroe when compile parted 1.6.12

exception.c:72: warning: conflicting types for built-in function 'log2'
make[3]: *** [exception.lo] Error 1
make[3]: Leaving directory `/mnt/storage/cache/abs/local/parted/src/parted-1.6.12/libparted'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/storage/cache/abs/local/parted/src/parted-1.6.12/libparted'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/storage/cache/abs/local/parted/src/parted-1.6.12'
make: *** [all] Error 2
==> ERROR: Build Failed.  Aborting...

I wanna get gparted, so I have to compile latest parted tarball for it, but when I compiled parted 1.6.12, I got the above error message. I am using the same pkgbuild as official old one. Anyone can help me? Thanks in advance.

Offline

#2 2018-01-10 13:14:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,075

Re: Erroe when compile parted 1.6.12

gparted in repos is at 0.30-2 , and that appears to be latest version.
parted itself is at version 3.2 and th eoldest version i could find is 1.6.25 from 2005 .

Where did you find this "latest parted tarball" with version 1.6.12 ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-01-10 13:29:00

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,983
Website

Re: Erroe when compile parted 1.6.12

2004. I'm afraid you've fallen for the bait in this thread. tongue

Mod note: Closing as per https://wiki.archlinux.org/index.php/Co … bumping.22


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB