You are not logged in.

#1 2009-02-13 00:11:49

Aidas
Member
Registered: 2009-02-12
Posts: 3

Dell Latitude E6400 internal mic not working

I've got Latitude E6400 with ICH9 Intel HDA Audio (using 'snd_hda_intel').

Everything related to audio work fine (including external mic), but I coudn't manage to get my internal mic working. But the internal mic works fine in Windows.

I have have been playing with alsamixer a lot, but nothing seems to help.

I use latest alsa 1.0.19 and kernel 2.6.28 from official repos.


Any help highly appreciated.

Offline

#2 2009-02-13 01:16:27

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: Dell Latitude E6400 internal mic not working

I don't know whether this will help ya, but I've got an Inspiron 6400 with ICH7 audio and here's what I do to get the microphone working:

Add to /etc/modprobe.conf:

options snd-hda-intel model=ref

Reboot
Open alsamixer
Press TAB to show all devices, press SPACE on capture to show L/R channels, set VOLS to 50-60%

Last edited by thayer (2009-02-13 01:17:08)


thayer williams ~ cinderwick.ca

Offline

#3 2009-02-13 01:18:03

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: Dell Latitude E6400 internal mic not working

This may work as well:

options snd-hda-intel model=dell-m25

thayer williams ~ cinderwick.ca

Offline

#4 2009-02-13 10:27:13

Aidas
Member
Registered: 2009-02-12
Posts: 3

Re: Dell Latitude E6400 internal mic not working

I tried these two and also "dell-m4-1".

With "dell-m4-1" and "dell-m25" there was no difference and with "ref" sound was not working at all. sad

Are there any Latitude E6400/E6500 archers who got internal mic working?

Offline

#5 2009-02-15 13:27:22

raf_kig
Member
Registered: 2008-11-28
Posts: 143

Re: Dell Latitude E6400 internal mic not working

I guess you won't be lucky, im on 2.6.29 rc4 now and the sound card is still only partially supported

1) the volume levels are to low
2) dock line-in/line-out won't work (they used to with 2.6.27 and model=ref)
3) the internal mic isn't working

There are still (several?) open bugs on the kernel bugtrack regarding this device, sit and wait or fix it yourself seem to be the only options ;-)

regards

raf

Offline

#6 2009-02-15 14:22:10

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,026

Re: Dell Latitude E6400 internal mic not working

To use the internal mic maybe you will have to fiddle with mic boost.
Usually for external mics you don't need to use it (and you set it to the minimum) but for internal mics usually you need to raise it at least half way if not all.
At least from my limited experience its usually like that. Also don't for get to change the input source to internal mic.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#7 2009-02-16 08:41:53

w1rele55
Member
Registered: 2007-06-23
Posts: 17

Re: Dell Latitude E6400 internal mic not working

Hi.
I have E6500 model (bios A11) and also on latest versions (alsa 1.0.19 & kernel 2.6.28.5) int mic does not work

BUT
with 2.6.27.10 and 1.0.18a I have in alsamixer swith ('Digital Input Source',0) in playback with 2 modes:
'Digital Mic 1' (int mic) and 'Analog Inputs' (ext mic)
It did work!
I did not use also any model option in modprobe.conf

I am wonder why it is broken with 2.6.28 kernels sad

Maybe wee need to patch as it claims gentoo wiki:
http://en.gentoo-wiki.com/wiki/Dell_Lat … 6x00#Audio

My NOT working (int mic) configuration
http://www.alsa-project.org/db/?f=d9669 … b2b5bad939

Last edited by w1rele55 (2009-02-16 08:54:23)

Offline

#8 2009-02-18 15:14:21

loudtiger
Member
Registered: 2009-01-08
Posts: 68

Re: Dell Latitude E6400 internal mic not working

does anyone also get the "pop" on suspend? this stuff used to work for me in 2.6.27 with 1.0.18 alsa. 2.6.28 with 1.0.18 alsa is broken, and so is 1.0.19.

Offline

#9 2009-02-18 17:17:18

anrxc
Member
From: Croatia
Registered: 2008-03-22
Posts: 833
Website

Re: Dell Latitude E6400 internal mic not working

I saw a bug report for that, apparently sound card power management is to blame (if it's enabled it will "pop"). A fix is expected...


You need to install an RTFM interface.

Offline

#10 2009-03-01 15:20:10

w1rele55
Member
Registered: 2007-06-23
Posts: 17

Re: Dell Latitude E6400 internal mic not working

Thx to nice wiki  http://en.gentoo-wiki.com/wiki/Dell_Latitude_E6x00 I have FIXED mics problem:

I am currently up2date with arch:

kernel26 2.6.28.7-1
alsa-lib 1.0.19-1
alsa-utils 1.0.19-1

HOWTO FIX:

mkdir -p abs/alsa-driver
cd alsa-driver
create PKGBUILD file:

pkgname=alsa-driver
pkgver=1.0.19
pkgrel=1
pkgdesc="Alsa kernel drivers"
arch=(i686)
url="http://alsa-project.org/"
license=('GPL')
groups=()
depends=('kernel26>2.6.28.1')
makedepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
backup=()
options=()
install=alsa-driver.install
source=("ftp://ftp.alsa-project.org/pub/driver/$pkgname-$pkgver.tar.bz2" dell-e6x00.patch)
noextract=()

build() {
  cd "$srcdir/$pkgname-$pkgver"
  ./configure --with-cards=hda-intel --with-sequencer=yes 
  patch -p1 < ../dell-e6x00.patch || return 1
  make || return 1
  make DESTDIR=$pkgdir install || return 1
  rm -rf $pkgdir/usr
  mv "$pkgdir/lib/modules/`uname -r`/kernel/sound" "$pkgdir/lib/modules/`uname -r`/kernel/$pkgname"
}

# vim:set ts=2 sw=2 et:

create e6x00.patch file:

diff --git a/alsa-kernel/pci/hda/patch_sigmatel.c b/alsa-kernel/pci/hda/patch_sigmatel.c
index a4d4afe..7678bf3 100644
--- a/alsa-kernel/pci/hda/patch_sigmatel.c
+++ b/alsa-kernel/pci/hda/patch_sigmatel.c
@@ -4963,7 +4963,7 @@ again:
     case STAC_DELL_M4_3:
         spec->num_dmics = 1;
         spec->num_smuxes = 0;
-        spec->num_dmuxes = 0;
+        spec->num_dmuxes = 1;
         break;
     default:
         spec->num_dmics = STAC92HD71BXX_NUM_DMICS;

create alsa-driver.install file:

post_install() {
  KERNEL_VERSION='2.6.28-ARCH'
  
  mv /lib/modules/$KERNEL_VERSION/kernel/sound /lib/modules/$KERNEL_VERSION/kernel/sound.orig
  ln -s /lib/modules/$KERNEL_VERSION/kernel/alsa-kenel /lib/modules/$KERNEL_VERSION/kernel/sound
  
  depmod $KERNEL_VERSION
}

post_remove() {
  KERNEL_VERSION='2.6.28-ARCH'
  rm /lib/modules/$KERNEL_VERSION/kernel/sound
  mv /lib/modules/$KERNEL_VERSION/kernel/sound.orig /lib/modules/$KERNEL_VERSION/kernel/sound
  
  depmod $KERNEL_VERSION
}

makepkg

sudo pacman -U alsa-driver-1.0.19-1-i686.pkg.tar.gz

/etc/modprobe.conf :

#
# /etc/modprobe.conf (for v2.6 kernels)
#
options snd-hda-intel model=dell-m4-1

sudo reboot

run alsamixer and you see 'Digital Input Source' switch back again!

Simple mixer control 'Digital Input Source',0
  Capabilities: enum
  Items: 'Analog Inputs' 'Mixer' 'Digital Mic 1'
  Item0: 'Digital Mic 1'

3 Items ext, int and mix of ext and int mic inputs
Works ok on e6500. Should work on e6400 too.

Enjoy.

Offline

#11 2009-03-01 20:31:44

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

Re: Dell Latitude E6400 internal mic not working

With OSSv4 builtin mic works by default (just have to switch output channels in ossxmix to digmic-1)
Tested on Dell Inspiron 1525 n.


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#12 2009-07-04 06:48:54

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Dell Latitude E6400 internal mic not working

I'd like to state that with current Arch Linux for Dell Studio 17 S1737-O2OB/020B, all that's needed is to add options snd-hda-intel model=dell-m4-1 to /etc/modprobe.conf, rmmod and modprobe, and then you can select the capture source and it works fine. I hope this gets detected automatically soon -- I've never had an intel-hda laptop that had an internal mic work out of the box.

Offline

Board footer

Powered by FluxBB