You are not logged in.

#1 2004-09-03 06:35:04

cereal
Member
From: Switzerland
Registered: 2004-08-29
Posts: 29
Website

jackd: weird startup problem (crosspost...)

Hello there

(Already postet this in the Newbie Corner, but I was told, that I should try it here in Package Configuration Problems)

Well... I've got several problems concerning the jack-audio-connection-kit. Most of them, I think, are Hardware- or Kernel-Configuration specific, so I think I'm gonna post them elsewhere...

The one problem, I think, that *may be* arch-specific is, that everytime I boot my box, it says something like:

:: Starting Jack Audio Connection-Kit Daemon [DONE]
/etc/rc.d/jack-audio-connection-kit: line 11: 1159 Aborted
/usr/bin/jackd $SERVER_PARAMS -d $DRIVER_PARAMS &>/dev/null

So... I redirected output of jackd and what it says is:

jackd 0.98.1
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|8|48000|0|0|nomon|swmeter|-|32bit
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such file or directory
jackd: pcm.c:690: snd_pcm_nonblock: Assertion `pcm' failed.

The funny thing is, that, when I start jack later on (either using the startup script or manually), jack doesn't fail (at least not at this point... but that's another story). I also looked for this /dev/snd/pcmC0D0p device and at least when the system is up and running, this device exists. The startup-script of the jack-audio-connection-kit is the last rc-script, that runs, right after the alsamixer-script restores the volumes (and that worked flawlessly).

So... anyone got an idea of what may cause this problem?

Thanks in advance...


"I watched a snail crawl along the edge of a straight razor. That's my dream. That's my nightmare." - (Kurtz, Apocalypse Now)

A few PKGBUILDs

Offline

#2 2004-09-03 07:47:15

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: jackd: weird startup problem (crosspost...)

hw:0|hw:0|1024|8|48000|0|0|nomon|swmeter|-|32bit

... only a guess: do your soundchip support 48kHz?

grüesslis us basel


The impossible missions are the only ones which succeed.

Offline

#3 2004-09-03 12:27:34

cereal
Member
From: Switzerland
Registered: 2004-08-29
Posts: 29
Website

Re: jackd: weird startup problem (crosspost...)

Uhm... I suppose if it supports up to 96kHz; it should also be able to support 48kHz... (?) And I already said, that, when I login and start jackd manually with the same parameters as in the startup script, it wouldn't fail.

(dp: au ä Gruess us Basel:))


"I watched a snail crawl along the edge of a straight razor. That's my dream. That's my nightmare." - (Kurtz, Apocalypse Now)

A few PKGBUILDs

Offline

Board footer

Powered by FluxBB